Results 1 to 7 of 7
  1. #1


    Member Since
    Nov 28, 2008
    Posts
    5
    Snow leopard is corrupt. Help please!
    ok so I've been having startup issues with my macbook pro a1211 and I'm running snow leopard and when I run disk utility I got errors that can't be repaired. And I have been backing up my HD to an external using carbon copy cloner.

    Now to the fun part, my computer crashed last night so I did a clean install of SL and tried to move over my user and library etc. from my external. The problem is that I don't wan to do an identical copy of my external because it has the same problems as my original HD. I tried to bring just copy exactly what i needed but I've been through it 1000 times and thought I got everything, then i tried to open certain applications like iphoto and it crashes on startup I have no clue what to do right now to copy over everything correctly. Like is there any archive and install for snow leopard like in earlier versions of osx or is there something else I can do to ensure all of my application stuff is transfered correctly?

    Thanks

  2. #2

    Lifeisabeach's Avatar
    Member Since
    Sep 30, 2007
    Location
    The Republic of Neptune
    Posts
    7,754
    Quote Originally Posted by jude1234 View Post
    ok so I've been having startup issues with my macbook pro a1211 and I'm running snow leopard and when I run disk utility I got errors that can't be repaired. And I have been backing up my HD to an external using carbon copy cloner.

    <snip>
    Exactly what errors are you getting with Disk Utility? And what are these startup issues that you are referring to? If your hard drive is crashing, then the files you are copying to the backup may be corrupt.

  3. #3

    harryb2448's Avatar
    Member Since
    Nov 28, 2007
    Location
    Nambucca Heads Australia
    Posts
    22,101
    Specs:
    Imac 27" Retina 5K, 512GB flash memory, 3.3GHz, 16GB memory, macOS Sierra beta.
    Sure sounds like it is a time for a new hard drive, format from SL disk and do a clean install. And of course all you are doing is copying problems over. You can try to correct by inserting the SL disk, and running install from there and see if there is any joy. The update to OS X.6.8 using the combo updater.
    Hang on to those original install discs like grim death! Using OS X.7 or later make a bootable USB thumb drive before running Installer!

  4. #4


    Member Since
    Nov 28, 2008
    Posts
    5
    I don't have the exact disk utility errors since they were on my old drive but they were like Warning: SUID file "System/Library/CoreServices/RemoteManagement/ARDAgent.app/Contents/MacOS/ARDAgent" has been modified and will not be repaired." except for there were more that couldn't be repaired ARDAgent is the only that i remember.

    but I'm running verify permissions now to post them soon.

    Startup problems i was having was that when i would turn on the computer everything would work except for the screen and also when i woke it from sleep my password screen would appear for a second then disappear or wouldn't show up at all so i thought it was a SMC problem but after doing a clean install of SL those problems don't happen except for during startup the blue screen between the grey logo and account login screen takes a very long time.

    I know I'm just copying problems over but most of the problems were mainly in like the system library I did a clean SL install and originally used Carbon copy cloner to just copy my user, applications, & data e.i. music,photos,video. And my applications weren't working correctly and it seemed as if it was because I didn't copy over things like frameworks so I did and still can't open a lot of apps like iphoto so basically I want to try and copy applications, preferences, and media but with a good file system unlike the bad one that i had on my previous SL install and have on my external

  5. #5


    Member Since
    Nov 28, 2008
    Posts
    5
    Quote Originally Posted by jude1234 View Post
    I don't have the exact disk utility errors since they were on my old drive but they were like Warning: SUID file "System/Library/CoreServices/RemoteManagement/ARDAgent.app/Contents/MacOS/ARDAgent" has been modified and will not be repaired." except for there were more that couldn't be repaired ARDAgent is the only that i remember.

    but I'm running verify permissions now to post them soon.

    Startup problems i was having was that when i would turn on the computer everything would work except for the screen and also when i woke it from sleep my password screen would appear for a second then disappear or wouldn't show up at all so i thought it was a SMC problem but after doing a clean install of SL those problems don't happen except for during startup the blue screen between the grey logo and account login screen takes a very long time.

    I know I'm just copying problems over but most of the problems were mainly in like the system library I did a clean SL install and originally used Carbon copy cloner to just copy my user, applications, & data e.i. music,photos,video. And my applications weren't working correctly and it seemed as if it was because I didn't copy over things like frameworks so I did and still can't open a lot of apps like iphoto so basically I want to try and copy applications, preferences, and media but with a good file system unlike the bad one that i had on my previous SL install and have on my external
    last permissions run

    Verify permissions for “Macintosh HD”
    Warning: SUID file "Applications/Utilities/Keychain Access.app/Contents/Resources/kcproxy" has been modified and will not be repaired.
    Stopped by user

    Permissions verification complete

    Repairing permissions for “Macintosh HD”
    Warning: SUID file "Applications/Utilities/Keychain Access.app/Contents/Resources/kcproxy" has been modified and will not be repaired.
    Permissions differ on "System/Library/Frameworks/JavaVM.framework/Versions/1.6.0/Classes/dt.jar", should be -rw-r--r-- , they are lrwxr-xr-x .
    Repaired "System/Library/Frameworks/JavaVM.framework/Versions/1.6.0/Classes/dt.jar".
    Permissions differ on "System/Library/Frameworks/JavaVM.framework/Versions/1.6.0/Classes/jce.jar", should be -rw-r--r-- , they are lrwxr-xr-x .
    Repaired "System/Library/Frameworks/JavaVM.framework/Versions/1.6.0/Classes/jce.jar".
    Permissions differ on "System/Library/Frameworks/JavaVM.framework/Versions/1.6.0/Classes/jconsole.jar", should be -rw-r--r-- , they are lrwxr-xr-x .
    Repaired "System/Library/Frameworks/JavaVM.framework/Versions/1.6.0/Classes/jconsole.jar".
    Permissions differ on "System/Library/Frameworks/JavaVM.framework/Versions/1.6.0/Classes/management-agent.jar", should be -rw-r--r-- , they are lrwxr-xr-x .
    Repaired "System/Library/Frameworks/JavaVM.framework/Versions/1.6.0/Classes/management-agent.jar".
    User differs on "System/Library/Frameworks/JavaVM.framework/Versions/1.6.0/Home/lib", should be 95, user is 0.
    Repaired "System/Library/Frameworks/JavaVM.framework/Versions/1.6.0/Home/lib".
    Permissions differ on "System/Library/Frameworks/JavaVM.framework/Versions/1.6.0/Home/lib/dt.jar", should be lrwxr-xr-x , they are -rw-r--r-- .
    Repaired "System/Library/Frameworks/JavaVM.framework/Versions/1.6.0/Home/lib/dt.jar".
    Permissions differ on "System/Library/Frameworks/JavaVM.framework/Versions/1.6.0/Home/lib/jce.jar", should be lrwxr-xr-x , they are -rw-r--r-- .
    Repaired "System/Library/Frameworks/JavaVM.framework/Versions/1.6.0/Home/lib/jce.jar".
    Permissions differ on "System/Library/Frameworks/JavaVM.framework/Versions/1.6.0/Home/lib/management-agent.jar", should be lrwxr-xr-x , they are -rw-r--r-- .
    Repaired "System/Library/Frameworks/JavaVM.framework/Versions/1.6.0/Home/lib/management-agent.jar".
    Permissions differ on "System/Library/Frameworks/JavaVM.framework/Versions/1.6.0/Home/lib/security/blacklist", should be -rw-r--r-- , they are lrwxr-xr-x .
    Repaired "System/Library/Frameworks/JavaVM.framework/Versions/1.6.0/Home/lib/security/blacklist".
    User differs on "System/Library/Frameworks/JavaVM.framework/Versions/1.6.0/Libraries", should be 95, user is 0.
    Repaired "System/Library/Frameworks/JavaVM.framework/Versions/1.6.0/Libraries".
    Permissions differ on "System/Library/Frameworks/JavaVM.framework/Versions/1.6.0/Resources/JavaPluginCocoa.bundle", should be drwxr-xr-x , they are lrwxr-xr-x .
    Repaired "System/Library/Frameworks/JavaVM.framework/Versions/1.6.0/Resources/JavaPluginCocoa.bundle".
    Permissions differ on "System/Library/Frameworks/JavaVM.framework/Versions/1.6.0/Resources/JavaPluginCocoa.bundle/Contents/Resources/Java/deploy.jar", should be -rw-r--r-- , they are lrwxr-xr-x .
    Repaired "System/Library/Frameworks/JavaVM.framework/Versions/1.6.0/Resources/JavaPluginCocoa.bundle/Contents/Resources/Java/deploy.jar".
    Permissions differ on "System/Library/Frameworks/JavaVM.framework/Versions/1.6.0/Resources/JavaPluginCocoa.bundle/Contents/Resources/Java/libdeploy.jnilib", should be -rwxr-xr-x , they are lrwxr-xr-x .
    Repaired "System/Library/Frameworks/JavaVM.framework/Versions/1.6.0/Resources/JavaPluginCocoa.bundle/Contents/Resources/Java/libdeploy.jnilib".
    Permissions differ on "System/Library/Frameworks/JavaVM.framework/Versions/A/Resources/Deploy.bundle/Contents/Home/lib/security/cacerts", should be -rw-r--r-- , they are lrwxr-xr-x .
    Repaired "System/Library/Frameworks/JavaVM.framework/Versions/A/Resources/Deploy.bundle/Contents/Home/lib/security/cacerts".
    Permissions differ on "System/Library/Frameworks/JavaVM.framework/Versions/A/Resources/Deploy.bundle/Contents/Resources/Java/deploy.jar", should be -rw-r--r-- , they are lrwxr-xr-x .
    Repaired "System/Library/Frameworks/JavaVM.framework/Versions/A/Resources/Deploy.bundle/Contents/Resources/Java/deploy.jar".
    Permissions differ on "System/Library/Frameworks/JavaVM.framework/Versions/A/Resources/Deploy.bundle/Contents/Resources/Java/libdeploy.jnilib", should be -rwxr-xr-x , they are lrwxr-xr-x .
    Repaired "System/Library/Frameworks/JavaVM.framework/Versions/A/Resources/Deploy.bundle/Contents/Resources/Java/libdeploy.jnilib".
    Warning: SUID file "System/Library/CoreServices/RemoteManagement/ARDAgent.app/Contents/MacOS/ARDAgent" has been modified and will not be repaired.

    Permissions repair complete

  6. #6

    harryb2448's Avatar
    Member Since
    Nov 28, 2007
    Location
    Nambucca Heads Australia
    Posts
    22,101
    Specs:
    Imac 27" Retina 5K, 512GB flash memory, 3.3GHz, 16GB memory, macOS Sierra beta.
    All is okay do not worry about that lot.

    http://support.apple.com/kb/TS1448

    If they really worry you just de-select the Show Details button.
    Hang on to those original install discs like grim death! Using OS X.7 or later make a bootable USB thumb drive before running Installer!

  7. #7

    bobtomay's Avatar
    Member Since
    Dec 22, 2006
    Location
    Texas, where else?
    Posts
    26,484
    Specs:
    15" MBP '06 2.33 C2D 4GB 10.7; 13" MBA '14 1.8 i7 8GB 10.11; 21" iMac '13 2.9 i5 8GB 10.11; 6S
    Permissions not repaired is normal and Apple has a long list of them that should be ignored. The list is sooooo long, that I have ignored all permissions that don't get repaired for about 3 years now. A reinstall is not necessary nor required for this. See the link harryb posted above.

    You'll not be able to drag and drop any application that has it's own installer from one system to another and expect for it to work.

    If the only issue you have is one of permissions not being repaired, boot to your CCC backup and clone it back to your internal drive. There is nothing wrong.

    If, when you boot to the CCC backup, you have other issues, what are they?
    I cannot be held responsible for the things that come out of my mouth.
    In the Windows world, most everything folks don't understand is called a virus.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. VMware Fusion update lets users virtualize Leopard, Snow Leopard (MacWorld)
    By Lifeisabeach in forum Apple Rumors and Reports
    Replies: 16
    Last Post: 11-22-2011, 04:20 PM
  2. Replies: 2
    Last Post: 08-10-2011, 02:00 PM
  3. Remove Snow Leopard Server and re-install Snow Leopard
    By b-rad in forum OS X - Operating System
    Replies: 4
    Last Post: 08-09-2011, 01:33 AM
  4. Replies: 6
    Last Post: 01-02-2011, 05:15 PM
  5. Replies: 2
    Last Post: 04-10-2010, 05:09 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •