Results 1 to 5 of 5
  1. #1


    Member Since
    Jul 06, 2011
    Location
    New Hampshire
    Posts
    2
    Dashboard Client Quit Unexpectedly
    Hello! I'm new here, but not to Mac : )

    I own a 2008 iMac, and a 2011 MacBook Pro. I use each of my machines moderately, but usually my iMac for the heavier stuff, like my photography software and videos. When I first got my MBP in March, I used it a lot. I was just so excited!!!

    Yesterday, I did a software update. Restart was needed, so I restarted. Oh, and I'm version 10.6.8 2.3 GHz Intel Core i5, 4GB 1333 Mhz. I ALWAYS update the things I use. Since it's sweltering here in NH, I wanted to know what the weather would be like for the week, so I hit dashboard. Nothing in my dashboard that was normally there, was there, and the widget thing popped up at the bottom. I tried to add a widget, but the widget disappeared after a few seconds and then I got a message saying that "Dashboard Client Quit Unexpectedly" sent report to Apple blah blah blah.

    I then restarted, tried again, no luck. I went to work and came back hoping it would have magically fixed itself, but no. So I've spent the past few hours researching ways of fixing it. I'll tell you what I've done so far!!!

    Shut down, safe boot, and went into Library > Preferences > and deleted com.apple.dashboard.plist as well as com.apple.dashboardclient.plist. Restarted from safe boot, tried again, no luck. It also asked me send a report in safeboot about 6 or 7 times, instead of just once.

    Tried just normally deleting those two from preferences, no luck.

    Tried command terminal killAll Dock, still didn't work.

    Repaired disk permissions, didn't work.

    I have a friend who works at the Apple store, and he said that I should back it up and take it in, because they might need to reboot the whole entire thing. I'm attending university in the fall and I have been putting off buying an external portable hard drive, so I don't have one. I'm also very hesitant to throw all my files onto that little thing.

    Are there any other suggestions or things I could try to do to make this work so I can save myself the trip down there? I'm still covered by warranty, but this really is a pain in my butt.

    Oh-- by the way, I upgraded my iMac to 10.6.8 before I got my MBP. I did the same update, and dashboard works just fine on there. Any advice would be helpful and greatly appreciated! Thanks!!!

  2. #2

    bobtomay's Avatar
    Member Since
    Dec 22, 2006
    Location
    Texas, where else?
    Posts
    26,454
    Specs:
    15" MBP '06 2.33 C2D 4GB 10.7; 13" MBA '14 1.8 i7 8GB 10.11; 21" iMac '13 2.9 i5 8GB 10.11; 6S
    If this happened simultaneously with the update, then I'd try downloading the combo update and installing it. Maybe a glitch in the 1st go round, this can sometimes repair update glitches - link.
    I cannot be held responsible for the things that come out of my mouth.
    In the Windows world, most everything folks don't understand is called a virus.

  3. #3


    Member Since
    Jul 06, 2011
    Location
    New Hampshire
    Posts
    2
    Hey, thanks that worked!!! I would have never thought of that. I'll keep that in mind if I ever encounter more problems.

    Have a good one!

  4. #4

    bobtomay's Avatar
    Member Since
    Dec 22, 2006
    Location
    Texas, where else?
    Posts
    26,454
    Specs:
    15" MBP '06 2.33 C2D 4GB 10.7; 13" MBA '14 1.8 i7 8GB 10.11; 21" iMac '13 2.9 i5 8GB 10.11; 6S
    Glad it worked for you.
    I cannot be held responsible for the things that come out of my mouth.
    In the Windows world, most everything folks don't understand is called a virus.

  5. #5


    Member Since
    Jul 13, 2012
    Posts
    1
    Question dashboard
    Quote Originally Posted by bobtomay View Post
    If this happened simultaneously with the update, then I'd try downloading the combo update and installing it. Maybe a glitch in the 1st go round, this can sometimes repair update glitches - link.
    Similar problem. Same solution or something else?

    I'm not positive but I don't think I updated just before this happened. I didn't lose all my widgets. I would only get the "quit unexpectedly" message when I clicked on weather.com. I think it either disappeared then, or I dropped it and tried to add it again, and NOW it disappears whenever I try to add it. Then weatherbug got stuck on one temp/wind direction/day, so I tried dropping it and adding it again, and now it's still just stuck on permanent "loading". None of the links will connect me to the weatherbug web page anymore either. My other widgets are still working, but I don't know that they would if I dropped and re-added them either. Assumed this was a weather.com related issue until I also had problems with weatherbug. Now I'm not sure.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Preview quit unexpectedly
    By Ds123 in forum OS X - Operating System
    Replies: 0
    Last Post: 06-15-2012, 09:49 AM
  2. Programs quit unexpectedly
    By Marty Moose in forum OS X - Operating System
    Replies: 3
    Last Post: 09-05-2011, 03:49 PM
  3. such and such quit unexpectedly...
    By oanyego in forum OS X - Apps and Games
    Replies: 6
    Last Post: 01-05-2010, 11:19 PM
  4. Unexpectedly Quit
    By Jeremy W in forum Switcher Hangout
    Replies: 2
    Last Post: 07-27-2006, 09:12 AM
  5. Application has unexpectedly quit. Help
    By justink31 in forum OS X - Operating System
    Replies: 4
    Last Post: 09-28-2004, 01:02 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •