Results 1 to 3 of 3
  1. #1

    Seventh's Avatar
    Member Since
    Oct 10, 2009
    Location
    Boston, MA
    Posts
    48
    Specs:
    27" iMac, 17" MBP, Mini x2
    Question Corrupt/conflicting Keyboard & Mouse drivers
    Hi folks,

    I'm a recent OSX adopter (last year and a half or so) so I apologize if this is a relatively simple question.

    I'm running OSX 10.6.8 on a 27" iMac. I have a Logitech Dinovo Edge keyboard that works great, and a Razer Naga mouse. Everything has been working fine for quite some time.

    That said, Razer came out with a driver update that I applied and it has made my system extremely unhappy. The mouse and keyboard both work until I try to bring up the Preferences Panel for either of them. If I open either the Razer, Mouse, or Keyboard Prefpane, my keyboard (which is bluetooth) loses connectivity and never recovers.

    Additionally, the Keyboard preference pane and Logitech software preference pane do not open - they just hang indefinitely and I have to force quit the application and reboot my machine to get my keyboard back.

    I did some googling and tried doing a kextunload of the Razer drivers. I unloaded them, and moved them to the trash. After a reboot both the mouse and keyboard work, but I still have the same problem - as soon as I open a preference panel (either the standard Apple Mouse or Keyboard panels) my keyboard loses connectivity, the prefpane hangs and I have to reboot.

    I'm at a loss as to how to begin troubleshooting this. I believe the Razer drivers were the cause, but as I can tell I've unloaded them and there is no Razer software at all on the machine anymore. Is there a log file or something that I should be looking at to help track this down?

    Any insight would very much be appreciated. Thanks!

  2. #2

    Seventh's Avatar
    Member Since
    Oct 10, 2009
    Location
    Boston, MA
    Posts
    48
    Specs:
    27" iMac, 17" MBP, Mini x2
    Here's a tail of system.log. It looks like the Razer driver is still trying to load, which I assume is at least part of the problem, but I'm not sure where to go about disabling/removing it.


    $ tail system.log
    Jun 29 21:20:26 Vault com.apple.launchd.peruser.501[147] (com.razer.nagaepicdaemon[245]): posix_spawn("/Applications/Razer Naga Epic.app/Contents/SharedSupport/RazerNagaEpicDaemon.app/Contents/MacOS/RazerNagaEpicDaemon", ...): No such file or directory
    Jun 29 21:20:26 Vault com.apple.launchd.peruser.501[147] (com.razer.nagaepicdaemon[245]): Exited with exit code: 1
    Jun 29 21:20:26 Vault com.apple.launchd.peruser.501[147] (com.razer.nagaepicdaemon): Throttling respawn: Will start in 10 seconds
    Jun 29 21:20:36 Vault com.apple.launchd.peruser.501[147] (com.razer.nagaepicdaemon[246]): posix_spawn("/Applications/Razer Naga Epic.app/Contents/SharedSupport/RazerNagaEpicDaemon.app/Contents/MacOS/RazerNagaEpicDaemon", ...): No such file or directory
    Jun 29 21:20:36 Vault com.apple.launchd.peruser.501[147] (com.razer.nagaepicdaemon[246]): Exited with exit code: 1
    Jun 29 21:20:36 Vault com.apple.launchd.peruser.501[147] (com.razer.nagaepicdaemon): Throttling respawn: Will start in 10 seconds
    Jun 29 21:20:40 Vault login[248]: USER_PROCESS: 248 ttys000
    Jun 29 21:20:46 Vault com.apple.launchd.peruser.501[147] (com.razer.nagaepicdaemon[253]): posix_spawn("/Applications/Razer Naga Epic.app/Contents/SharedSupport/RazerNagaEpicDaemon.app/Contents/MacOS/RazerNagaEpicDaemon", ...): No such file or directory
    Jun 29 21:20:46 Vault com.apple.launchd.peruser.501[147] (com.razer.nagaepicdaemon[253]): Exited with exit code: 1
    Jun 29 21:20:46 Vault com.apple.launchd.peruser.501[147] (com.razer.nagaepicdaemon): Throttling respawn: Will start in 10 seconds

  3. #3

    chscag's Avatar
    Member Since
    Jan 23, 2008
    Location
    Fort Worth, Texas
    Posts
    48,033
    Specs:
    Late 2013 27" iMac, iPad 3, iPhone 6s+, iPhone 6+, 3 iPods, El Capitan
    Look in these places:

    MacIntosh HD/Library/LaunchDaemons/

    MacIntosh HD/Library/LaunchAgents/

    MacIntosh HD/Library/StartupItems/

    MacIntosh HD/Users/your user name/Library/LaunchAgents/

    Also look under System Preferences, Accounts, Login Items.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. GarageBand: conflicting 3rd party drivers
    By dogtonharrants in forum Music, Audio, and Podcasting
    Replies: 2
    Last Post: 03-20-2012, 05:30 AM
  2. Mouse & Keyboard Freeze
    By pjstingray in forum OS X - Operating System
    Replies: 6
    Last Post: 01-24-2012, 09:41 PM
  3. Microsoft Keyboard & Mouse Drivers for Mac
    By BEARSPAW in forum Apple Desktops
    Replies: 0
    Last Post: 04-24-2008, 06:50 AM
  4. Need Help With Wireless Keyboard & Mouse
    By Bruki in forum Internet, Networking, and Wireless
    Replies: 0
    Last Post: 01-31-2008, 04:16 PM
  5. Keyboard & Mouse settings
    By mimi8 in forum Apple Notebooks
    Replies: 1
    Last Post: 11-21-2006, 09:45 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •