New To Mac-Forums?

Welcome to our community! Join the discussion today by registering your FREE account. If you have any problems with the registration process, please contact us!

Get your questions answered by community gurus Advice and insight from world-class Apple enthusiasts Exclusive access to members-only contests, giveaways and deals

Join today!

 
Start a Discussion
 

Mac-Forums Brief

Subscribe to Mac-Forums Brief to receive special offers from Mac-Forums partners and sponsors

Join the conversation RSS
OS X - Operating System General OS operation information and support

Corrupt/conflicting Keyboard & Mouse drivers


Post Reply New Thread Subscribe

 
Thread Tools
Seventh

 
Seventh's Avatar
 
Member Since: Oct 10, 2009
Location: Boston, MA
Posts: 48
Seventh is on a distinguished road
Mac Specs: 27" iMac, 17" MBP, Mini x2

Seventh is offline
Hi folks,

I'm a recent OSX adopter (last year and a half or so) so I apologize if this is a relatively simple question.

I'm running OSX 10.6.8 on a 27" iMac. I have a Logitech Dinovo Edge keyboard that works great, and a Razer Naga mouse. Everything has been working fine for quite some time.

That said, Razer came out with a driver update that I applied and it has made my system extremely unhappy. The mouse and keyboard both work until I try to bring up the Preferences Panel for either of them. If I open either the Razer, Mouse, or Keyboard Prefpane, my keyboard (which is bluetooth) loses connectivity and never recovers.

Additionally, the Keyboard preference pane and Logitech software preference pane do not open - they just hang indefinitely and I have to force quit the application and reboot my machine to get my keyboard back.

I did some googling and tried doing a kextunload of the Razer drivers. I unloaded them, and moved them to the trash. After a reboot both the mouse and keyboard work, but I still have the same problem - as soon as I open a preference panel (either the standard Apple Mouse or Keyboard panels) my keyboard loses connectivity, the prefpane hangs and I have to reboot.

I'm at a loss as to how to begin troubleshooting this. I believe the Razer drivers were the cause, but as I can tell I've unloaded them and there is no Razer software at all on the machine anymore. Is there a log file or something that I should be looking at to help track this down?

Any insight would very much be appreciated. Thanks!
QUOTE Thanks
Seventh

 
Seventh's Avatar
 
Member Since: Oct 10, 2009
Location: Boston, MA
Posts: 48
Seventh is on a distinguished road
Mac Specs: 27" iMac, 17" MBP, Mini x2

Seventh is offline
Here's a tail of system.log. It looks like the Razer driver is still trying to load, which I assume is at least part of the problem, but I'm not sure where to go about disabling/removing it.

Quote:

$ tail system.log
Jun 29 21:20:26 Vault com.apple.launchd.peruser.501[147] (com.razer.nagaepicdaemon[245]): posix_spawn("/Applications/Razer Naga Epic.app/Contents/SharedSupport/RazerNagaEpicDaemon.app/Contents/MacOS/RazerNagaEpicDaemon", ...): No such file or directory
Jun 29 21:20:26 Vault com.apple.launchd.peruser.501[147] (com.razer.nagaepicdaemon[245]): Exited with exit code: 1
Jun 29 21:20:26 Vault com.apple.launchd.peruser.501[147] (com.razer.nagaepicdaemon): Throttling respawn: Will start in 10 seconds
Jun 29 21:20:36 Vault com.apple.launchd.peruser.501[147] (com.razer.nagaepicdaemon[246]): posix_spawn("/Applications/Razer Naga Epic.app/Contents/SharedSupport/RazerNagaEpicDaemon.app/Contents/MacOS/RazerNagaEpicDaemon", ...): No such file or directory
Jun 29 21:20:36 Vault com.apple.launchd.peruser.501[147] (com.razer.nagaepicdaemon[246]): Exited with exit code: 1
Jun 29 21:20:36 Vault com.apple.launchd.peruser.501[147] (com.razer.nagaepicdaemon): Throttling respawn: Will start in 10 seconds
Jun 29 21:20:40 Vault login[248]: USER_PROCESS: 248 ttys000
Jun 29 21:20:46 Vault com.apple.launchd.peruser.501[147] (com.razer.nagaepicdaemon[253]): posix_spawn("/Applications/Razer Naga Epic.app/Contents/SharedSupport/RazerNagaEpicDaemon.app/Contents/MacOS/RazerNagaEpicDaemon", ...): No such file or directory
Jun 29 21:20:46 Vault com.apple.launchd.peruser.501[147] (com.razer.nagaepicdaemon[253]): Exited with exit code: 1
Jun 29 21:20:46 Vault com.apple.launchd.peruser.501[147] (com.razer.nagaepicdaemon): Throttling respawn: Will start in 10 seconds
QUOTE Thanks
chscag

 
chscag's Avatar
 
Member Since: Jan 23, 2008
Location: Fort Worth, Texas
Posts: 40,997
chscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond repute
Mac Specs: 27" iMac i5, 3.2 GHz, iPad 3, iPhone 5c, 3 iPods, Yosemite

chscag is offline
Look in these places:

MacIntosh HD/Library/LaunchDaemons/

MacIntosh HD/Library/LaunchAgents/

MacIntosh HD/Library/StartupItems/

MacIntosh HD/Users/your user name/Library/LaunchAgents/

Also look under System Preferences, Accounts, Login Items.
QUOTE Thanks

Post Reply New Thread Subscribe


« Multiple workstation OSX install | Error when downloading software updates »
Thread Tools

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off
Forum Jump

Similar Threads
Thread
Thread Starter
Forum
Replies
Last Post
Mouse buttons and keyboard randomly stop responding on secondary display geronimo77 OS X - Operating System 0 04-08-2010 06:36 PM
Bluetooth keyboard and mouse Laytonx Other Hardware and Peripherals 2 01-19-2010 06:30 PM
Paraplegic computer, dying slowly from the inside. Broken mouse and keyboard. lord.enlil OS X - Operating System 0 01-08-2009 10:22 AM
Wireless Keyboard and Mouse under Windows via Bootcamp? vrDUCKin Running Windows (or anything else) on your Mac 0 12-22-2008 08:01 PM

All times are GMT -4. The time now is 01:36 AM.

Powered by vBulletin
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
X

Welcome to Mac-Forums.com

Create your username to jump into the discussion!

New members like you have made this community the ultimate source for your Mac since 2003!


(4 digit year)

Already a member?