New To Mac-Forums?

Welcome to our community! Join the discussion today by registering your FREE account. If you have any problems with the registration process, please contact us!

Get your questions answered by community gurus • Advice and insight from world-class Apple enthusiasts • Exclusive access to members-only contests, giveaways and deals

Join today!

 
Start a Discussion
 

Mac-Forums Brief

Subscribe to Mac-Forums Brief to receive special offers from Mac-Forums partners and sponsors

Join the conversation RSS
OS X - Operating System General OS operation information and support

Kernel Panics after Updates 10.6.5+


Post Reply New Thread Subscribe

 
Thread Tools
numinos

 
Member Since: Jun 28, 2011
Posts: 5
numinos is on a distinguished road

numinos is offline
Hello. I have a serious problem with updating my MacBook Pro 13" (early 2010). Everything works fine with 10.6.4. but from 10.6.5. on, i get instant kernel panics directly before/after the loginwindow appear(s/ed) (random kexts are indicated: IOUSBFamily, IOAHCI, Logitech stuff, but also SMC, HDA). I thought that this issue would be fixed in 10.6.6, 7 or 8 but it never changed. These KPs also appear in safe mode, after deleting the kext cache or nvram etc. Apparently the reason is the new kernel.

Does anybody have the same issues after updating from 10.6.4. to a newer version?

Thanks in advance.
QUOTE Thanks
Lifeisabeach

 
Lifeisabeach's Avatar
 
Member Since: Sep 30, 2007
Location: Wilmington, NC
Posts: 7,048
Lifeisabeach has a reputation beyond reputeLifeisabeach has a reputation beyond reputeLifeisabeach has a reputation beyond reputeLifeisabeach has a reputation beyond reputeLifeisabeach has a reputation beyond reputeLifeisabeach has a reputation beyond reputeLifeisabeach has a reputation beyond reputeLifeisabeach has a reputation beyond reputeLifeisabeach has a reputation beyond reputeLifeisabeach has a reputation beyond reputeLifeisabeach has a reputation beyond repute
Mac Specs: iMac i3 (mid-2010) + OS 10.9; TV 3; iPhone 5S; iPad 4

Lifeisabeach is offline
I'm wondering if the update brought to light a hardware issue that you had but was unaware of. Have you run the Apple Hardware Test? Have you done anything like change out the RAM yourself?


Please verify and include the exact model/year of your Mac and OS X version number (available from "About This Mac", then "More Info" on the Apple menu).
------
Links: Onyx | EasyFind | Apple Hardware Test | How to test your hard drive | The Safe Mac » Adware Removal Guide | Uninstall MacKeeper
------
Lifeisabeach - Mac-Forums Member of the Month June 2009, Feb 2012, and March 2013.
QUOTE Thanks
numinos

 
Member Since: Jun 28, 2011
Posts: 5
numinos is on a distinguished road

numinos is offline
Yes, I did the Apple Hardware Test and everything worked out fine. BTW: The MBP is equipped with an SSD harddrive 256 GB.

And, to be more precise: These KPs appear on every startup. Means, I had to roll back to 10.6.4. all the time. Furthermore, I always updated using Comboupdates and with repairing permissions in advance.
QUOTE Thanks
Lifeisabeach

 
Lifeisabeach's Avatar
 
Member Since: Sep 30, 2007
Location: Wilmington, NC
Posts: 7,048
Lifeisabeach has a reputation beyond reputeLifeisabeach has a reputation beyond reputeLifeisabeach has a reputation beyond reputeLifeisabeach has a reputation beyond reputeLifeisabeach has a reputation beyond reputeLifeisabeach has a reputation beyond reputeLifeisabeach has a reputation beyond reputeLifeisabeach has a reputation beyond reputeLifeisabeach has a reputation beyond reputeLifeisabeach has a reputation beyond reputeLifeisabeach has a reputation beyond repute
Mac Specs: iMac i3 (mid-2010) + OS 10.9; TV 3; iPhone 5S; iPad 4

Lifeisabeach is offline
Quote:
Originally Posted by numinos View Post
Yes, I did the Apple Hardware Test and everything worked out fine. BTW: The MBP is equipped with an SSD harddrive 256 GB.

And, to be more precise: These KPs appear on every startup. Means, I had to roll back to 10.6.4. all the time. Furthermore, I always updated using Comboupdates and with repairing permissions in advance.
And have you done anything like change the RAM yourself? And is the SSD original from Apple, or a 3rd party?


Please verify and include the exact model/year of your Mac and OS X version number (available from "About This Mac", then "More Info" on the Apple menu).
------
Links: Onyx | EasyFind | Apple Hardware Test | How to test your hard drive | The Safe Mac » Adware Removal Guide | Uninstall MacKeeper
------
Lifeisabeach - Mac-Forums Member of the Month June 2009, Feb 2012, and March 2013.
QUOTE Thanks
numinos

 
Member Since: Jun 28, 2011
Posts: 5
numinos is on a distinguished road

numinos is offline
Nothing changed with RAM, SSD original APPLE SSD TS256B. I newer had a KP within 10.6.4. I also installed a fresh 10.6.6. on the computer without updating from my TM-Backup. And the same things happened.

On the 10.6.5. update I read in several forums that there was an issue with WiFi, but I do not find these threads anymore...
QUOTE Thanks
EvenStranger

 
EvenStranger's Avatar
 
Member Since: Dec 09, 2010
Location: Virginia
Posts: 845
EvenStranger is just really niceEvenStranger is just really niceEvenStranger is just really niceEvenStranger is just really niceEvenStranger is just really nice
Mac Specs: Currently 13" Late 2010 MBA, 4GB/128GB; Early 2011 13" MBP, dual core i7 2.7ghz, 4gb ram, 500gb hd

EvenStranger is offline
Since the issue links USB and Logitec components, you may be dealing with an older 3rd party driver that is not compatible with the more recent versions of MacOS, most likely for a keyboard or mouse.
QUOTE Thanks
Lifeisabeach

 
Lifeisabeach's Avatar
 
Member Since: Sep 30, 2007
Location: Wilmington, NC
Posts: 7,048
Lifeisabeach has a reputation beyond reputeLifeisabeach has a reputation beyond reputeLifeisabeach has a reputation beyond reputeLifeisabeach has a reputation beyond reputeLifeisabeach has a reputation beyond reputeLifeisabeach has a reputation beyond reputeLifeisabeach has a reputation beyond reputeLifeisabeach has a reputation beyond reputeLifeisabeach has a reputation beyond reputeLifeisabeach has a reputation beyond reputeLifeisabeach has a reputation beyond repute
Mac Specs: iMac i3 (mid-2010) + OS 10.9; TV 3; iPhone 5S; iPad 4

Lifeisabeach is offline
Check out this article to see if his tip works for you:
How to fix a Kernel Panic issue after updating to Mac OS X 10.6.5 - My rambling weblog of things and...stuff

Also… do you have any kexts in /Library/Extensions or in ~/Library/Extensions?

There are a number of kexts in /System/Library/Extensions, but that is Apple's stuff and shouldn't normally be messed with, so for the moment, ignore them.

If you can… try installing OS X to a new partition on your internal drive, or to an external if the space is not available. Don't migrate a user. We want a virgin installation free of any 3rd party factors that may be causing the problem. I actually have OS X installed on a thumb drive, complete with various utilities, just for emergencies.
Format Your USB Flash Drive for Use With OS X


Please verify and include the exact model/year of your Mac and OS X version number (available from "About This Mac", then "More Info" on the Apple menu).
------
Links: Onyx | EasyFind | Apple Hardware Test | How to test your hard drive | The Safe Mac » Adware Removal Guide | Uninstall MacKeeper
------
Lifeisabeach - Mac-Forums Member of the Month June 2009, Feb 2012, and March 2013.
QUOTE Thanks
Lifeisabeach

 
Lifeisabeach's Avatar
 
Member Since: Sep 30, 2007
Location: Wilmington, NC
Posts: 7,048
Lifeisabeach has a reputation beyond reputeLifeisabeach has a reputation beyond reputeLifeisabeach has a reputation beyond reputeLifeisabeach has a reputation beyond reputeLifeisabeach has a reputation beyond reputeLifeisabeach has a reputation beyond reputeLifeisabeach has a reputation beyond reputeLifeisabeach has a reputation beyond reputeLifeisabeach has a reputation beyond reputeLifeisabeach has a reputation beyond reputeLifeisabeach has a reputation beyond repute
Mac Specs: iMac i3 (mid-2010) + OS 10.9; TV 3; iPhone 5S; iPad 4

Lifeisabeach is offline
EvenStranger has a good point… I noticed the Logitech references and forgot to address that. Try uninstalling any Logitech software and drivers.


Please verify and include the exact model/year of your Mac and OS X version number (available from "About This Mac", then "More Info" on the Apple menu).
------
Links: Onyx | EasyFind | Apple Hardware Test | How to test your hard drive | The Safe Mac » Adware Removal Guide | Uninstall MacKeeper
------
Lifeisabeach - Mac-Forums Member of the Month June 2009, Feb 2012, and March 2013.
QUOTE Thanks
numinos

 
Member Since: Jun 28, 2011
Posts: 5
numinos is on a distinguished road

numinos is offline
Thank you very much for your replies.

As mentioned above I already installed a virgin 10.6.6. also noticing the KPs. Thus, Logitech cannot be the reason. I think, I will try the AirPort fix - thanks for finding the sources again!
QUOTE Thanks
Lifeisabeach

 
Lifeisabeach's Avatar
 
Member Since: Sep 30, 2007
Location: Wilmington, NC
Posts: 7,048
Lifeisabeach has a reputation beyond reputeLifeisabeach has a reputation beyond reputeLifeisabeach has a reputation beyond reputeLifeisabeach has a reputation beyond reputeLifeisabeach has a reputation beyond reputeLifeisabeach has a reputation beyond reputeLifeisabeach has a reputation beyond reputeLifeisabeach has a reputation beyond reputeLifeisabeach has a reputation beyond reputeLifeisabeach has a reputation beyond reputeLifeisabeach has a reputation beyond repute
Mac Specs: iMac i3 (mid-2010) + OS 10.9; TV 3; iPhone 5S; iPad 4

Lifeisabeach is offline
Quote:
Originally Posted by numinos View Post
Thank you very much for your replies.

As mentioned above I already installed a virgin 10.6.6. also noticing the KPs. Thus, Logitech cannot be the reason. I think, I will try the AirPort fix - thanks for finding the sources again!
DOH! I missed that. If the Airport fix doesn't work, then definitely try a different drive for kicks.


Please verify and include the exact model/year of your Mac and OS X version number (available from "About This Mac", then "More Info" on the Apple menu).
------
Links: Onyx | EasyFind | Apple Hardware Test | How to test your hard drive | The Safe Mac » Adware Removal Guide | Uninstall MacKeeper
------
Lifeisabeach - Mac-Forums Member of the Month June 2009, Feb 2012, and March 2013.
QUOTE Thanks
numinos

 
Member Since: Jun 28, 2011
Posts: 5
numinos is on a distinguished road

numinos is offline
Hi.

AirPort fix did not work. But thanks to lifeisabeach, I tried the external install! I did the external drive install and everything worked out. No KPs. Checking the SSD and again an AHT did not help - the harddrive is ok. Hence, I conclude that some drivers changed which do not work well with my SSD. Does anybody have an idea to solve this or at least noticed the same issue?
QUOTE Thanks
harryb2448

 
harryb2448's Avatar
 
Member Since: Nov 28, 2007
Location: Nambucca Heads Australia
Posts: 18,324
harryb2448 has a reputation beyond reputeharryb2448 has a reputation beyond reputeharryb2448 has a reputation beyond reputeharryb2448 has a reputation beyond reputeharryb2448 has a reputation beyond reputeharryb2448 has a reputation beyond reputeharryb2448 has a reputation beyond reputeharryb2448 has a reputation beyond reputeharryb2448 has a reputation beyond reputeharryb2448 has a reputation beyond reputeharryb2448 has a reputation beyond repute
Mac Specs: iMac i5 2.7GHz, 16GB memory, OS 10.10.1

harryb2448 is offline
Do not rely on AHT solely to diagnose hard drive problems. When you installed the SSD any chance you cloned the operating system to it? if so suggest a format and clean install of Snow Leopard then update with the OS X.6.8 Combo Updater.


http://support.apple.com/kb/DL1399

Hang on to those original install discs like grim death! Using OS X.7 or later make a bootable USB thumb drive before running Installer!
QUOTE Thanks
Lifeisabeach

 
Lifeisabeach's Avatar
 
Member Since: Sep 30, 2007
Location: Wilmington, NC
Posts: 7,048
Lifeisabeach has a reputation beyond reputeLifeisabeach has a reputation beyond reputeLifeisabeach has a reputation beyond reputeLifeisabeach has a reputation beyond reputeLifeisabeach has a reputation beyond reputeLifeisabeach has a reputation beyond reputeLifeisabeach has a reputation beyond reputeLifeisabeach has a reputation beyond reputeLifeisabeach has a reputation beyond reputeLifeisabeach has a reputation beyond reputeLifeisabeach has a reputation beyond repute
Mac Specs: iMac i3 (mid-2010) + OS 10.9; TV 3; iPhone 5S; iPad 4

Lifeisabeach is offline
Quote:
Originally Posted by numinos View Post
Hi.

AirPort fix did not work. But thanks to lifeisabeach, I tried the external install! I did the external drive install and everything worked out. No KPs. Checking the SSD and again an AHT did not help - the harddrive is ok. Hence, I conclude that some drivers changed which do not work well with my SSD. Does anybody have an idea to solve this or at least noticed the same issue?
Alrighty… now we're on track! However… don't be too quick to assume it's a problem to the SSD specifically. It "could" be the SATA controller too since that would have no impact on the functioning of an external drive. This actually happened to another member recently. Realistically, the only thing I can think to try is to replace the SSD with an HDD and see if the problem replicates. If it doesn't, then the problem is definitely rooted in the SSD and OS updates. If it does replicate, then it's some other hardware component.

Regardless of which component it is, you are in an interesting pickle. Everything works fine up until you install 10.6.5 or later, which is really odd. The question remains… is it a bug in the updates, or a fault in the hardware that the updates have brought to light? I don't think we can answer that question. I would call Apple, even if you are out of warranty. Sometimes they can make exceptions, and if you have an existing hardware flaw that was only revealed with the updates, then they should be on the hook for it IMO. There may well even be a recall you don't know about.


Please verify and include the exact model/year of your Mac and OS X version number (available from "About This Mac", then "More Info" on the Apple menu).
------
Links: Onyx | EasyFind | Apple Hardware Test | How to test your hard drive | The Safe Mac » Adware Removal Guide | Uninstall MacKeeper
------
Lifeisabeach - Mac-Forums Member of the Month June 2009, Feb 2012, and March 2013.
QUOTE Thanks

Post Reply New Thread Subscribe


« Batching file names | How to transfer Mac O s X On To Another Mac »
Thread Tools

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off
Forum Jump

Similar Threads
Thread
Thread Starter
Forum
Replies
Last Post
Freshly installed MBP with leopard now it takes 6 minutes to load / boot up! studio-steve OS X - Operating System 5 03-14-2010 01:13 PM
time machine error - never stops to prepare or stopping back-up alonewithmymac OS X - Apps and Games 3 12-26-2008 08:56 PM
kernel panics - what does this mean? jnev OS X - Operating System 4 10-07-2007 02:54 PM
Kernel PAnics Go go Mac Apple Notebooks 1 02-19-2007 05:35 PM
Kernel panic while trying to play a dvd image made by disk util in dvd player. Toanjii OS X - Operating System 6 11-01-2004 01:57 AM

All times are GMT -4. The time now is 12:03 PM.

Powered by vBulletin
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
X

Welcome to Mac-Forums.com

Create your username to jump into the discussion!

New members like you have made this community the ultimate source for your Mac since 2003!


(4 digit year)

Already a member?