Hi all,

I have read several threads on here about internet sharing not working on a Mac, but since none of them seem to mention my problem, I thought I'd post in hopes someone could help.

I'm currently in a hotel, which only has one ethernet link per room. I'm looking to utilize internet sharing so the others staying with me can access the web from their devices. However, I CANNOT get this to work. Basically, I'm following the instructions -- going to System Preferences -> Sharing and then switching on Internet Sharing. I'm clicking AirPort Options, creating a name for the network and putting a password on it. But when I do, I does NOT appear on any of the other devices as an option. I've tried manually joining this network by typing it in, but I constantly see a "network not found."

I have tried everything. I've disabled my firewall. I've disabled the password on the network. I've tried creating another network from my network settings (which works, but doesn't share the internet connection). I've tried both 40-bit and 128-bit WEP encryption. Everything.

I'd really like to be able to do this, so if anyone has any suggestions or ideas, please let me know.