Results 1 to 4 of 4
  1. #1

    Member Since
    May 18, 2011
    HELP! iMac 2010 i3 won't recognise firewire equipments
    Hi all. This is an urgent help request regarding the firewire connection problem of an iMac purchased in 2010, running iOS 10.6.7, i3 3.06G 21inch model. This model has only one firewire 800 port.

    I'm a professional photographer still working on film, and I regularly scan films using my Epson V700 (it's rather fast).

    If I connect the scanner via USB, it works; but if I connect it via a 800-400 convert to the iMac's 800 port, there is nothing, it is not recognized.

    I tried replacing the 800-400 cable to no avail. It seems that it's the iMac's 800 port that won't do anything.

    I did plenty research on the internet and found several similar cases, there are guys who can't connect their HDD, or scanner. But I didn't find the answer.

    So please could anyone tell me what to do next (except for calling apple for repair, I'd rather solve this problem myself since the service in France is rather slow).

    Can I use the terminal to check the firewire port, or can I force it to install-uninstall drivers?

    Same problem persists while I connect the V700 under bootcamp, windows xp won't recognize anything.

    Do you guys believe it's a hardware failure?

    Thank you very much!!

  2. #2

    EvenStranger's Avatar
    Member Since
    Dec 09, 2010
    Currently 13" Late 2010 MBA, 4GB/128GB; Early 2011 13" MBP, dual core i7 2.7ghz, 4gb ram, 500gb hd
    Three questions - have you verified that the firewire port on the scanner works with another computer? And if you connect the scanner to the Mac, open System Profiler, and check under Firewire, is the scanner at least a visible device? Do you have a different Firewire device, such as a hard drive, you could use to verify the port on the iMac is bad?

  3. #3

    Member Since
    Oct 06, 2014
    same problem
    Hi, I have a 2010 imac that is driving me nuts.
    In system report, under hardware>firewire, it shows:
    FireWire Bus:
    Maximum Speed: Up to 800 Mb/sec

    Which tells me that the FW bus is reading, but I have tried the two different FW audio devices that I have and neither one pops up in the Audio device manager.

    I've tried two different cords, I also went to the local music store and plugged the same mixer with the same cable into their iMac and it popped right up.
    Does this mean my FW port is bad?
    Many thanks

  4. #4

    chas_m's Avatar
    Member Since
    Jan 22, 2010
    Victoria, BC
    Mid-2012 MBP (16GB, 1TB HD), Monoprice 24-inch second monitor, iPhone 5s 32GB, iPad Air 2 64GB
    You're hijacking a four-year-old thread.

    Start a new thread and ask, you'll get a lot more help that way.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. iMac 2010 won't recognize my firewire devices
    By groovepro in forum Apple Desktops
    Replies: 3
    Last Post: 10-18-2014, 12:11 PM
  2. Mac Book Pro won't recognise portable hard drive won
    By badshoehabit in forum Other Hardware and Peripherals
    Replies: 9
    Last Post: 02-10-2012, 09:32 PM
  3. Mac won't recognise printer!
    By saucysnook in forum OS X - Operating System
    Replies: 1
    Last Post: 10-18-2011, 04:49 PM
  4. My brand new imac won't recognise ANY printer I seem to try and link it to?
    By jack123 in forum Other Hardware and Peripherals
    Replies: 3
    Last Post: 10-07-2010, 04:30 PM
  5. bootcamp won't recognise xp sp2 cd
    By Quertis in forum Running Windows (or anything else) on your Mac
    Replies: 8
    Last Post: 11-01-2006, 12:06 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts