Results 1 to 8 of 8
  1. #1

    Member Since
    May 16, 2011
    Unhappy Mac Boot Problem- need help with FSCK in Single user mode
    Hey All!

    applogies if this is a reaccuring post, I went through alot of the other posts regarding rebooting problems, and couldn't find a match.

    I tried all the shortcuts (safe mode etc), and the only one that worked was Command S - (single user mode)
    I ran:
    /sbin/fsck -fy

    The first time got :

    ** The volume mac was repaired successfully.
    I ran it once more and got:
    ** The volume Mac appears to be OK
    I than hit the # reboot -- No go.

    Every time I run the FSCK I get errors, after running it a second time it says everything is fine- no modifications, than if I reboot and try again it repeats the same erorrs again:
    -incorrect block count for file libSystem.B.dylib
    (it should be 5784 instead of 3856)
    -Invalid volume file count
    (it should be 725867 instead of 725868)
    -Invalid directory count
    (it should be 158886 instead of 158885)

    I also tried fsck -fy on the root (no sbin)- same ****.

    any help, advice and comments are greatly appreciated- thanks !!

  2. #2

    harryb2448's Avatar
    Member Since
    Nov 28, 2007
    Nambucca Heads Australia
    iMac i5 2.7GHz, 16GB memory, OS 10.11
    G'day and welcome to the forums.

    Boot from your system install disc, go into Utilities in the Menu bar, Disk Utility and run Repair Disk from there.
    Hang on to those original install discs like grim death! Using OS X.7 or later make a bootable USB thumb drive before running Installer!

  3. #3

    Member Since
    May 16, 2011
    Thanks so much for the reply but...
    Quote Originally Posted by harryb2448 View Post
    G'day and welcome to the forums.

    Boot from your system install disc, go into Utilities in the Menu bar, Disk Utility and run Repair Disk from there.

    I can't boot from the CD for two reasons:

    - The CD_ROM is ruined- can't put anything into the computer.
    - I don't have it or a way to get a hold of it (I'm out of the country)

    a quick update: The computer now skips past the Grey apple + spinning gears screen- but halt's on a blue screen (the mouse cursor even moves) but nothing happens. it's been on for hours now.

    Would appreciate any further input- Thanks !

  4. #4

    MacsWork's Avatar
    Member Since
    May 22, 2005
    Closer than you think.
    Performa 6116 2GBSCSI 8MB OS 7.5.3
    Boot with CMD+V. What is the error it stops on?

  5. #5

    Member Since
    May 16, 2011
    Disk0s2: I/O error.
    AppleAHCIDiskQueueManager::setPowerState(0x3d33a00 ,2 -> 1) timed out after 100358 ms disk0s2: I/O error

  6. #6

    EvenStranger's Avatar
    Member Since
    Dec 09, 2010
    Currently 13" Late 2010 MBA, 4GB/128GB; Early 2011 13" MBP, dual core i7 2.7ghz, 4gb ram, 500gb hd
    disk0s2: I/O error

    That's a flaky drive... back up, and either wipe and reload the drive or replace it. Personally, if I was seeing constant errors and having boot failures, with the cost of HDs as low as they are, I'd just replace the drive and keep on trucking.

  7. #7

    Member Since
    May 16, 2011
    how do I wipe it out ?
    Thanks much for the advice

    luckily there is nothing of consequence on the drive.
    how do I wipe it out ?

    through single user mode ?

    Thanks !

  8. #8

    chscag's Avatar
    Member Since
    Jan 23, 2008
    Fort Worth, Texas
    27" iMac i5, 3.2 GHz, iPad 3, iPhone 5c, iPhone 6+, 3 iPods, El Capitan
    If your optical drive is not working and you don't have your original install DVD with you, there's not a whole lot you can do. And even if you do somehow wipe the drive, how are you going to reinstall OS X?

    I don't know where you are right now so this suggestion may not be viable. Buy an external optical drive and a copy of Snow Leopard. Use that combo to wipe the hard drive and reinstall. Keep in mind that your hard drive is on its way south and can fail at any time.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Single-User Mode, fsck problem
    By jordan4501 in forum OS X - Operating System
    Replies: 8
    Last Post: 09-22-2013, 05:43 PM
  2. How do I write in terminal when the Mac is in single-user mode?
    By annastasiabeal in forum OS X - Operating System
    Replies: 1
    Last Post: 07-17-2012, 02:27 PM
  3. Replies: 5
    Last Post: 01-28-2011, 09:24 PM
  4. Boot into desktop from single user mode.
    By markh789 in forum OS X - Operating System
    Replies: 0
    Last Post: 08-08-2010, 04:36 AM
  5. can i boot a disc in single user mode?
    By poobah in forum Apple Desktops
    Replies: 0
    Last Post: 02-13-2005, 08:20 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts