Hi guys first time poster here, having some issues with time machine. My setup is a Mac mini with two USB external drives, both shared. The mini backs up to one drive, and the other I have as a network Time Machine disk for my wife's macbook air. Both are running the lastest version of snow leopard. This setup has worked perfectly for the first month we had the air. Yesterday though I noticed that the air was not completing any backups, but instead getting stuck on "making backup disk available". Trying to stop the backup gives the spinning beach ball and sometimes locks up the computer completely. If I pull the hard drive from the mini and plug it in USB to the Air, it backs up fine. The mini has no problem backing up to it's external drive. I have tried backing up the Air to a different shared drive with no luck, so I know it's not a drive problem. I have moved the sparse bundle for the air to a different drive, reformatted the drive and tried again, with no luck. Basically, I am no longer able to do network backups from the air, even though I could every hour with no problem 10 days ago. Now the internal drive on the mini did get corrupted the day before this issue began, and I had to do a restore from it's time machine. But, even after this restore I was able to make network backups for the air for almost a whole day, so I don't think this is the issue. Sorry for the long read, but does anyone have any ideas what the issue may be? Thanks