Results 1 to 2 of 2
  1. #1

    Member Since
    Apr 29, 2011
    Unhappy Preference folder/No such file or Directory
    Hello knowledgeable ones!

    So I'm using single user mode to move/delete my preference folder in hopes that it will recreate itself and upon start up, get past the grey screen of despair.

    I tried what it says on the site about renaming/moving preferences and the iMac only responds "no such file or directory". Possibly because I don't remember what I did for the short name on my account? I don't know 100% which exact version of OS it is either.. This is because I've only had the computer six days, it was the family computer my younger brother mainly used but he passed away 4/nearly 5 months ago now, and my dad asked me to take it on my birthday, kinda TMI I guess but it does sound stupid that I don't know. My dad's computer is close to same/or maybe it is the same as this one, so this computer may have 10.58 like his, my dad however much he's infatuated with Mac products knows next to nothing about them.

    The endless grey screen started after I installed avast! because dumbly I thought I'd check for viruses since I hadn't used this computer in ages (I've been working with an outdated snail-speed PC since I moved out of my parent's house). avast! told me something within my preferences was corrupted something like media_preference and I assumed after deleting it, it would remake it on start-up anyway and avast! gave no other option and refused to quit..

    Sooo I have an idea of what's wrong but not what to do?

    I have an install disc that may not be the correct one. The iMac won't boot it on start-up from 'c' or 'option' and the disc is Tiger v. 10.48 but this computer has been upgraded before maybe, it is 10.58 now? I have nothing but the keyboard plugged in, I've tried many times doing safe mode start-up with 'shift' 'command 'v' and it says generating crash report and something with the computers name and error with loginwindow. My account is the admin, and my brother's doesn't have admin rights and it doesn't automatically log you in on start-up if that makes a difference?

    Is there a way to clear a cache of some kind to make stuff work? I tried making a new user in single user mode to log-in or maybe that will recreate the deleted preference, honestly maybe I'm not doing it right? I haven't made much progress in single user mode. I don't think my dad has a firewire cable and I know I don't, I read that maybe we could hook them up to restore stuff though I have no idea how and he doesn't actually know the computer isn't working since it was my brother's, I feel incredibly bad and am very reluctant to tell him.

    How do I get past this grey screen + spinning wheel? Sorry this was long! Thank you for reading!

  2. #2

    toMACsh's Avatar
    Member Since
    Jul 30, 2009
    Mac Mini Core 2 Duo
    Sorry for your loss. I know what that's like. My brother has passed away also.

    For your Preferences, you can remove the plist files one at a time or en mass and they will "regenerate" the next time that app is started. I don't know about deleting the whole folder. Some folders holding "sensitive" items cannot be deleted.

    And no, a Tiger disc will not work in a machine that has Leopard installed on it. To find out what version of Leopard you have, go to About this Mac in the Menu.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Damaged preference file in /bin/sh
    By jffffj in forum OS X - Operating System
    Replies: 6
    Last Post: 11-19-2014, 05:38 AM
  2. Application file association preference
    By stereodan98 in forum OS X - Operating System
    Replies: 0
    Last Post: 11-19-2010, 06:02 PM
  3. Replies: 1
    Last Post: 02-12-2010, 09:44 AM
  4. Can I lock my iTunes folder location preference...?
    By ukaser in forum Internet, Networking, and Wireless
    Replies: 5
    Last Post: 05-18-2008, 09:51 AM
  5. HELP! Catalog B-tree error, can't delete a HUGE preference file
    By markpetrowsky in forum Running Windows (or anything else) on your Mac
    Replies: 5
    Last Post: 03-12-2004, 12:39 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts