Results 1 to 6 of 6
  1. #1

    Member Since
    Mar 29, 2011
    Safari and Skype stopped working simultaneously. Help!

    I am a complete tech noob here, I'm going to try and express my problem in as general/simple a way as I can. If any advice can be written with the fact that I don't even know how to manually insert commands with my macbook in mind, I'd appreciate it!

    I have a Macbook Pro using Mac OS X 10.6.5. I've only been using it for a year, and everything is in relatively good condition.

    However, just last night I've encountered problems with Safari and Skype. Safari opens fine, and if I don't type anything into the URL box and hit enter, then I can do all the clickings such as checking my bookmarks, history, etc. But once I type a URL in and hit enter, it loads a bit and immediately freezes (with that rainbow swirly thing). With Skype, it lets me open, logs into the interface, and lasts as far as me being able to see all the users that are online/offline on my contact list before shutting down (not just freezing like Safari, but disappears with the error message popping up.) I managed to download and install skype again. This time, nothing goes wrong until I click on a user name and open up the window to begin typing. Then, instead of just shutting down, it freezes.

    I have reset/shut down my laptop multiple times, and attempted to "reset" Safari, since a friend suggested that it might be some cookie problem. However, Safari freezes on me every time I attempt to make a reset. Since it's the default browser for mac, I can't make any software updates either (assuming that will fix anything that is).

    The two long error messages I get after I force quit Skype and Safari seem to be similar. I don't know if it'll be helpful for me to post them here since they're so long...but this is what my friend commented:

    "both safari and skype failing at the same time means something is going wrong with the OS system calls made by both applications. the stack traces you sent me also seem to suggest this. Firefox uses its own internal programming to do everything which is why it still works. Unfortunately I don't know enough about development on mac to give you an answer from stack traces.

    my best guesses would be something wonky in your font configuration or possibly graphics subsystem, windowing toolkit, or filesystem. it's a long shot but try repairing permissions and check the filesystem on your main partition in disk utility. I notice the safari stack trace suggests a failure at 18 HTTPCookieStorage::lookupAndCopyCookies() "

    I've already repaired permissions and verified my HD. Everything seems to be fine with my HD, but the problem persists.

    Another friend suggested that it might be problems with a program(?) called "Webkit". How do I go about fixing that?

    Does anyone have any idea what is wrong with my computer and how to go about fixing it? I don't remember downloading anything between the span of it working and malfunctioning so I'm dumbfolded.

  2. #2

    chscag's Avatar
    Member Since
    Jan 23, 2008
    Keller, Texas
    2017 27" iMac, 10.5" iPad Pro, iPhone 6s+, iPhone 7+, Numerous iPods, High Sierra
    Are you able to use Firefox without problems? You seem to say that in your post above. We need to isolate this between something going on internally or with your connection so it's important to know if another browser is working OK.

    Also, you should update your version of Snow Leopard. The latest is 10.6.7 which you can get through Apple software updates.

  3. #3

    Member Since
    Mar 29, 2011
    My firefox is working fine, so I'm pretty sure it's an internal problem. Also, when I tried to update my software, the Software Update program bar stalls during the "checking" phase and quits automatically...

    This is a the error message:

    Process: Software Update [606]
    Path: /System/Library/CoreServices/Software Update
    Version: 4.0.5 (262)
    Build Info: SoftwareUpdate-2620000~1
    Code Type: X86-64 (Native)
    Parent Process: launchd [117]

    Date/Time: 2011-03-29 18:03:20.778 -0400
    OS Version: Mac OS X 10.6.5 (10H574)
    Report Version: 6

    Interval Since Last Report: 34335 sec
    Crashes Since Last Report: 19
    Per-App Interval Since Last Report: 281960 sec
    Per-App Crashes Since Last Report: 5
    Anonymous UUID: A3F0E22C-1E35-485C-B06C-9D197D566515

    Exception Type: EXC_CRASH (SIGABRT)
    Exception Codes: 0x0000000000000000, 0x0000000000000000
    Crashed Thread: 5

    Application Specific Information:
    abort() called
    *** Terminating app due to uncaught exception 'NSInvalidArgumentException', reason: '-[NSCFNumber length]: unrecognized selector sent to instance 0x1005a9d70'
    *** Call stack at first throw:
    0 CoreFoundation 0x00007fff86f137b4 __exceptionPreprocess + 180
    1 libobjc.A.dylib 0x00007fff8291b0f3 objc_exception_throw + 45
    2 CoreFoundation 0x00007fff86f6d110 +[NSObject(NSObject) doesNotRecognizeSelector:] + 0
    3 CoreFoundation 0x00007fff86ee591f ___forwarding___ + 751
    4 CoreFoundation 0x00007fff86ee1a68 _CF_forwarding_prep_0 + 232
    5 CFNetwork 0x00007fff81b04ba8 _ZL23stringIsHTTPHeaderCleanPK10__CFString + 51
    6 CFNetwork 0x00007fff81b047d4 CFHTTPCookieCreateWithProperties + 292
    7 CFNetwork 0x00007fff81b0457c _ZN13MemoryCookies28mutableCookiesForCookieDictsEP K9__CFArray + 136
    8 CFNetwork 0x00007fff81b044c4 _ZN13MemoryCookies23parseOldStyleCookieDataEPK9__C FArray + 24
    9 CFNetwork 0x00007fff81b04064 _ZN13MemoryCookies15inflateFromDataEPK8__CFData + 122
    10 CFNetwork 0x00007fff81b03b06 _ZN17DiskCookieStorage17syncStorageLockedEh + 440
    11 CFNetwork 0x00007fff81b03919 _ZN17DiskCookieStorage23copyDomainCookiesLockedEPK 10__CFStringh + 37
    12 CFNetwork 0x00007fff81b038d1 _ZN24PrivateHTTPCookieStorage17copyDomainCookiesEP K10__CFStringh + 61
    13 CFNetwork 0x00007fff81b03774 _ZN17HTTPCookieStorage20lookupAndCopyCookiesEPK10_ _CFStringS2_hP9__CFArray + 74
    14 CFNetwork 0x00007fff81b03421 _ZN17HTTPCookieStorage17copyCookiesForURLEPK7__CFU RLh + 209
    15 CFNetwork 0x00007fff81b032d4 _CFHTTPCookieStorageCopyRequestHeaderFieldsForURL + 109
    16 CFNetwork 0x00007fff81b02c2a _ZN12HTTPProtocol10addCookiesEP15__CFHTTPMessagePK 13_CFURLRequest + 312
    17 CFNetwork 0x00007fff81b027b6 _ZN12HTTPProtocol12createStreamEv + 650
    18 CFNetwork 0x00007fff81b0251f _ZN12HTTPProtocol19createAndOpenStreamEv + 59
    19 CFNetwork 0x00007fff81b00944 _ZN19URLConnectionLoader24loaderScheduleOriginLoad EPK13_CFURLRequest + 304
    20 CFNetwork 0x00007fff81b14a75 _ZN19URLConnectionLoader18loaderScheduleLoadEPK13_ CFURLRequest + 457
    21 CFNetwork 0x00007fff81b7783e _ZN19URLConnectionLoader26LoaderConnectionEventQue ue33processAllEventsAndConsumePayloadEP20XConnecti onEventInfoI12XLoaderEvent18XLoaderEventParamsEl + 270
    22 CFNetwork 0x00007fff81b007e3 _ZN19URLConnectionLoader13processEventsEv + 99
    23 CFNetwork 0x00007fff81afd748 _ZN17MultiplexerSource7performEv + 160
    24 CoreFoundation 0x00007fff86eb0401 __CFRunLoopDoSources0 + 1361
    25 CoreFoundation 0x00007fff86eae5f9 __CFRunLoopRun + 873
    26 CoreFoundation 0x00007fff86eaddbf CFRunLoopRunSpecific + 575
    27 Foundation 0x00007fff83dad07f +[NSURLConnection(NSURLConnectionReallyInternal) _resourceLoadLoop:] + 297
    28 Foundation 0x00007fff83d2e0a5 __NSThread__main__ + 1429
    29 libSystem.B.dylib 0x00007fff8399f536 _pthread_start + 331
    30 libSystem.B.dylib 0x00007fff8399f3e9 thread_start + 13

    Thread 0: Dispatch queue:
    0 libSystem.B.dylib 0x00007fff839662da mach_msg_trap + 10
    1 libSystem.B.dylib 0x00007fff8396694d mach_msg + 59
    2 0x00007fff86eae932 __CFRunLoopRun + 1698
    3 0x00007fff86eaddbf CFRunLoopRunSpecific + 575
    4 0x00007fff87d7091a RunCurrentEventLoopInMode + 333
    5 0x00007fff87d7071f ReceiveNextEventCommon + 310
    6 0x00007fff87d705d8 BlockUntilNextEventMatchingListInMode + 59
    7 0x00007fff80ddae64 _DPSNextEvent + 718
    8 0x00007fff80dda7a9 -[NSApplication nextEventMatchingMask:untilDate:inMode:dequeue:] + 155
    9 0x00007fff80da048b -[NSApplication run] + 395
    10 0x00007fff80d991a8 NSApplicationMain + 364
    11 0x0000000100001cc8 0x100000000 + 7368

    Thread 1: Dispatch queue:
    0 libSystem.B.dylib 0x00007fff8397f16a kevent + 10
    1 libSystem.B.dylib 0x00007fff8398103d _dispatch_mgr_invoke + 154
    2 libSystem.B.dylib 0x00007fff83980d14 _dispatch_queue_invoke + 185
    3 libSystem.B.dylib 0x00007fff8398083e _dispatch_worker_thread2 + 252
    4 libSystem.B.dylib 0x00007fff83980168 _pthread_wqthread + 353
    5 libSystem.B.dylib 0x00007fff83980005 start_wqthread + 13

    And it goes on..

  4. #4

    chscag's Avatar
    Member Since
    Jan 23, 2008
    Keller, Texas
    2017 27" iMac, 10.5" iPad Pro, iPhone 6s+, iPhone 7+, Numerous iPods, High Sierra
    Go here to download the Snow Leopard 10.6.7 combination update. LINK Install it and let see what happens. If you have any problems installing that update, you may be looking at complete reinstall of Snow Leopard. Make sure that you have a good backup on hand.

    The combo update may solve the problem with Safari and Skype, so try that first.

  5. #5

    Member Since
    Mar 29, 2011
    Thanks so much for the link. I installed the updates successfully. However, after the reset, the first thing that popped up after I logged back in was an error message saying "Softwareupdatechecker failed to open" or something like that. I think it opened and froze; hence the error message. That pretty much suggested that my Skype and Safari aren't fixed either (and they're not, still the same freezing problems).

    Is there no other way to fix this but to re-install my entire OS? I mean, I can live without Safari and Skype for now (I'm abroad at the moment), but it just bugs me not knowing why the **** my laptop became like this.

  6. #6

    chscag's Avatar
    Member Since
    Jan 23, 2008
    Keller, Texas
    2017 27" iMac, 10.5" iPad Pro, iPhone 6s+, iPhone 7+, Numerous iPods, High Sierra
    I don't have any other suggestion to offer. And I'm not even sure that reinstalling will solve the problem but it's worth a try. As I stated previously, before you try that make sure you have everything backed up.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Safari stopped working, help!
    By Dave Beddis in forum macOS - Operating System
    Replies: 1
    Last Post: 01-18-2015, 07:14 PM
  2. Right Click Select function Stopped working partially on safari
    By dougiedd in forum macOS - Operating System
    Replies: 4
    Last Post: 03-13-2014, 12:48 AM
  3. my skype suddenly stopped working!!
    By mia in forum macOS - Operating System
    Replies: 0
    Last Post: 02-27-2012, 09:53 AM
  4. Skype stopped working
    By Aggi in forum macOS - Operating System
    Replies: 4
    Last Post: 07-20-2011, 11:39 AM
  5. All Video Stopped Working in Safari (using iMac)
    By jillnewkirk in forum macOS - Apps and Games
    Replies: 0
    Last Post: 07-08-2010, 01:00 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts