I am running the above software on a PowerBook G4 17" (pre-intell)
and have recently encountered a problem.
After not using my epson perfection 3200 scanner for a while I opened photoshop through which I usually scan, and from there to import via epson scan. Epson scan opened fine but none of the adjustment controls were working, so I tried to scan anyway the scan would progress and near the end it would just stop downloading the information. I tried a very low res scan which came through fine but the previous problem persisted. Eventually I uninstalled epson scan and reinstalled it after which the scan software worked fine on its own. But when I tried to open photoshop it would start loading until it was "building TWAIN menu items" then just quit unexpectedly. I then uninstalled and reinstalled photoshop - following the uninstall procedure. The newly installed photoshop is still behaving in the exact same way - quitting while "building TWAIN menu items"

If anyone has some insight as to where the problem lies, I would greatly appreciate some advice on how to remedy this problem.