New To Mac-Forums?

Welcome to our community! Join the discussion today by registering your FREE account. If you have any problems with the registration process, please contact us!

Get your questions answered by community gurus Advice and insight from world-class Apple enthusiasts Exclusive access to members-only contests, giveaways and deals

Join today!

 
Start a Discussion
 

Mac-Forums Brief

Subscribe to Mac-Forums Brief to receive special offers from Mac-Forums partners and sponsors

Join the conversation RSS
OS X - Operating System General OS operation information and support

Snow Leopard 10.6.6 Vs. Epson Stylus Pro 7800


Post Reply New Thread Subscribe

 
Thread Tools
The Austringer

 
Member Since: Jan 18, 2011
Posts: 10
The Austringer is on a distinguished road

The Austringer is offline
Hi all, I am trying to connect my large format printer to my new iMac without much luck. I am using a FireWire 400 to 800 adapter from Neet along with my old FireWire cable and I've tried to print via Aperture and iPhoto but cannot get the mac to see the printer so I'm unable to 'add printer'. Can anyone tell me what I might be missing with this setup and why the Mac doesn't see the Epson 7800 printer. Thanks in advance, The Austringer.
QUOTE Thanks
Buzzard2010

 
Buzzard2010's Avatar
 
Member Since: Oct 22, 2010
Location: Sheffield, UK
Posts: 2,571
Buzzard2010 is just really niceBuzzard2010 is just really niceBuzzard2010 is just really niceBuzzard2010 is just really niceBuzzard2010 is just really nice
Mac Specs: iMac 21.5" i3 500gb HDD 4gb RAM OSX 10.9.2 - iPhone 5s 16gb

Buzzard2010 is offline
You could try the latest Epson drivers download from Apple, most of, if not all of these are included in 10.6.6, but it may be worth a shot.
Epson Printer Drivers v2.5.1 for Mac OS X v10.6

- Simon


If you have been helped, don't forget to use the Reputation system at the bottom of the users profile.
May 2011
Nominated: March 2011 & April 2011
QUOTE Thanks
chscag

 
chscag's Avatar
 
Member Since: Jan 23, 2008
Location: Fort Worth, Texas
Posts: 38,488
chscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond repute
Mac Specs: 27" iMac i5, 3.2 GHz, iPad 3, iPhone 5c, 3 iPods, OS X Mavericks

chscag is offline
Don't use the Firewire port or cables with the Epson. Instead, attach it via USB and your iMac should have no problem "seeing" it. You probably have something amiss with the firewire cables especially the part about adapting FW400 to FW800.

You should also do as advised in the previous reply and make sure you have all the correct drivers for your Mac.
QUOTE Thanks
The Austringer

 
Member Since: Jan 18, 2011
Posts: 10
The Austringer is on a distinguished road

The Austringer is offline
Hi, I've downloaded the Epson Drivers but no change. I changed the connection to the small square connection on the back of the printer and used the old standard USB connection on the Mac. It worked! so thanks for your input. Now I have different problems. Neither aperture or iphoto will transfer the roll paper info over to the printer. The printer is telling me I have the wrong choice of paper! What I need is a Mac/Epson genius who lives in the North Wales /Chester area who can set me up for a small fee. Anyway thanks for your time. The Austringer.
QUOTE Thanks
chscag

 
chscag's Avatar
 
Member Since: Jan 23, 2008
Location: Fort Worth, Texas
Posts: 38,488
chscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond repute
Mac Specs: 27" iMac i5, 3.2 GHz, iPad 3, iPhone 5c, 3 iPods, OS X Mavericks

chscag is offline
Thanks for posting back. That's a very nice professional printer you have there; let's hope you can get maximum usage out of it. Perhaps you can contact an Epson support person there in the UK to lend a hand.
QUOTE Thanks
The Austringer

 
Member Since: Jan 18, 2011
Posts: 10
The Austringer is on a distinguished road

The Austringer is offline
Hi chscag, Epson support are next on my list. Your right it's a very nice printer, but I do have to get a grip on the setup. At 80 per ink cartridge its not funny if the results are less than perfect. Thanks, The Austringer.
QUOTE Thanks

Post Reply New Thread Subscribe


« help with disk image | Trying again on "can't login" »
Thread Tools

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off
Forum Jump

Similar Threads
Thread
Thread Starter
Forum
Replies
Last Post
Upgrading Tiger to (Leopard, Snow Leopard or...HELP!) wilkesep3 OS X - Operating System 5 01-09-2011 03:42 PM
Logic Pro 8 with Snow Leopard cdjohnny Music, Audio, and Podcasting 1 10-17-2010 06:16 PM
Pro Tools on Imac Snow Leopard Nicola of Earth Music, Audio, and Podcasting 5 10-08-2010 12:44 PM
Upgrade from Leopard to snow Leopard in Mac Pro wil OS X - Operating System 4 09-15-2010 03:24 AM
Techtool Pro Utility and Snow Leopard Mac-Meri OS X - Apps and Games 4 09-28-2009 07:16 PM

All times are GMT -4. The time now is 07:10 AM.

Powered by vBulletin
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
X

Welcome to Mac-Forums.com

Create your username to jump into the discussion!

New members like you have made this community the ultimate source for your Mac since 2003!


(4 digit year)

Already a member?