New To Mac-Forums?

Welcome to our community! Join the discussion today by registering your FREE account. If you have any problems with the registration process, please contact us!

Get your questions answered by community gurus Advice and insight from world-class Apple enthusiasts Exclusive access to members-only contests, giveaways and deals

Join today!

 
Start a Discussion
 

Mac-Forums Brief

Subscribe to Mac-Forums Brief to receive special offers from Mac-Forums partners and sponsors

Join the conversation RSS
OS X - Operating System General OS operation information and support

enable loopback connections


Post Reply New Thread Subscribe

 
Thread Tools
stevieg_83

 
Member Since: Jan 05, 2011
Posts: 4
stevieg_83 is on a distinguished road

stevieg_83 is offline
Hi folks, hopefully someone will be able to help.

At work I run on Windows XP, I'm able to connect to my home network through SSH and onto another Windows box with remote desktop.

From that Windows box I'm then able to use VNC to remote desktop to my Mac

However, I'd rather just connect from my work PC to the Mac. I added some port forwarding rules on the router and also some tunnel rules for SSH but when I try to connect using VNC I get "Sorry, loopback connections are not enabled".

How can I enable loopback connections and will that solve my problem?

Thanks in advance,
Steven
QUOTE Thanks
MacsWork

 
MacsWork's Avatar
 
Member Since: May 22, 2005
Location: Closer than you think.
Posts: 2,132
MacsWork is just really niceMacsWork is just really niceMacsWork is just really niceMacsWork is just really niceMacsWork is just really nice
Mac Specs: Performa 6116 2GBSCSI 8MB OS 7.5.3

MacsWork is offline
If you are forwarding 22 on your home router to the Mac use SSHTunnelManager to create a tunnel sending 5901 to 5900 on your home's public IP. Then use VNC://127.0.0.1:5901 to connect to the remote Mac through the SSH Tunnel.

I have set my ssh daemon up listening on 443 however to avoid outbound firewall rules blocking 22 when I'm on public networks. 443 is usually open outbound everywhere.
QUOTE Thanks
stevieg_83

 
Member Since: Jan 05, 2011
Posts: 4
stevieg_83 is on a distinguished road

stevieg_83 is offline
yeah I've got Putty forwarding 5901 to 5900 and also using 443 for SSH for the reason you said. However, still getting "loopback not enabled".
QUOTE Thanks
MacsWork

 
MacsWork's Avatar
 
Member Since: May 22, 2005
Location: Closer than you think.
Posts: 2,132
MacsWork is just really niceMacsWork is just really niceMacsWork is just really niceMacsWork is just really niceMacsWork is just really nice
Mac Specs: Performa 6116 2GBSCSI 8MB OS 7.5.3

MacsWork is offline
There is no Putty for Mac. Why is Putty doing the 5901 to 5900?
QUOTE Thanks
stevieg_83

 
Member Since: Jan 05, 2011
Posts: 4
stevieg_83 is on a distinguished road

stevieg_83 is offline
I'm not connection from Mac to Mac.

I'm connecting from XP to Mac - hence I need an SSH client on Windows (Putty).
QUOTE Thanks
MacsWork

 
MacsWork's Avatar
 
Member Since: May 22, 2005
Location: Closer than you think.
Posts: 2,132
MacsWork is just really niceMacsWork is just really niceMacsWork is just really niceMacsWork is just really niceMacsWork is just really nice
Mac Specs: Performa 6116 2GBSCSI 8MB OS 7.5.3

MacsWork is offline
In order for the loopback to work the tunnel must be from Mac to Mac. Having the remote Mac ssh-ing to the XP SSH server does nothing for the remote Mac to tunnel in to the host Mac via a loopback, just the XP machine.

If your router supports port triggering enable remote management on the Mac and setup triggering on the router to pass traffic directly to the Mac to create the Mac to Mac tunnel with SSHTunnelManager on the remote Mac. Use whatever port you want, most likely 22 if you haven't change the listening daemon on the Mac. Then and only then will the loopback work.

The loopback can only forward local traffic if the tunnel is originating from itself.
QUOTE Thanks
javamac

 
Member Since: Mar 04, 2011
Posts: 1
javamac is on a distinguished road

javamac is offline
I also got the "Sorry, loopback connections are not enabled" error messages when trying to tunnel using TightVnc. This happened right after I upgraded. I found a solution. Insteading of VNC's to 127.0.0.1, change the default port from 5900 to 5901, so in the tightVNC box you will type: localhost:1 (It didn't work when I just used localhost)

Of course you have to set up Putty as well to do the forwarding:
In putty, under ssh, and then under tunnels, add this:
source port: 5901, destination: my-remote-server-that-is-running-vnc-server.com:5900, and then start up putty and then log in.
QUOTE Thanks

Post Reply New Thread Subscribe


« G4 Quicksilver not taking Tiger upgrade from Panther. Help? | iMac taking forever to boot »
Thread Tools

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off
Forum Jump

Similar Threads
Thread
Thread Starter
Forum
Replies
Last Post
Enable WindowBuffer Compression in Tiger? willwinuk OS X - Operating System 0 05-22-2009 03:22 PM
Safari Enable Plugins markjwiggins OS X - Apps and Games 1 12-12-2008 06:08 AM
Mac newbie question - enable root access mac_newbie OS X - Operating System 5 07-04-2008 03:12 AM
Need suggestions re USB connections PapaNoHair Apple Desktops 10 04-06-2008 06:22 PM
maximum open network connections? BT related wingk1314 OS X - Operating System 2 01-31-2008 10:08 PM

All times are GMT -4. The time now is 03:30 AM.

Powered by vBulletin
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
X

Welcome to Mac-Forums.com

Create your username to jump into the discussion!

New members like you have made this community the ultimate source for your Mac since 2003!


(4 digit year)

Already a member?