New To Mac-Forums?

Welcome to our community! Join the discussion today by registering your FREE account. If you have any problems with the registration process, please contact us!

Get your questions answered by community gurus Advice and insight from world-class Apple enthusiasts Exclusive access to members-only contests, giveaways and deals

Join today!

 
Start a Discussion
 

Mac-Forums Brief

Subscribe to Mac-Forums Brief to receive special offers from Mac-Forums partners and sponsors

Join the conversation RSS
OS X - Operating System General OS operation information and support

Disable write-caching on removable drives?


Post Reply New Thread Subscribe

 
Thread Tools
SUparJErk

 
Member Since: Jan 03, 2011
Posts: 1
SUparJErk is on a distinguished road

SUparJErk is offline
I have a MacBook Pro running OS X 10.6.5, and would like to disable write-caching (asynchronous I/O) on removable drives so as to help prevent data corruption, but have so far been unsuccessful. Here's what I have tried so far:

- Looked for an Apple-provided setting in System Preferences -- doesn't seem to be anything there.

- Looked for /etc/fstab to change default mount options. /etc/fstab.hd exists, but contains only a comment telling me the file does nothing and should be ignored.

- Found this section in /etc/autofs.conf:

Code:
# Mount options.
# A string containing a comma-separated list of mount options
# that will be applied, by default, to all mounts done by automountd(8).
# The options for a particular mount can override these options.
# This controls the same default mount options that the -o option to
# automountd(8) controls.
AUTOMOUNTD_MNTOPTS=nosuid,nodev
I tried changing the final line to read:
Code:
AUTOMOUNTD_MNTOPTS=nosuid,nodev,noasync
but even after a reboot, plugging in a drive, and running the "mount" command in the Terminal, the drive was mounted without the noasync option.

- I tried just manually mounting the drive in Terminal with the following command:
Code:
sudo mount -o noasync -t hfs /dev/disk1s3 temp
But this gives me the following error:
Code:
mount_hfs: -o async: option not supported
This one is particularly baffling, as the -o option I passed in was definitely "noasync", not "async". Also, the man page for mount clearly documents that "async" and "noasync" are both supported options. Why are they not functioning??

I welcome any suggestions. Thanks in advance.
QUOTE Thanks

Post Reply New Thread Subscribe


« how to change macbook identity | bootcamp Vista help? »
Thread Tools

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off
Forum Jump

Similar Threads
Thread
Thread Starter
Forum
Replies
Last Post
DVD R or DVD RW? (Difference?) Joeytpg Switcher Hangout 17 03-24-2010 10:09 AM
Those wanting to write to NTFS drives 05GT OS X - Apps and Games 4 09-20-2008 11:48 AM
can't write to external drives? bsxiong OS X - Operating System 2 11-18-2007 11:39 AM
Issues with external hard drives: Help Please! NJRonbo Other Hardware and Peripherals 5 01-23-2007 02:14 PM
Seagate 7200.10 incompatible? Detailed benchmarks! otheronenorehto Apple Desktops 5 01-15-2007 04:38 AM

All times are GMT -4. The time now is 03:51 PM.

Powered by vBulletin
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
X

Welcome to Mac-Forums.com

Create your username to jump into the discussion!

New members like you have made this community the ultimate source for your Mac since 2003!


(4 digit year)

Already a member?