Results 1 to 5 of 5
  1. #1

    Member Since
    Jan 01, 2011
    external HD won't mount (OS 10.5.8)
    Hi everyone,

    I searched similar topics on this forum as well as numerous other resources available throughout the web, but I still haven't managed to solve my problem.

    Just today I found out that I can no longer see my external HD (Seagate FreeAgent Desktop, 500gb). The disk is approx three years old, but so far I have never had any issues with it. Important information: for the past couple of weeks, every now and then, I would receive a OS "Device Removal" message (as in: improper removal), although I wouldn't touch anything. The drive was connected via an unpowered USB hub, so one might think that the message was due to insufficient power, but this type of HD has a power brick. However, I do concur that the problem was probably caused by poor quality USB hub.

    Checks I performed and facts:

    - The drive doesn't appear on desktop nor in finder
    - The drive doesn't appear in terminal "ls /volumes" command
    - The drive does appear in Disk Utility, but it's partition is greyed out.
    - The partition won't mount in Disk Utility.
    - Disk Utility First Aid hasn't detected any problems with the disk or - to be more exact - it did once and fixed it. Further checks returned no errors/problems.
    - No information available in "Owners Enabled" in Desktop Utility (marked: "-")
    - Seagate Disk Utility won't see it neither.
    - Connecting it to a different USB port and with a different USB cable doesn't help.
    - Logging into the system with "root user" and trying to change the access to the drive yielded no positive results. The disk doesn't appear in finder, and although it does appear in Disk Utility there is no option to change access.

    I am now downloading Disk Warrior as I have read elsewhere that it might help. Will update on any results or lack thereof.

    In the meantime - does anyone have any idea what to do?


  2. #2

    baggss's Avatar
    Member Since
    Oct 10, 2004
    27" 3.4 Ghz i7 iMac-13" C2D Macbook-OSX 10.10.2 -64Gb iPad 2-64 Gb iPhone 6+-ATV 2-14Tb of Storage
    When you say a different USB port and cable, does that mean you tried a different port on the USB hub or tried plugging it into a USB port on your Mac itself? If not, then give that a try.

    Since disc utility sees it, are you able to use that to repair the disc? Does the "Mount" button at the top of Disc utility show as an option? In disc utility do you see two drives for the volume (the drive and the partition) or just one?

  3. #3

    Member Since
    Jan 01, 2011
    hi baggss, thanks for your reply.

    - I tried connecting the disk via a working (checked with another ext. hd) USB cable to a computer USB port. not hub.
    - as I mentioned, the Disk Utility sees the disk and the partition, but the partition is greyed out. In both cases the "mount" button is activated, but upon clicking returns an error message (to the extent of: "can't mount").

    Now good news

    Disk Warrior kicked the sh** out of the bugger! What a lovely piece of software! It took no more than 5 minutes! Case closed. Alarm called off.

    Happy New Year!

  4. #4

    Member Since
    Dec 13, 2009
    iMAc 1.8GHz PowerPC G5, 2GB, 10.5.8
    Quote Originally Posted by marcinito View Post
    ...Now good news

    Disk Warrior kicked the sh** out of the bugger! What a lovely piece of software! It took no more than 5 minutes! Case closed...
    Always nice to hear good news! But what exactly did it let you do? (What did it let you change/fix so you could see the drive?). Just curious, good info I'll hopefully never need to know ha ha

  5. #5

    Member Since
    Jan 01, 2011
    3 folders had a directory entry with an incorrect flag that was repaired.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Script to mount volume (external drive or disk image) which won't mount..?
    By MaccIngs in forum OS X - Development and Darwin
    Replies: 2
    Last Post: 09-09-2011, 10:05 PM
  2. External HD Won't Mount
    By Syze in forum OS X - Operating System
    Replies: 1
    Last Post: 07-26-2011, 04:00 PM
  3. Updated OS, Now External HD Won't Mount
    By jyosha in forum Other Hardware and Peripherals
    Replies: 2
    Last Post: 10-24-2010, 08:57 PM
  4. External Won't Mount
    By henryo11 in forum Other Hardware and Peripherals
    Replies: 13
    Last Post: 02-22-2007, 06:41 AM
  5. External HD won't mount
    By macAttack in forum Other Hardware and Peripherals
    Replies: 3
    Last Post: 08-21-2005, 10:45 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts