Results 1 to 3 of 3

Thread: powerbook G4

  1. #1

    Member Since
    Jan 21, 2007
    powerbook G4
    HI I need some help i have been given a powerbook G4 by my son inlaw to fix as it won't boot
    The situation is when you power on you hear the chimes then a grey screen with what looks like a stop sign in grey and it just sits there.
    Also there is an osx disk stuck inside the tray which i can't figure out how to open There must be a key stroke combination to open the tray but i have no idea what it is. Assuming someone can tell me how to eject the disk what do i do then to get this up and running again

  2. #2

    louishen's Avatar
    Member Since
    Oct 22, 2007
    Mac Mini Core i7 2012 | White 2009 MacBook 2 Ghz | 733 Mhz G4 Quicksilver
    To eject the disk, hold down the mouse button at start-up (or the Trackpad button). That will force eject the disk

    Find out what disk you have in there, is it a grey restore disk or is it another type.

    Just a thought as well, if a valid OSX install disk is already in there, first try a restrat and hold down the C key straight after the start-up chime, that should force the G4 to boot from the optical disc.
    Member of the Month September 2008 & August 2012 | Found advice useful? use the rep system

  3. #3

    Member Since
    Jan 21, 2007
    HI louishen thanks for your reply tried both of your suggestions but neither worked,the only difference was instead of a grey stop sign i am left with the black apple

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 2
    Last Post: 03-10-2010, 12:54 PM
  2. Transfer Music from Powerbook 2 Powerbook?
    By randomfactor in forum Apple Notebooks
    Replies: 4
    Last Post: 10-30-2005, 04:22 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts