New To Mac-Forums?

Welcome to our community! Join the discussion today by registering your FREE account. If you have any problems with the registration process, please contact us!

Get your questions answered by community gurus Advice and insight from world-class Apple enthusiasts Exclusive access to members-only contests, giveaways and deals

Join today!

 
Start a Discussion
 

Mac-Forums Brief

Subscribe to Mac-Forums Brief to receive special offers from Mac-Forums partners and sponsors

Join the conversation RSS
OS X - Operating System General OS operation information and support

MacBook running slow and safari doesn't load


Post Reply New Thread Subscribe

 
Thread Tools
Macmaxxx

 
Member Since: Dec 30, 2010
Posts: 6
Macmaxxx is on a distinguished road

Macmaxxx is offline
Hi
I'm having a problem with my MacBook, it's running very slowly when you open some applications. Safari opens and loads a little bit then the rainbow wheel comes up and the MacBook freezes and only occasionally if you wait long enough can you force quit it and then that freezes. Also the software updater also freezes yet word, PowerPoint, excel and firefox all still work fine. I've tried uninstalling and reinstalling safari but same problem still happens.
Please help me.
QUOTE Thanks
immanuelsun

 
Member Since: Dec 29, 2010
Posts: 9
immanuelsun is on a distinguished road

immanuelsun is offline
only safari? have you tried other browsers like chrome, firefox?
by the way what version is your safari? 4.0.1 or 5.0.2 or ......?
QUOTE Thanks
roflitskyle

 
roflitskyle's Avatar
 
Member Since: Dec 23, 2010
Location: United States
Posts: 544
roflitskyle has a spectacular aura about
Mac Specs: MacBook Unibody 13" 150 GB HDD

roflitskyle is offline
Try reseting Safari in Safari>Reset Safari>Reset
Hopefully that will work.
QUOTE Thanks
Macmaxxx

 
Member Since: Dec 30, 2010
Posts: 6
Macmaxxx is on a distinguished road

Macmaxxx is offline
Hi i tried restarting but it did nothing it wouldn't even finish the restart. Even tried deleting the app using appdelete and reinstalling but also did not work. Its safari 5.0.3 and tried updating but get error code -1001 which is something to do with the internet connection i believe. Firefox works fine its just safari.
QUOTE Thanks

Post Reply New Thread Subscribe


« MicroSD Error code -43 | Multiple docks at the SAME time »
Thread Tools

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off
Forum Jump

Similar Threads
Thread
Thread Starter
Forum
Replies
Last Post
Safari on iMac G5 running slow, iMac running hot j_m_damon OS X - Operating System 2 07-08-2010 06:22 PM
Macbook with safari running slow dropping connection gliczarow OS X - Operating System 3 06-12-2010 09:31 AM
macbook is running slow all of a sudden zerofantasym OS X - Operating System 15 06-26-2009 01:55 PM
New MacBook...running slow...! krewelement394 OS X - Operating System 1 01-04-2009 01:44 PM
Safari AND Firefox running slow 5litreLX OS X - Apps and Games 18 10-18-2006 09:29 AM

All times are GMT -4. The time now is 03:38 PM.

Powered by vBulletin
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
X

Welcome to Mac-Forums.com

Create your username to jump into the discussion!

New members like you have made this community the ultimate source for your Mac since 2003!


(4 digit year)

Already a member?