New To Mac-Forums?

Welcome to our community! Join the discussion today by registering your FREE account. If you have any problems with the registration process, please contact us!

Get your questions answered by community gurus Advice and insight from world-class Apple enthusiasts Exclusive access to members-only contests, giveaways and deals

Join today!

 
Start a Discussion
 

Mac-Forums Brief

Subscribe to Mac-Forums Brief to receive special offers from Mac-Forums partners and sponsors

Join the conversation RSS
OS X - Operating System General OS operation information and support

Help Configuring Hotkeys


Post Reply New Thread Subscribe

 
Thread Tools
zigs16

 
Member Since: Dec 27, 2010
Posts: 3
zigs16 is on a distinguished road

zigs16 is offline
Hi, sorry I haven't contributed much to the forums yet but I have a question about configuring the extra F hotkeys on my new keyboard. I'm using a macbook with snow leopard and I finally got the external keyboard with the numberpad.

I'm often typing in equations into the computer but its a nuisance to always type "x^" and "( )" constantly from the numberpad. I tried playing with the system prefs for the keyboard but I can't find a way to map F16 to be "x^", F17 to be "(" and F18 to be ")".

Any suggestions?

When I try to map it out, I think its supposed to be a command. Is it possible to make it just reconfigure the key location?
QUOTE Thanks
zigs16

 
Member Since: Dec 27, 2010
Posts: 3
zigs16 is on a distinguished road

zigs16 is offline
Figured it out with the help of a few different sources. Figured I'd explain it for anyone else out there who might want help.

First I had to make a workflow in automator:

1. Get specified text - "my text"
2. Copy to clipboard
3. Run applescript:
on run {input, parameters}
tell application "Google Chrome"
activate
tell application "System Events"
keystroke "v" using command down
end tell
return input
end tell
end run

Then I saved it as "run x" and added it to my keyboard shortcuts.

Small delay, but that's understandable because it has to run the process. If theres anything more efficient than what I did, please let me know, but this works fine for me.
QUOTE Thanks

Post Reply New Thread Subscribe


« New hardrive install | Font in Finder somehow changed »
Thread Tools

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off
Forum Jump

Similar Threads
Thread
Thread Starter
Forum
Replies
Last Post
Configuring an Airport card for my stone age mother addie Internet, Networking, and Wireless 0 10-21-2010 11:39 PM
Hotkeys changed? OS 10.5.8 julianess OS X - Operating System 9 08-01-2010 01:30 PM
My Spaces hotkeys have just stopped working Cakebread Switcher Hangout 0 04-07-2009 03:30 AM
Configuring Gmail IMAP labels/folders on iPhone & Apple Mail 3.0 m021478 OS X - Apps and Games 0 04-11-2008 01:03 PM
having trouble configuring system mayam OS X - Operating System 3 07-01-2006 08:43 PM

All times are GMT -4. The time now is 04:00 PM.

Powered by vBulletin
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
X

Welcome to Mac-Forums.com

Create your username to jump into the discussion!

New members like you have made this community the ultimate source for your Mac since 2003!


(4 digit year)

Already a member?