New To Mac-Forums?

Welcome to our community! Join the discussion today by registering your FREE account. If you have any problems with the registration process, please contact us!

Get your questions answered by community gurus • Advice and insight from world-class Apple enthusiasts • Exclusive access to members-only contests, giveaways and deals

Join today!

 
Start a Discussion
 

Mac-Forums Brief

Subscribe to Mac-Forums Brief to receive special offers from Mac-Forums partners and sponsors

Join the conversation RSS
OS X - Operating System General OS operation information and support

Migration Assistant ERROR PROBLEM BUG


Post Reply New Thread Subscribe

 
Thread Tools
koppenhoefer

 
Member Since: Dec 23, 2010
Location: Switzerland
Posts: 5
koppenhoefer is on a distinguished road
Mac Specs: iMac11,3 Intel Core i5 2.8GHz 16GB

koppenhoefer is offline
Hello,

I am trying (failing) to get MigrationAssistant to migrate my files from my old (mac mini) to my new (iMac) OS X machine (both machines are running 10.6.5 having just re-run SoftwareUpdate and rebooting both machines).

MA application successfully launches, and is able to see the old machine (connected via firewire with the old machine in TargetMode)(the resumé of SelectItemsToMigrate shows disk-usages that correctly correspond to what I saw on the old machine before I booted it in target-mode).
However, clicking on 'Continue' has no effect (beyond the button going temporarily blue).

Has anyone had troubles with MigrationAssistant in this way… and solved it?
Or is MigrationAssistant broken under 10.6.5?

Best regards,
/Shawn

p.s. here is some background info:

BACKGROUND
1. The Settings choice shows 171KB and the others show calculating.
2. The 'Remaining space' shows 919.9GB
3. After about 2minutes, Users shows 48.7GB,.. the others show calculating
4. After another 2minutes, Other files and Folders shows 14.9GB
5. After another 2minutes, Applications shows 18.4GB
6. The button CONTINUE is now black instead of grey (so clickable?)

THE PROBLEM
When I click on 'CONTINUE' the button temporarily goes blue (as usual) and then back to unpushed mode (but still black.. clickable). Pushing the button AGAIN has the same effect.
Note that the MA application is not frozen, (attested to by the fact that I can open the little triangles under Users and Settings to reveal more details… and/or click on GoBack ).

OTHER OBSERVATIONS
TOP:
If I go into the terminal and use 'top', I see two tasks related to Migration.
MigrateTool (using 0%cpu)
MigrationAssistant (using 0%cpu)

PS
If use ps -axl, they both show they are sleeping ('S')(less than 20seconds)

DISK USE NOPE
I cannot hear the hard disk of the new machine (a new imac) making noise.
I cannot hear the hard disk of the old machine (mac mini) making noise.
Getting INFO on the newmachine disk shows 11,721,187,328 bytes and this number is not changing (even if I close the info window and run it again).
Running DF in the terminal shows 22380944 blocks used and this this number doesn't change.

WHAT ELSE I'VE TRIED
1. Let the machine 'work' for a long time.
NO JOY. After two days of sitting there, no change.

2. Use MA across the network.
NO JOY: The behavior is exactly the same.

3. Use a TimeMachine backup to install.
NO JOY: TimeMachine says that unless the backup was made on the iMac (it wasn't… it was made on the MacMini) I shouldn't use it to install on the iMac.

4. Create an account that has administrator access
NO JOY: The entire process IS ALREADY using an admin account.

5. Make the hard-drive on the new machine the same name as the hard-drive on the old-machine.
NO JOY: The behavior is the same

6. Run DiskUtility to ensure there are no problems with the disk on the old machine.
NO JOY: Disk Utility is saying that the old machine's disk is spiffy.

7. Run DiskUtily to ensure the disk on the new machine is ok.
NO JOY: DU tells me the disk is fine.

8. Make sure the size of the old disk is smaller than the size of the new.
NO JOY: The old disk is 119.69GB and the new disk is 1TB.

9. Make sure the format of the two disks is the same.
NO JOY: The old one is Mac OS Extended (Journaled), the new one is also Mac OS Extended (Journaled).

10. Make sure that a past try to get MA to succeed didn't actually work.
NO JOY. Comparing the contents of the Users/ folder on the old mac shows 10 user folders (including ftp git Shared and a few real users) and on the new mac only 2 users (admin and Shared).

11. Give up and 'sudo ditto'.
NO WAY… From the article I read here (Tech Tails #659: eWaste Roundup Recap, When Migration Assistant Fails, ASLServer vs. My Workstation) it seems that this is only an option for copying user folders, and won't get you your applications etc. UGH!

12. Give up and reinstall everything using installers.
NO WAY DUDE!… I thought the whole point of MigrationAssistant was to avoid that pain.
Surely, surely someone has found a solution?!
I can't believe that a spanking new mac with a virgin OS installation has problems with this.

13. Reinstall your OS X on the new machine and try again.
NO JOY: Using the OS X installation DVD I tried this. The newly installed OS X boots just fine… but the MA process fails exactly as before.

14. Use MigrationAssistant the other direction.
I just thought of that now.. maybe that will work.
QUOTE Thanks
MacsWork

 
MacsWork's Avatar
 
Member Since: May 22, 2005
Location: Closer than you think.
Posts: 2,146
MacsWork is just really niceMacsWork is just really niceMacsWork is just really niceMacsWork is just really niceMacsWork is just really nice
Mac Specs: Performa 6116 2GBSCSI 8MB OS 7.5.3

MacsWork is offline
Are you logged into the account that you are trying to migrate to?

You can't do that.

Create a temp admin account, delete the account created with setup assistant, reboot, rerun MA.
QUOTE Thanks
bobtomay

 
bobtomay's Avatar
 
Member Since: Dec 22, 2006
Location: Texas, where else?
Posts: 25,135
bobtomay has a reputation beyond reputebobtomay has a reputation beyond reputebobtomay has a reputation beyond reputebobtomay has a reputation beyond reputebobtomay has a reputation beyond reputebobtomay has a reputation beyond reputebobtomay has a reputation beyond reputebobtomay has a reputation beyond reputebobtomay has a reputation beyond reputebobtomay has a reputation beyond reputebobtomay has a reputation beyond repute
Mac Specs: 15" MBP 2.33 C2D 256 4GB, MBA 13" i7 1.8, MB 2.0 2GB, Nano 4th, 3GS, iPad 1

bobtomay is offline
4 years and I didn't know that. Of course, I haven't had to replace my first Mac yet either...

I cannot be held responsible for the things that come out of my mouth.
In the Windows world, most everything folks don't understand is called a virus.
QUOTE Thanks
koppenhoefer

 
Member Since: Dec 23, 2010
Location: Switzerland
Posts: 5
koppenhoefer is on a distinguished road
Mac Specs: iMac11,3 Intel Core i5 2.8GHz 16GB

koppenhoefer is offline
@Macswork probably hit the right answer...


I have since made some progress! Yes yes yes....

15. Don't use the same accountname as on old mac.
On the new mac, work from an account with a different name than any account on the old mac.
NO JOY: I created a new user called admin2 (which doesn't exist on the old mac). I logged out, logged in under admin2 and deleted the admin1 acccount.
Migration Assistant still doesn't behave any differently.

16. Don't copy the user folders
In the choice of what to migrate, REMOVE users and 'other files' from the list.
SUCCESS!

Hitting 'continue' brought me to a screen telling me the Applications folder is being transferred (est.38 minutes).

I'll let this go to its conclusion and then try migrating the users and/or otherfiles independently. And failing that, use the 'sudo ditto' approach.
QUOTE Thanks
koppenhoefer

 
Member Since: Dec 23, 2010
Location: Switzerland
Posts: 5
koppenhoefer is on a distinguished road
Mac Specs: iMac11,3 Intel Core i5 2.8GHz 16GB

koppenhoefer is offline
ok... After having successfully the Applications and Settings and OtherFilesAndFolders I ran Migration Assistant only on the Users folder (the whole folder)...

NO JOY... MA obstinately refuses to accept my clicking on the CONTINUE button.

but...

If I open the little triangle, on Users, and remove the not-really-users accounts... then EVERYTHING BEHAVES and Migration Assistant seems to work. :-) The not-really-users accounts that I removed are: ftp git privoxy squid temp and friends.

The migration of the other 5 really-truly-are user accounts is moving right along (2hours31 more minutes to go)... and then I'll know whether this really worked or not.

Best regards,
Shawn
QUOTE Thanks
koppenhoefer

 
Member Since: Dec 23, 2010
Location: Switzerland
Posts: 5
koppenhoefer is on a distinguished road
Mac Specs: iMac11,3 Intel Core i5 2.8GHz 16GB

koppenhoefer is offline
Ok... bad news first.... but the story has a HAPPY ENDING...

RESULTS OF LAST EFFORT:
After the migation completed, I rebooted and was welcomed with a grey screen and ugly message saying the OS was unusable and to please reinstall from the DVD (sorry... I didn't retain the exact message).

DIFFERENT APPROACH : USE CCC
So tried a different approach using CCC (Carbon Copy Cloner) from the MacMini (mounting the new iMac in target mode onto the macMini) - I first used DiskUtility to reformat the iMac drive... and then just cloned directly onto it. It took about 5 hours for CCC to finish. On reboot, SAME ERROR MESSAGE (arghhh).

WHAT ABOUT MA DURING NEW INSTALLATION
I reinstalled from the DVD (reformatting the disk as well). As part of the reinstallation process, migrating from a firewire-connected computer is offered (seemingly identical process to Migration Assistant). Several hours later, this completed and I was able to reboot with success... BUT ONLY TEMPORARILY: the login process crashed at one point as the startup items started appearing. Subsequent rebooting failed (this time failing long before any login windows appeared).

THE SOLUTION THAT WORKED
Solution: Reboot in safe-mode (while rebooting wait for the chime sound and then hold down the shift key). Investigating /var/log/system.log shows many problems such as:

dyld_shared_cache_x86_64") => -1 (errno: 2)
mDNS_SetSecretForDomain: ERROR: Could not convert shared secret from base64: domain . key shawn.
AppleUSBCDC.kext is not valid; omitting from mkext.
PACESupportFamily.kext is not valid; omitting from mkext.
Can't load AppleSMBusPCI.kext - validation problems.
etc.
etc.

So I removed everything from /Library/StartupItems (DynDNSUpdate Privoxy, PACESupport, VirtualBox ParallelsDesktopTransporter tun tap CoreDuoTemp BRESINKx86Monitoring Wireshark PureFTPD) and rebooted. SUCCESS! IT WORKED!

Everything SEEMS to be fine now... except for a persevering message from mysqldabout mysqld_safe not being present, LittleSnitch rules being missing, and OSXvnc-server failing.
So next step will be to reinstall the pieces that I've removed and keep my fingers crossed that the machine continues to successfully boot.

oof
QUOTE Thanks
makingchange

 
Member Since: Dec 05, 2010
Posts: 8
makingchange is on a distinguished road

makingchange is offline
set up a new account? do you use a term like what, not guest right? And do the operating systems have to be the same? Will this solve my acrobat professional problem and migrate it over? I dunno, but any help would help me. So, this would be a new account, as in login to osx and not osx server login at the turn on of the computer?

I'm losing myself, trying to stay afloat in this!!!
QUOTE Thanks

Post Reply New Thread Subscribe


« Can somebody tell me what is going on here?.. | Can't set wallpaper »
Thread Tools

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off
Forum Jump

Similar Threads
Thread
Thread Starter
Forum
Replies
Last Post
Migration assistant miscalculating account size pdwallace OS X - Operating System 1 11-27-2010 07:05 AM
migration assistant won't recognize my hard drive dEd2 OS X - Operating System 5 08-28-2010 11:15 AM
migration assistant - from Mac Mini to iMac grey owl OS X - Operating System 2 12-27-2009 11:09 PM
Migration Assistant Tip chiselneck OS X - Operating System 1 11-24-2006 05:55 AM

All times are GMT -4. The time now is 10:51 AM.

Powered by vBulletin
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
X

Welcome to Mac-Forums.com

Create your username to jump into the discussion!

New members like you have made this community the ultimate source for your Mac since 2003!


(4 digit year)

Already a member?