Results 1 to 3 of 3

Thread: Time Machine Restore Issues - Kind of Odd...

  1. #1

    XJ-linux's Avatar
    Member Since
    Jul 02, 2007
    Going Galt...
    Question Time Machine Restore Issues - Kind of Odd...
    The short of it...
    Does the act of performing a Time Machine restore from an externally attached HDD change anything about the characteristics, identification, boot/EFI settings of that drive during the restore process? My external HDD was used to perform a TM restore to a Mac Mini. the restore appeared to be unsuccessful. The Mini would not boot after the restore and the external drive will not spin up after the restore. After installing a new HDD into the Mini, the external drive still will not work, even though the Mini is now fine. Any input, theories or suggestions would be great. The goal is to find a way to access the external drive so that it's contents can be migrated to new hardware. I'm ordering a RAID 1 device from OWC, so snagging the data is more important to me than the drive being viable again for future extended use.

    The long of it...
    My 2009 Mac Mini 3,1 running 10.6.5 was unresponsive on the network so I rebooted it. I thought perhaps there might be a network issues as the Comcast DNS issue had made my network unstable for a time and perhaps there as another Comcast issue. I noticed the Mini couldn't be reached via Desktop sharing and that my MBP's icon for Time Machine showed the "!" symbol indicating the remote TM backup disk was inaccessible. At reboot, it eventually hung on the grey start up screen after the Apple logo and at the spinning loading wheel. I rebooted via the OS X installation media and ran the verify and repair Disk Utility routines - no problem. I then ran the check and repair permissions routines and both took about 2 seconds to complete with no errors - not good. The first sign of a bad HDD which I should have taken to heart. It should take at least a minute if not more on a 7200rpm 100GB Seagate HDD.

    Subsequent reboots did nothing but hang, so I decided to restore form the Time Machine backup which is connected to this system via FW800. All went fine until it completed and the display had the "smoky colored shade" slide down from the top saying "You need to restart your computer..." in about 5 languages. I restarted it several times and the same thing happened each time. OK, time for a new HDD - easy enough.
    I popped open the Mini with my handy cake decorating spatulas and had the OEM 120GB 5400 rpm HDD installed in about 20 minutes. Upon rebooting the system everything looked good, but now the external HDD (with all my music, videos, software images, VM copies and photos) is having issues. It's a simple 3.5" Acomdata MiniPal 320GB External USB 2.0 Hub & FireWire External Hard Drive that looks sort of like a Mac Mini. I installed a Seagate 750GB PATA drive into it about 2 years ago as an upgrade and it's performed well that entire time.
    I turn on it's power and either:
    -The external light flashes from blue to red exactly 5 times, then stays red, but the platter never spins up
    -The external light flashes from blue to red exactly 5 times, repeats the 5 flash pattern 3 times, then goes to red and the platter never spins up
    -The platter spins up, then down repeatedly, and possibly indefinitely until I pull the power cord. The front light flashes a bit as if it's trying to read from it, but nothing ever happens as it spins back down again. This will repat indefinitely.

    Obviously this is sort of odd to me, because the drive was readable just 30 minutes before when I restored the Time Machine backup to the Mini's internal drive. I have several theories, so maybe a fresh set of eyes will help...

    -In retrospect, it's pretty obvious that the internal drive on the Mini was dead/dying before I attempted the TM restore. Perhaps something about restoring to a dead drive and then rebooting to that dead drive while the external drive was attached and powered on caused some corruption on the external drive or the like
    -The OEM HDD that I tossed back into the Mini turns out to be an image from a while back which is actually 10.5.7. The Mini was running 10.6.5 before it's demise. Perhaps there is some setting or feature on a drive that was created off of a 10.6.5 system that makes it somehow incompatible with a 10.5.7 system and somehow unable to mount?
    -The above might make sense, but the Acomdata drive won't spin up even if it is not attached to anything. That would seem to indicate that whatever happened between the TM restore and the reboot occurred effected the external drive in some manner which is persistent even without a connection to a computer.
    -Again, a bit odd to me is that the dead/dying internal drive from the Mini is readable (though not bootable) on my MBP. I was able to put it into an OWC Mercury external drive enclosure and pull a few important items off of it. So, while I'm grateful I can still access the drive, it is puzzling to me why it is not bootable. And if the TM restore nuked the Acomdata external drive such that it is inaccessible, why is the Mini's internal, unbootable, dying drive easily accessible?

    Anyhow, I ran home over lunch and am running Software Update to get the system back up to 10.6.5 again in hopes that it will somehow be able to access the Acomdata drive. I'm also tempted to use Migration Assistant to pull config files off of the original Mini internal HDD just to get it back as close to how it was before the floor dropped out.

    Any suggestions are welcome...

    Never judge a man, untill you have walked a mile in his shoes...
    That way you'll be a mile away from him, and you'll have his shoes.

  2. #2

    chscag's Avatar
    Member Since
    Jan 23, 2008
    Keller, Texas

    Smaller bites please..... How about splitting your post into short paragraphs so the folks don't look at and get reader weary. I just tried to absorb all you wrote and began to lose attention span. Yeah, I know, us older fellows have a short attention span.

  3. #3

    XJ-linux's Avatar
    Member Since
    Jul 02, 2007
    Going Galt...
    I tried to summarize with "the short of it". Guess I didn't accomplish that.

    Anyhow, progress...

    I installed the internal OEM HDD and brought it up to 10.6.5 - no issues. I was also able to access the "crashed" internal HDD via FW800 enclosure on my MacBook Pro. Not sure what specifically rendered the HDD unbootable, but the files were still good. Since that worked on the MBP, I decided to try mounting it on the Mini. It worked and I used Migration Assistant to return it to pretty much where it was before the issues.

    The Acomdata took longer. I powered it up and down maybe 10 times after work with same blinking light errors - no joy. Tried powering up with no connection to the Mini and while connected to the Mini. Decided to hook it to the Mini via USB too. That time it didn't mount but the platter spun up and no blinking light. Tried the USB connection to the MBP and it spun up but was unreadable, but no blinking light. Tried the FW800 connection to the MBP and it spun up and was readable. Wasted no time and copied as much as possible to the MBP and recovered the important VM's, software images and family photos/video.

    When I had only 60GB of the 320GB MBP disk left, I stopped - didn't want to run out of HDD for paging and sleep images. I left the Acomdata powered up, ejected the volume and then plugged it into the Mini - works fine now. Very odd. I'm guessing the external drive is tanking in addition to the Mini's internal drive.

    Moral(s) of the story...

    -RAID 1 is better than a desktop caliber HDD in a fanless enclosure.
    -DVD backups are probably in my future for important stuff
    -Keep your original storage media. The $40 you'd get selling is far less than it's worth to you when you need a known working drive ready to drop in at 10:30 PM
    -Hardware behaves differently even on the same manufacturers platform so experiment...
    -Be persistent

    Never judge a man, untill you have walked a mile in his shoes...
    That way you'll be a mile away from him, and you'll have his shoes.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 3
    Last Post: 11-26-2014, 10:53 PM
  2. Replies: 9
    Last Post: 11-28-2011, 02:20 PM
  3. Time Machine Restore Issues
    By phatkrome in forum macOS - Operating System
    Replies: 2
    Last Post: 05-20-2010, 05:57 AM
  4. Time Machine backup restore on/to a different machine?
    By scarredtaka in forum macOS - Operating System
    Replies: 3
    Last Post: 01-10-2008, 04:35 AM
  5. Time Machine Restore Issues
    By zenyatta80 in forum macOS - Operating System
    Replies: 8
    Last Post: 10-31-2007, 09:42 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts