I recently upgraded both my iMac and MacBook Pro from 10.5.6 to 10.5.8.

Today I tried to activate Web Sharing so that I can test some php files in my /pavi/Sites directory.

However neither is working!

On the iMac
I received the Forbidden message telling me I didn't have sufficient access, so after searching for solutions I found threads suggesting to create a pavi.conf file in the etc/apache2/users directory with the code

<Directory "/Users/pavi/Sites/">

Options Indexes MultiViews

AllowOverride None

Order allow,deny

Allow from all

I also did a

sudo chown root:wheel /etc/apache2/users/pavi.conf
in the Terminal.

That cleared up the access permission issue, but now when I click on the link under "Your personal website" in the Sharing panel of System Preferences I get connection errors:
Firefox can't establish a connection to the server at
Safari can’t open the page “” because Safari can’t connect to the server “”.

On the MacBookPro
a stranger issue - when I turn on Web Sharing the panel in System Preferences tells me Web Sharing is on, but there is no display underneath showing either "Your computer's website" or "Your personal website". (I mean it's completely blank, not just missing links).

I remember that previously it was so tried that and got the same access permissions error, again cleared up by creating the pavi.conf file and doing the sudo command, but the same "unable to connect messages" now appear whenever I try to load a page into my browser.

There is still no display of "Your computer's website" or "Your personal website" in my System Prefs.

Given that identical errors are appearing on both machines I assume there's some simple thing I've failed to do correctly.

I've been searching these forums and Googling but can't find the place to begin troubleshooting here.

Any advice would be greatly appreciated, and given that this is the first thing I've had to ever troubleshoot with regard to php/apache etc (previously it all worked fine just by switching on Web Sharing) , please advise in simple language!

Thanks in advance.