Results 1 to 3 of 3
  1. #1

    Member Since
    Nov 10, 2010
    iTunes on iMac, media on Linux server via SMB - slow imports, changes and stalls
    I have an unRAID server (If you're unfamiliar with unRAID, you can check it out at which is a Linux based server. I'm getting terrible performance with iTunes on my iMac. The music playback is fine. But if I import a song file or change any metadata, it has problems. This isn't new, I've read many, many posts complaining about this and other problems concerning SMB shares and file systems. But I think I may be onto something and would like some advice.

    This is what I've found so far. Snow Leopard, OS 10.6.x, has a problem with SMB and/or any file system other than HFS+. HFS+ is the common files system for OS X.

    There are hundreds of posts on the web complaining about temporary freezes, slowdowns, sometimes crashes on the Mac using SMB shares and other file systems. I have yet to see Apple acknowledge that there is a problem, but there are a few suggestions out there that seem to have helped people. I'll be trying out some of these this week and post the results here.

    From my own observations, specifically with iTunes, I've noticed some strange behavior. Here's my setup. I have an iMac running 10.6.4 (the latest update), the latest iTunes 10. The iTunes app is located on the local internal HD, I have my iTunes library files and all my media on disk 1 of my unRAID server. I'm hard wired to the server via a gigabit router. I have iTunes set to keep the media organized and copy the media files to the server.

    When importing a song file into iTunes, the file initially seems to copy at a good rate, the file appears in it's proper place and you can see the size increasing as it copies. Then it stalls for a while, then the name changes to a long hex number for a few seconds and then reverts back to its' normal state. The process can take 30-40 seconds, even with a small song file. I looked at the console and I got the following error message:

    11/8/10 12:24:28 AM /Applications/[2820] Possible unresolved transaction race -103/(Master Music Library/John Lennon/Rock 'N' Roll,(null))
    The same thing happens when I make a change in the metadata. It takes a LONG time to update the file. For example, I added onto the name of an album and for each song it changed I got:

    11/8/10 12:37:36 AM /Applications/[2820] Possible unresolved transaction race -103/(Master Music Library/John Lennon/Signature Box Set 5 - Walls And Bridges,(null))
    This happens for each file imported or changed even within iTunes. It doesn't seem to matter if the source file is on the Mac (for import from, let's say) or the server (for metadata changes, let's say)

    I followed the first path in the error message: /Applications/[2820].

    In the /Applications/ folder I find the following files:

    where iTunes is a Unix Executable File.

    I did some more research and have found some posts about file systems other than HFS+ having trouble with app packages. I believe that all OS X apps are actually packages, like folders, but appearing as a single file. Other file systems don't seem to know what to do with these. There was some talk of "flattening" these app packages, but I haven't gone forward with that yet because I'm not sure I understand it enough yet.

    I've also noticed that in the getinfo box under sharing & permissions I usually get "You can read and write", but with apps I get "You have custom access". This was something i had noticed before and thought it was a problem on the server, but I didn't realize it until now, I'm getting the custom access on every app. So I think that's probably normal.

    I'm wondering if I'm having a permissions problem with the iTunes Unix Executable File. Right now the permissions are set as follows:

    system: Read & Write
    admin: Read & Write
    everyone: Read only
    Maybe it's trying to write to that file or another one and doesn't have the right permissions since the song file is now on the server and that's causing the stalls? I'm over my head here. Anyone have any ideas?

  2. #2

    Member Since
    Nov 16, 2010
    Interesting post, I recently moved my iTunes library to an external drive connected via USB 2.0 to my router. I don't have a very large library, only about 3gb, but it was taking forever to add songs, set the gapless playback, etc... After reading your post I went to my Apps folder and checked the info on my iTunes package. There where 3 permissions listed: System (with a single shadow body to represent it) Wheel (2 shadows) and Everyone (3 shadows...does the shadows thing make sense to you?). I do not, nor have I ever had a user called "Wheel" and this was very confusing. I happen to use a Mac at work (not connected to a library on a nas drive) and found the following 3 permissions: System, Admin, and Everyone.
    I have no idea where Wheel came from but just for the heck of it I set all 3 to have Read and Write permissions. This seems to have solved the problem. As a test I tried it with my iPhoto library. I had also put its library on the NAS drive and it would take it 30 seconds or more to open. After making the same changes and giving everyone read/write to the package it opens in less then 5 seconds.
    As a final test I returned the iPhoto permissions to their default level, but it did not change the performance. It is still working as fast as it was after the initial change. So either something totally unrelated has changed allowing faster SMB access, or during the brief time that everyone had access to write it changed whatever it needed to change to allow it to work faster......either that or I am crazy and its all in my head.

  3. #3

    Member Since
    Nov 10, 2010
    Wheel is a unix permission thing I think. The way I understand it is all of the users on your system are included in the "staff" group, and all of the administrators on your system are in the "wheel" group. So I guess "staff" and "everyone" as far as os x is concerned is the same, while "wheel" is only for administrators. But I'm no expert at this, maybe someone else here knows.

    As for the SMB problem. I gave up on it and put my iTunes & iPhoto libraries on a USB ext. drive, like you, and using my unRAID as a backup. Problem not solved, but not an issue anymore.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. iTunes as Media Server
    By MarkWebb in forum Internet, Networking, and Wireless
    Replies: 4
    Last Post: 10-28-2014, 09:12 AM
  2. Mail tasks very slow or stalls
    By oceans11 in forum OS X - Apps and Games
    Replies: 1
    Last Post: 02-19-2010, 02:34 PM
  3. PHP, Flash Media Server, Windows & Linux Question?!?!
    By MrChris in forum Web Design and Hosting
    Replies: 0
    Last Post: 06-23-2007, 04:47 AM
  4. iTunes Media Server
    By chuckalicious in forum iPod Hardware and Accessories
    Replies: 0
    Last Post: 03-13-2006, 05:01 AM
  5. Can't see Linux SMB Server when browsing network.
    By SogniX in forum Internet, Networking, and Wireless
    Replies: 0
    Last Post: 03-13-2004, 11:33 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts