Results 1 to 5 of 5

Thread: Dead G4 DA ?

  1. #1


    Member Since
    Dec 29, 2007
    Location
    Bristol, England
    Posts
    7
    Specs:
    G4-Digital Audio-466mhz-1.25GB-120GB HDD
    Dead G4 DA ?
    Hi im new here so I wasnt sure where to put this. I have an aging G4 DA which has been serving me quite well recently, I changed the hard drive because my old one died but now I cant install anything on it. Im trying to install Tiger 10.4. When it starts up I can get to the "select destination" screen and no hard drives are showing up despite having formatted the drive (I have tried 5 hd's and nothing) I cant access the Utilities on the DVD, this just causes it to freeze. Is this G4 dead ? If not does anyone have any ideas what it could be.

  2. #2

    louishen's Avatar
    Member Since
    Oct 22, 2007
    Location
    London
    Posts
    8,968
    Specs:
    Mac Mini Core i7 2012 | White 2009 MacBook 2 Ghz | 733 Mhz G4 Quicksilver
    Is it something to do with the master / slave settings on any of the drive
    Member of the Month September 2008 & August 2012 | Found advice useful? use the rep system

  3. #3


    Member Since
    Dec 29, 2007
    Location
    Bristol, England
    Posts
    7
    Specs:
    G4-Digital Audio-466mhz-1.25GB-120GB HDD
    No, i only have one drive in it and its set to master

  4. #4

    dtravis7's Avatar
    Member Since
    Jan 04, 2005
    Location
    Modesto, Ca.
    Posts
    28,932
    Specs:
    iMac 2010 27" QuadI7 OSX10.11, iMac 2008 OSX10.11, MBP Late2011OSX10.11 , iPad Air, iPhone 3GS
    What brand is the hard drive? Some WD drives if they are the only drive you set it to single.

    When booting with the OSX DVD, you try and launch Disk Utility and it freezes?

    Another thing to check it the IDE Ribbon cable. Seen a lot of them fail on the G4 Macs as it flexes every time the door is opened and closed.

  5. #5


    Member Since
    Dec 29, 2007
    Location
    Bristol, England
    Posts
    7
    Specs:
    G4-Digital Audio-466mhz-1.25GB-120GB HDD
    The drive is Seagate. When I try to run ANYTHING from the menu it freezes. I will have to check/change the ribbon cable and see if that works, thanks dtravis7

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Dead Mini, still dead...
    By Cor80 in forum Apple Desktops
    Replies: 4
    Last Post: 06-21-2011, 03:17 AM
  2. dead. just dead. (battery issue?)
    By jediracer in forum iPod Hardware and Accessories
    Replies: 1
    Last Post: 03-10-2011, 08:36 PM
  3. Macbook HD dead or not dead?
    By MaDDiZ in forum Apple Notebooks
    Replies: 4
    Last Post: 12-08-2009, 07:36 PM
  4. Is It Dead?
    By colormeandrew in forum Apple Notebooks
    Replies: 8
    Last Post: 10-28-2007, 03:00 PM
  5. Dead
    By larsmac in forum Apple Notebooks
    Replies: 0
    Last Post: 08-16-2005, 07:26 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •