Results 1 to 7 of 7
  1. #1


    Member Since
    Oct 23, 2009
    Posts
    7
    Printing problems with Canonprinter
    I have a canon MP500 in a network.

    When I print from the web I get good printouts. But printing Pages documents or Word documents gets me all blank pages.
    When connected direct thru USB I have the same problem, so not a network issue.

    what can be the problem?
    Peterwillem

  2. #2


    Member Since
    Oct 23, 2009
    Posts
    7
    More info about the problem and what I have done so far:
    Installed the latest Canon drivers for the Mac.
    Checked the FontBook.app. for fonts causing problems, none found.
    Printed from the Font Book archive according to the help instructions, but again a blank sheet came out of the printer.

    I tried printing via my wife's little HP printer, there were no problems there.
    So this points to the Canon printer. But how come that printing from the web works, and copying documents works?

    peterwillem

  3. #3

    hughvane's Avatar
    Member Since
    May 18, 2008
    Location
    Banks Peninsula, Canterbury
    Posts
    3,306
    Specs:
    MacMini 2.4, 8 Gb, OS 10.11 and 10.6; MacBook 2.4, 4 Gb, OS 10.6.8
    Have you connected the Canon to another Mac computer (if feasible)? I suspect a System Permissions problem. But how web text prints but not docs from within the Mac itself is a mystery.

    As a meantime measure, repair Permissions, preferably using OnyX Titanium's Software • Download for your present OS version (which is???).

    Next, boot from your Install Disk 1, open Disk Utility, and run a hardware check (First Aid). Leave the printer connected and switched on whilst doing so.
    ABCDEFGHIJKLMNOPQRSTUVWXYZ
    Please post your Mac (or other) specs and MacOS version in your post, your profile or your signature. It helps us to help you better.

    I'm leaving now to go and find myself. If I should return before I get back, please ask me to wait.

  4. #4


    Member Since
    Oct 23, 2009
    Posts
    7
    Thx,
    I checked/repaired the hd with disk utilities on disk permissions. It was ok. I have the same problem with my Macbook pro and even with my netbook which runs on windows 7.
    So I think it is the canon printer. But have no idea where in the printer the problem lies.
    Installed latest drivers.

    peterwillem

  5. #5

    chscag's Avatar
    Member Since
    Jan 23, 2008
    Location
    Fort Worth, Texas
    Posts
    48,280
    Specs:
    Late 2013 27" iMac, iPad 3, iPhone 6s+, iPhone 6+, 3 iPods, El Capitan
    It sounds like something is not set correctly in your Printer sharing preferences.

    Open System Preferences, Print & Fax. Highlight your Canon MP500 and first make sure you've checked off the sharing box. "Share this printer on the network"

    Now click on the sharing preferences tab. Check off the appropriate boxes for sharing = Printer, Scanner, etc. Under Users, it should say: "Everyone Can Print" If it doesn't say that, click the down arrow and select "Can Print".

    Let us know.

  6. #6


    Member Since
    Oct 23, 2009
    Posts
    7
    Talking
    Quote Originally Posted by chscag View Post
    It sounds like something is not set correctly in your Printer sharing preferences.

    Open System Preferences, Print & Fax. Highlight your Canon MP500 and first make sure you've checked off the sharing box. "Share this printer on the network"

    Now click on the sharing preferences tab. Check off the appropriate boxes for sharing = Printer, Scanner, etc. Under Users, it should say: "Everyone Can Print" If it doesn't say that, click the down arrow and select "Can Print".

    Let us know.
    Thank you,
    all was already set as mentioned by you above.
    Meanwhile I have found out that I can use the Canon, but only when printing in collars.No black or grayed printing, then I get blank pages. What the reason for that is , beats me. I like to know that.
    Right now I am using an other printer in the network, which works fine.
    So the settings in the Mac are ok.

    peterwillem

  7. #7

    hughvane's Avatar
    Member Since
    May 18, 2008
    Location
    Banks Peninsula, Canterbury
    Posts
    3,306
    Specs:
    MacMini 2.4, 8 Gb, OS 10.11 and 10.6; MacBook 2.4, 4 Gb, OS 10.6.8
    Down to method of last resort - contact Canon. I believe they have a good support service.
    ABCDEFGHIJKLMNOPQRSTUVWXYZ
    Please post your Mac (or other) specs and MacOS version in your post, your profile or your signature. It helps us to help you better.

    I'm leaving now to go and find myself. If I should return before I get back, please ask me to wait.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Printing Problems
    By wicki in forum OS X - Operating System
    Replies: 2
    Last Post: 06-26-2009, 11:35 PM
  2. Printing Problems
    By texast in forum Switcher Hangout
    Replies: 2
    Last Post: 09-26-2007, 02:22 AM
  3. Printing Problems
    By luigihip in forum Images, Graphic Design, and Digital Photography
    Replies: 3
    Last Post: 10-12-2006, 12:04 PM
  4. Printing Problems
    By trinbagonet in forum OS X - Operating System
    Replies: 3
    Last Post: 05-02-2005, 11:18 PM
  5. Printing problems
    By afrdzak in forum Other Hardware and Peripherals
    Replies: 2
    Last Post: 01-08-2004, 02:15 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •