Results 1 to 5 of 5
  1. #1


    Member Since
    Nov 24, 2009
    Posts
    4
    Java / Javascript Problems in Firefox, Safari, Opera
    I'm on a 2.4 Ghz MacBookPro running Snow Leopard and the latest versions (as of today) of Firefox, Safari, and Opera. They all fail to properly load and operate this page:

    City of Hot Springs

    The icons are out of place, the list elements don't show up, the menus drop down in the wrong size with no text, the menus do nothing when you click on them, the info box has text when loading, but a broken link icon when loaded, etc. I will take screen shots if it might help.

    I've got an old G3 running legacy OS and browsers that handles it just fine.

    I've installed all the software updates available.

    I'm stumped. All help appreciated.

    zac

  2. #2

    vansmith's Avatar
    Member Since
    Oct 19, 2008
    Location
    Toronto
    Posts
    19,789
    Specs:
    Early 2015 13" rMBP
    It has nothing to do with either Java or Javascript (which, as a note, are two very different things despite the fact that they both have "java" in their name). The website was designed with Flex which compiles the project to Flash content. The issue then is Flash. What version of Flash are you using on the machine that is causing problems?
    Important Links: Community Guidelines : Use the reputation system if you've been helped.
    M-F Blog :: Write for the blog
    Writing a Quality Post

  3. #3


    Member Since
    Nov 24, 2009
    Posts
    4
    I don't remember, but I updated it yesterday. I think it's 10.

    I'm trying to check my computer, but I don't know where to look. It is the most recent, as of yesterday.

    zac

  4. #4

    vansmith's Avatar
    Member Since
    Oct 19, 2008
    Location
    Toronto
    Posts
    19,789
    Specs:
    Early 2015 13" rMBP
    You can check your version here. If you updated yesterday though, you're fine. Is it only that Flash content that you notice issues on?
    Important Links: Community Guidelines : Use the reputation system if you've been helped.
    M-F Blog :: Write for the blog
    Writing a Quality Post

  5. #5


    Member Since
    Nov 24, 2009
    Posts
    4
    Resolved! Thank you, vansmith, for your attention. It turned out to be a font issue: duplicates. I deleted all the fonts in my User\Library\Fonts directory, logged in again and it was solved. Resolving duplicates in Font Book wasn't enough, they had to be zapped. Same as it ever was.

    zac

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Javascript problems in safari
    By pandora_dora in forum Web Design and Hosting
    Replies: 1
    Last Post: 09-27-2011, 11:59 PM
  2. Shockwave works weird (Safari, Firefox, Opera) pls help
    By Gabrielc in forum OS X - Apps and Games
    Replies: 5
    Last Post: 12-28-2009, 09:07 PM
  3. Browsers other than Safari, Firefox, & Opera
    By AUZambo in forum Switcher Hangout
    Replies: 3
    Last Post: 11-18-2007, 01:06 PM
  4. Firefox vs. Safari vs. Opera
    By herkalees in forum OS X - Apps and Games
    Replies: 10
    Last Post: 05-26-2007, 01:37 PM
  5. Firefox, Safari Nor Opera will display youtube.com
    By ArturoC in forum OS X - Apps and Games
    Replies: 13
    Last Post: 01-17-2007, 04:55 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •