Mac Forums

Mac Forums (http://www.mac-forums.com/forums/)
-   OS X - Operating System (http://www.mac-forums.com/forums/os-x-operating-system/)
-   -   Snow Leopard Hanging-Running VERY SLOW (http://www.mac-forums.com/forums/os-x-operating-system/200830-snow-leopard-hanging-running-very-slow.html)

markwco 05-03-2010 03:43 PM

Snow Leopard Hanging-Running VERY SLOW
 
I am having a problem with running Snow Leopard on my MBP. It's running extremely slow and beachballing a lot. Here is the issue.

The computer is almost 3 years old to the day and is a Core 2 Duo MBP and has 4GB of memory. I upgraded to Snow Leopard a few months ago and am running the newest update.
About 6 months ago I experienced a video problem and the Apple Store replaced it with a new logic board. A few days later I experienced networking issues. it would connect to Wi-Fi but would not get any internet. The Apple store tried a few things to fix corrupt files and was unable to fix it. They suggested a reinstall of Leopard which is what I was running at that time but instead I did an upgrade to Snow Leopard. It immediately fixed the problem and my computer was running fast. I left this out but as part of the Snow Leopard upgrade I upgraded the hard drive to a 640GB drive.

Then a few days ago it began running slow. It seems to start slow so I thought it was just too many programs running and my computer was showing it's age. Yet it has gotten far worse and I know it may be a deeper issue.

I have questioned if it could be an issue with memory. Would this slow it down?
I tend to think its' software related, not hardware.

The question: How do I troubleshoot something like this? It happens as soon as I boot it up, I don't even have to start any programs. I have looked at my login items in accounts and see a few things like growl and a scanner application. The only other thing I see is I noticed there is 4 items relating to SOHO Organizer. I don't believe these should be slowing it down.

As an example when I boot it and log on at that point, it can beachball for 10 minutes before I get into the screen with the dock, etc. Dashboard won't even work. When I click on dashboard it brings up the calculator, weather, etc. but nothing opens up. i simply see the blank calculator but nothing is lighting up to type on it, no weather details, etc. and this is after bootup or using it.

When I try to close an application it can take a minute, it can take a minute to switch, it. My computer is nearly unusable.

If necessary I'll go to the Apple store but it just left the warranty period and I'm convinced its' simply something software related, maybe something that's hanging it. Any ideas of what could be wrong or how to troubleshoot to find out?

Thank you in advance for your help.

bobtomay 05-03-2010 05:45 PM

Assuming you still have at least 100 GB free space on the drive:

I'll lay odds - it's the hard drive - I've been seeing this simlilar type of thing a lot lately instead of the old clicking we've all been use to hearing with dying drives. Even had one of my 1.5 TB WD Green drives during the first month with the same symptoms on my Win 7 rig.

Mine seemed to install the OS just fine and run for maybe a couple of minutes after boot. Then it'd just sit there thinking after clicking on anything for minutes at a time, like 3-10 minutes and longer. Then it started giving me software errors, first affecting UAC, and then after a couple of re-boots not allowing me to log in to my user account. A boot into Safe Mode would allow me to try the repairs I needed and it would seem to run ok for a little longer, but finally it started exhibiting the same stuff. Mine also seemed to partition, format and install the OS just fine in the normal amount of time. It was really strange. All software errors that I was getting, but 3 days and a couple of fresh partitioning/formats/clean installs later... finally stuck another drive in it and all was well.

Have you got a bootable backup. What happens when you boot to that? If not, I'd make one.

markwco 05-04-2010 01:32 AM

I did some work this evening. For some reason I was unable to get into safe mode and I pressed and held the Shift key hoping to go into safe mode.

After that I tried the option of a hardware test by inserting the #1 CD that came with the MBP and booting up using D. I ran the extensive hardware test and it found no errors.

Yet I have even pulled the power cord and battery and did a restart and am having the same problem. I even had a few times it would not even boot. It would get to the grey apple with the progress indicator below and would be like that for 15-20 mins, never going further so I may have even deeper issues.

Fortunately I had been doing hard drive backups using Super Duper so I connected that drive and did a boot from it. I was excited since it seemed to boot at first and then was very slow and appeared to freeze as the icons were appearing on the desktop. I have only tried this once but since that's the case I didn't think it was the internal hard drive that was the issue.

Then I decided to hook the external back up drive to the other MBP our family has. I then booted up and was shocked how well it ran. It was running on USB but I got straight into the OS and opened a few documents, programs, etc. and had absolutely no problems.

What would this mean?
I originally though after it didn't work on the MBP that maybe it was indeed a problem with the internal hard drive and there were likely corrupted files or so that then got backed up onto this backup drive when I did the last backup a couple weeks ago. Yet it works fine on the other MBP.

I actually did the hardware test after I attempted the boot from the hard drive on the MBP so can try another boot later in case something just went wrong that time but since it boots fine on another MBP I tend to think the hard drive is not the issue. The good news is maybe I won't have to do a complete clean install of Snow Leopard and then all data, etc.

Could it be some type of hardware problem with the MBP? The hardware test found nothing but could it be a memory problem or would it have caught a memory problem or a hard drive problem? I had to have the Apple Store put a new logic board in this computer about 6 months ago. It was a video problem and the computer had no video at all. Would a more serious problem relating to the logic board or something on it cause a problem like this?

Once the hardware test is done I will try to boot again from this hard drive. I was ready to check into replacing through warranty the new hard drive I put in but I'm not sure if that is the problem now.

bobtomay 05-04-2010 05:16 AM

If you have the same issue with your SD! backup, likely not the drive.

A problem with your memory would typically be causing the machine to crash. You could try using one stick at a time.

You could also try a PRAM reset.

But with both drives exhibiting the same issue, think I'd be making an appointment at the Apple store again. Especially if you're hitting the end of your Applecare.

markwco 05-04-2010 01:37 PM

I tried a PRAM reset but unfortunately that didn't help so it seems like I'll be going by Apple.
I purchased the AppleCare for 2 additional years but it just expired in April. I had a logic board replaced in this MBP less than 6 months ago. Since this may be a problem with the logic board would Apple cover it or is all coverage over since the AppleCare expired? Unfortunately since I'm probably just a couple weeks past AppleCare being over I'm hoping there's some type of chance of coverage.


All times are GMT -4. The time now is 07:49 AM.

Powered by vBulletin
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.