Results 1 to 7 of 7
  1. #1
    rbaibich
    Guest
    Indexing a network drive with Spotlight
    I have a Buffalo Terastation NAS and I'd like to know if there's a way of indexing that drive for spotlight use.

    Also, if you're connected to another computer using tiger and you do a spotlight search, will it search the other computer as well?

  2. #2

    PowerBookG4's Avatar
    Member Since
    Jan 08, 2005
    Location
    New Jersey
    Posts
    6,188
    Specs:
    Mac Pro 8x3.0ghz 12gb ram 8800GT , MBP 2.16 2GB Ram 17 inch.
    Spotlight only works on the current computer you are on, I wanted to do what you are trying to do now and was told that it was impossible at least for now. That is the one thing that longhorn will have that tiger does not, hopefully leapard will have this new feature and you can spotlight multiple computers and network drives.

  3. #3

    iWhat's Avatar
    Member Since
    Nov 11, 2004
    Location
    Toledo, Ohio
    Posts
    5,736
    Specs:
    Macbook, iMac G5, iPad, iPhone 4, iPod (MANY)!
    You can search the other mac over the network, but you'll need to use the Finder for that. Once you have the other mac mounted, select it in the sidebar and search for what you want in the Finder search field, and it should show you that it is searching in the Volume "other_mac" near the top, and then it will search the other mac.

    For the external hard drive, Spotlight will search both your mac and the external hard drive on the fly. But I'm not sure, if you can manually tell your mac index the external HD in Tiger or I'm having a hard time finding it, I hope.

  4. #4

    PowerBookG4's Avatar
    Member Since
    Jan 08, 2005
    Location
    New Jersey
    Posts
    6,188
    Specs:
    Mac Pro 8x3.0ghz 12gb ram 8800GT , MBP 2.16 2GB Ram 17 inch.
    yes you can search the external drive if it is attached to your computer but not if it is network storage, unless like iWhat said, you use finder instead of spotlight. I to am having trouble finding how to index it in tiger.

  5. #5

    iWhat's Avatar
    Member Since
    Nov 11, 2004
    Location
    Toledo, Ohio
    Posts
    5,736
    Specs:
    Macbook, iMac G5, iPad, iPhone 4, iPod (MANY)!
    I think that you could manually tell Panther to index the drive, but I no longer see that option in Tiger. It was usually in the "Get Info" area.

  6. #6


    Member Since
    Dec 10, 2010
    Posts
    1
    Here is how you do it
    USE THE TERMINAL OPTION mdutil.
    It has a switch, -i, to enable indexing on a volume. So I just went ahead as root (sudo bash) and ran:
    sudo bash. (my network drive example is named "ldm" so replace ldm by your network drive name)
    mdutil /Volumes/ldm -i on
    Then I checked the status with
    mdutil /Volumes/ldm -s
    And, behold ... I got back the following:
    /Volumes/ldm/:
    Status: Indexing Enabled

    A second later, the Spotlight Icon started pulsating. Half an hour later, it stopped. I went to a Finder window, typed a query, and selected the network volume ldm. To my delight, matches were coming back instantaneously on files deep down in the file hierarchy on that volume. I have not checked whether newly added files are indexed on the fly, too, and I do not know where the .Spotlight-V100 file is stored (not in the root of the volume in question it seems).

    I thought that others may give it a try to confirm whether this is working as expected. The volume I tested this with was an AFP volume served via NETATALK (v. 2.0.2) by my Linux server (a x86 debian box). Unfortunately, it appears to fail with SAMBA. I have not checked NFS. One caveat: you must rerun the mdutil command each time the volume is mounted.

    Hope it helps someone!

  7. #7


    Member Since
    Aug 09, 2013
    Posts
    1
    Thumbs up Thanks!
    Awesome! This helped!

    Quote Originally Posted by sowattmusic View Post
    USE THE TERMINAL OPTION mdutil.
    It has a switch, -i, to enable indexing on a volume. So I just went ahead as root (sudo bash) and ran:
    sudo bash. (my network drive example is named "ldm" so replace ldm by your network drive name)
    mdutil /Volumes/ldm -i on
    Then I checked the status with
    mdutil /Volumes/ldm -s
    And, behold ... I got back the following:
    /Volumes/ldm/:
    Status: Indexing Enabled

    A second later, the Spotlight Icon started pulsating. Half an hour later, it stopped. I went to a Finder window, typed a query, and selected the network volume ldm. To my delight, matches were coming back instantaneously on files deep down in the file hierarchy on that volume. I have not checked whether newly added files are indexed on the fly, too, and I do not know where the .Spotlight-V100 file is stored (not in the root of the volume in question it seems).

    I thought that others may give it a try to confirm whether this is working as expected. The volume I tested this with was an AFP volume served via NETATALK (v. 2.0.2) by my Linux server (a x86 debian box). Unfortunately, it appears to fail with SAMBA. I have not checked NFS. One caveat: you must rerun the mdutil command each time the volume is mounted.

    Hope it helps someone!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Stop Spotlight From Indexing External Drive
    By PGB1 in forum OS X - Operating System
    Replies: 2
    Last Post: 10-10-2012, 05:08 PM
  2. Spotlight Stuck on Indexing
    By CleaStagnitti in forum OS X - Operating System
    Replies: 2
    Last Post: 06-17-2011, 01:06 PM
  3. Re-indexing Spotlight in 10.5.8
    By rsherid in forum OS X - Apps and Games
    Replies: 2
    Last Post: 02-11-2010, 09:20 PM
  4. Spotlight Indexing Stuck
    By Fromasta Flex in forum OS X - Operating System
    Replies: 5
    Last Post: 12-04-2007, 01:07 PM
  5. spotlight indexing
    By meanopause in forum OS X - Operating System
    Replies: 3
    Last Post: 04-29-2005, 01:54 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •