New To Mac-Forums?

Welcome to our community! Join the discussion today by registering your FREE account. If you have any problems with the registration process, please contact us!

Get your questions answered by community gurus Advice and insight from world-class Apple enthusiasts Exclusive access to members-only contests, giveaways and deals

Join today!

 
Start a Discussion
 

Mac-Forums Brief

Subscribe to Mac-Forums Brief to receive special offers from Mac-Forums partners and sponsors

Join the conversation RSS
OS X - Operating System General OS operation information and support

Can't boot OS X - can boot linux - no disk error...


Post Reply New Thread Subscribe

 
Thread Tools
notBanksy

 
Member Since: Mar 01, 2008
Posts: 4
notBanksy is on a distinguished road

notBanksy is offline
I have a very strange problem. My macbook (white 2005 model) crashed and wouldn't reboot - it just hung on the blue screen before the login screen. I had a mouse pointer, but the machine wouldn't respond. I booted using the install disk and ran the disk utility, which found no errors and fixed a handful of permissions. I also reset the PRAM and tried to boot into single user mode with no success.

I had to use a live linux cd to access my files, which I backed up.

I then used the mac install disk and reinstalled the operating system (tiger). When it got to the part where the machine reboots, it just hung on the blue screen before the login screen like before.

So out of curiosity I installed linux (mint 6) and tried to boot that. It works fine. So I wondered if there was something wrong with the mac bootloader which was still intact on the hard disk. I booted into gparted and deleted the partition table, then booted into the mac install disk and created a HFS partition for OS X (it was the only partition).

I reinstalled OS X and this time seemed to get to the end of the installation. I reached the part where it says installation complete, restart now. So I restarted, and the machine just hung again. After 20 or so minutes, I forced it to shut down and tried to boot. Exactly the same problem as before.

Please can anyone give me any advice as to what the problem may be, and how I can get OS X to install and boot again on this machine.

The machine has been used a lot, had tea spilled on the keyboard (a year or so back) so uses a USB keyboard, and the ethernet port recently gave up. Apart from that, it has been working well.

Thanks for any help
QUOTE Thanks
DarkestRitual

 
Member Since: Apr 09, 2009
Location: Ithaca NY
Posts: 2,073
DarkestRitual is just really niceDarkestRitual is just really niceDarkestRitual is just really niceDarkestRitual is just really nice
Mac Specs: 13 inch alMacBook 2GHz C2D 4G DDR3, 1.25GHz G4 eMac

DarkestRitual is offline
That is an interesting predicament. I will be watching this one closely to see where it goes. Sorry I can't offer any help.
QUOTE Thanks
Nethfel

 
Member Since: Feb 25, 2009
Posts: 2,088
Nethfel is a glorious beacon of lightNethfel is a glorious beacon of lightNethfel is a glorious beacon of lightNethfel is a glorious beacon of lightNethfel is a glorious beacon of lightNethfel is a glorious beacon of light
Mac Specs: Late 2013 rMBP, i7, 750m gpu, OSX versions 10.9.3, 10.10

Nethfel is offline
Have you run the Apple Hardware Test to see if everything was OK?

If you haven't, check this link that talks about accessing it:

Intel-based Macs: Using Apple Hardware Test

Honestly, I had a similar issue with a different Mac (powerbook) and it ended up being a problem with the hard drive.

My Macs: Late 2013 rMBP w/ 750m; Mac mini G4, 1.25 GHz, 512m ram (server); Late 2011 11" MBA, 1.8GHz i7, 4Gig Ram, 256Gig SSD, HD3000; Powerbook 12" G4 1.33GHz running Debian as a server; Apple TV (1080p version)
QUOTE Thanks
notBanksy

 
Member Since: Mar 01, 2008
Posts: 4
notBanksy is on a distinguished road

notBanksy is offline
Thanks for the replies. Yes I ran the apple hardware test. I also checked the disk in gparted. Neither reported any errors...
QUOTE Thanks

Post Reply New Thread Subscribe


« Ethernet Connection | nvram »
Thread Tools

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off
Forum Jump

Similar Threads
Thread
Thread Starter
Forum
Replies
Last Post
White (intel) iMac will not boot Jaytdub Apple Desktops 8 12-04-2009 06:23 PM
Mac Mini cannot boot to Linux Hotzilla Running Windows (or anything else) on your Mac 1 11-22-2009 05:01 PM
tried Repair Disk thru CD BOOT, but failed niall_aquaweb Apple Desktops 5 04-16-2009 10:41 AM
Boot Camp Disk Error Jax. Running Windows (or anything else) on your Mac 12 10-06-2008 10:37 PM
Boot Camp: Disk Error? Tarek Running Windows (or anything else) on your Mac 3 09-25-2008 01:37 AM

All times are GMT -4. The time now is 09:57 AM.

Powered by vBulletin
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
X

Welcome to Mac-Forums.com

Create your username to jump into the discussion!

New members like you have made this community the ultimate source for your Mac since 2003!


(4 digit year)

Already a member?