Results 1 to 4 of 4
  1. #1

    Member Since
    Mar 01, 2008
    Can't boot OS X - can boot linux - no disk error...
    I have a very strange problem. My macbook (white 2005 model) crashed and wouldn't reboot - it just hung on the blue screen before the login screen. I had a mouse pointer, but the machine wouldn't respond. I booted using the install disk and ran the disk utility, which found no errors and fixed a handful of permissions. I also reset the PRAM and tried to boot into single user mode with no success.

    I had to use a live linux cd to access my files, which I backed up.

    I then used the mac install disk and reinstalled the operating system (tiger). When it got to the part where the machine reboots, it just hung on the blue screen before the login screen like before.

    So out of curiosity I installed linux (mint 6) and tried to boot that. It works fine. So I wondered if there was something wrong with the mac bootloader which was still intact on the hard disk. I booted into gparted and deleted the partition table, then booted into the mac install disk and created a HFS partition for OS X (it was the only partition).

    I reinstalled OS X and this time seemed to get to the end of the installation. I reached the part where it says installation complete, restart now. So I restarted, and the machine just hung again. After 20 or so minutes, I forced it to shut down and tried to boot. Exactly the same problem as before.

    Please can anyone give me any advice as to what the problem may be, and how I can get OS X to install and boot again on this machine.

    The machine has been used a lot, had tea spilled on the keyboard (a year or so back) so uses a USB keyboard, and the ethernet port recently gave up. Apart from that, it has been working well.

    Thanks for any help

  2. #2

    Member Since
    Apr 09, 2009
    Ithaca NY
    13 inch alMacBook 2GHz C2D 4G DDR3, 1.25GHz G4 eMac
    That is an interesting predicament. I will be watching this one closely to see where it goes. Sorry I can't offer any help.

  3. #3

    Member Since
    Feb 25, 2009
    Late 2013 rMBP, i7, 750m gpu, OSX versions 10.9.3, 10.10
    Have you run the Apple Hardware Test to see if everything was OK?

    If you haven't, check this link that talks about accessing it:

    Intel-based Macs: Using Apple Hardware Test

    Honestly, I had a similar issue with a different Mac (powerbook) and it ended up being a problem with the hard drive.
    My Macs: Late 2013 rMBP w/ 750m; Mac mini G4, 1.25 GHz, 512m ram (server); Late 2011 11" MBA, 1.8GHz i7, 4Gig Ram, 256Gig SSD, HD3000; Powerbook 12" G4 1.33GHz running Debian as a server; Apple TV (1080p version)

  4. #4

    Member Since
    Mar 01, 2008
    Thanks for the replies. Yes I ran the apple hardware test. I also checked the disk in gparted. Neither reported any errors...

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Bless tool unable to set current boot disk... now mac pro won't boot at all.
    By name_is_david in forum OS X - Operating System
    Replies: 1
    Last Post: 05-11-2015, 05:07 PM
  2. Replies: 3
    Last Post: 01-11-2015, 08:40 PM
  3. Disk error when i boot using windows
    By mac-tastic45 in forum Running Windows (or anything else) on your Mac
    Replies: 1
    Last Post: 10-25-2008, 02:47 PM
  4. Boot Camp Disk Error
    By Jax. in forum Running Windows (or anything else) on your Mac
    Replies: 12
    Last Post: 10-06-2008, 10:37 PM
  5. Boot Camp: Disk Error?
    By Tarek in forum Running Windows (or anything else) on your Mac
    Replies: 3
    Last Post: 09-25-2008, 01:37 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts