Results 1 to 8 of 8
  1. #1


    Member Since
    Apr 08, 2010
    Posts
    3
    Help! Internet videos, YouTube, etc., no longer playing on my Mac.
    Hello folks,

    It's my first post, and I've joined because I'm hoping to get some help from folks who know more about Macs than I do!

    I'm not sure what happened, but I can no longer get YouTube or other internet videos to play on my computer (Mac G4 Powerbook PPC, OSX 10.4.11). When I go to Youtube and select a video, the image of the video flashes for a brief second and disappears, leaving a blank space where you'd expect to see the video. This happens with the other internet sites as well; I doublechecked.

    I think the videos stopped working after I had upgraded to the new version of Flash Player. But I have since uninstalled it (with the Adobe uninstaller) and then tried an older version (9.47) but that didn't work. So I uninstalled that, and put the new Flash Player back. I've also updated my Safari browser (can't get Firefox to work anymore without crashing every time).

    I've also checked my preferences to see that Java and Javascript are enabled. They are.

    Has anybody else had this problem? Or better yet, had anyone got a fix for me? Thanks!

  2. #2


    Member Since
    Sep 09, 2009
    Location
    Down Under :D
    Posts
    5,484
    Specs:
    Back to my old 2.2GHz C2D MB after selling my MBP and wondering what my next Mac will be :)
    Welcome to Mac forums.
    Maybe try installing Apple - Downloads - Mac OS X Updates - Mac OS X 10.4.11 Combo Update (PPC) and see if that fixes the issue.
    This will bring everything back to the state that it should be.

  3. #3


    Member Since
    Apr 08, 2010
    Posts
    3
    Hey thanks 6string!

    I appreciate the welcome and the advice. (I assume you play guitar? Me too, for a very long time now.) Anyway, I downloaded the update you suggested. I assume that it will help with a variety of functions, yet sadly, it doesn't seem to make any difference with the YouTube situation. Any and all further suggestions gladly accepted. Thanks again 6string.

  4. #4


    Member Since
    Sep 09, 2009
    Location
    Down Under :D
    Posts
    5,484
    Specs:
    Back to my old 2.2GHz C2D MB after selling my MBP and wondering what my next Mac will be :)
    Pleasure.... wish I could've helped.
    Because I don't have tiger anymore, or a PPC Mac, it makes it pretty much impossible for me to test it all out, but I hope that someone will be along shortly with suggestions.
    I would use OnyX OnyX (Tiger) for Mac - Free Mac software downloads and software reviews - CNET Download.com and repair permissions, clear caches, etc, and see if that fixes it.
    I would also remove firefox with AppCleaner and reinstall from Apple - Downloads - Internet Utilities - Mozilla Firefox
    *and yeah, play, teach, record, etc.... but slackin off heaps lately.

  5. #5


    Member Since
    Apr 08, 2010
    Posts
    3
    Hey thanks again 6string. (Sounds like your a lifer guitarist like myself.)

    I should mention another thing I'm noticing. When I go to a Myspace page, it tells me to upgrade my Flash Player, even though I've already done so numerous times. There must be something going on where the Flash Player is not being recognized for some reason or another. Oy.

  6. #6


    Member Since
    Mar 15, 2011
    Posts
    1
    Flash Player - G5
    I have a newly acquired late 2005 Power Mac G5 Dual Core, model A1177 with the 10.4.11 Tiger OS. The first thing I discovered is that nothing video related works from the web. I right away loaded the latest Abobe Flash 10 for Mac and the end result was that because its not an Intel Processor, it will not work with this system. I contacted Apple and they said nothing they can see will work with this system. I took the specs on this unit to the Apple store who also said they know of nothing out there that will work either. They said to contact Adobe who may be able to help or provide an older version that will work with this. I tried loading Flash Player 9....still nothing.
    My question is, I know it did work for 5 years in our office with Flash....why now will it no longer work? Is it that Adobe updated their software and nothing they have now will work with the older Power Macs?
    Also, with it known that Adobe does not work with the Iphones and Ipads, I can get YouTube and other videos from sites that are not Adobe Flash related, so it must be another flash type program that does work. Why would this not work on the G5?
    Any help is appreciated as my work involves using video from the web. I also want to know if anyone who owns this vintage G5....how do you do use video from the web?

    Thanks
    MG64

  7. #7


    Member Since
    Jan 05, 2007
    Posts
    11
    Specs:
    Running TIGER (Mac OS X 10.4.11) Dual 2 Ghz PPC G5 4.5 GB DDR2 SDRAM
    Quote Originally Posted by mg64 View Post
    I tried loading Flash Player 9....still nothing.
    My question is, I know it did work for 5 years in our office with Flash....why now will it no longer work?
    I also want to know if anyone who owns this vintage G5....how do you do use video from the web?

    Thanks
    MG64
    Don't want to just regurgitate the issue, but I have the same G5 configuration with Tiger and have always been able to view YouTube and most any other video. Then one day . . . nothing. I am always asked to update my Flash Player but Flash Player refuses to allow any kind of update on a PPC.

    Any one have any answers? My browser is Firefox 3.6.16

  8. #8


    Member Since
    Apr 23, 2011
    Posts
    28
    Quote Originally Posted by ibob View Post
    Don't want to just regurgitate the issue, but I have the same G5 configuration with Tiger and have always been able to view YouTube and most any other video. Then one day . . . nothing. I am always asked to update my Flash Player but Flash Player refuses to allow any kind of update on a PPC.

    Any one have any answers? My browser is Firefox 3.6.16
    have you tried to update your firefox, maybe it can solve the problem ..
    or if the problem still appear , try to clean remove the firefox using appcleaner it's free ..
    after that , restart your mac, and then try to install the new version of firefox that you've been downloaded ..

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Videos no longer playing in Youtube....help please
    By mach1ne in forum Movies and Video
    Replies: 6
    Last Post: 12-16-2012, 10:31 AM
  2. Can longer view videos on FB or YouTube
    By Rivergull in forum OS X - Operating System
    Replies: 1
    Last Post: 09-24-2012, 11:40 PM
  3. YouTube Videos Not Playing
    By sandrajohnson54 in forum OS X - Operating System
    Replies: 2
    Last Post: 08-29-2012, 07:32 PM
  4. Replies: 5
    Last Post: 06-17-2012, 05:15 AM
  5. youtube videos not playing properly
    By 69camaro in forum OS X - Operating System
    Replies: 0
    Last Post: 04-30-2009, 04:28 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •