Results 1 to 3 of 3
  1. #1

    Member Since
    Feb 13, 2007
    Worthing, West Sussex, UK
    27" iMac 3.1Ghz 16GB RAM, 1TB HD. iPhone 4.
    Cant Restore From Time Machine!
    Due to problems I was having with my Mac running slow after upgrading to Snow Leopard when it was first released, the other day I completely wiped my Mac and did a complete re-install of Snow Leopard.

    The good news is that my Mac is now back to being very fast and working perfectly. The bad news is that I am unable to restore certain files from my Time Machine drive!

    When I re-installed SL I completely blitzed the drive and didn't migrate my old user account from my Time Machine backup because I didn't realise I could. So my old user account was say peakoverload and when I re-installed SL I again called my account peakoverload with the same password as I used before, effectively recreating the same account.

    I then installed the applications I wanted and set about restoring my files from Time Machine.

    I entered Time Machine, went back to the day before I re-installed SL, selected the Documents folder and hit restore. All single files in the root of the documents folder were restored but any files within sub folders were not? To restore these I then had to go into the relevant sub folder in Time Machine, select the files and hit restore. I found that if files were in sub folders I got an error message saying:

    "The operation canít be completed because you donít have permission to access some items"

    I worked around this and simply restored each file(s) individually.

    However I then noticed that my Aperture Library file had not been fully restored showing up as 0KB whereas in Time Machine it's over 7GB.

    No matter what I try I cannot restore this file getting this error message:

    "The operation canít be completed because you donít have permission to access Aperture Library"

    Looking at the permissions of this file in Time Machine it says that: peakoverload (Me) has Read & Write privilege (but is that the new me or the old me and does that matter?)
    _unknown has read privilege
    everyone has read privilege

    If I try to add user privileges peakoverload is greyed out, presumably because it's already added but I can add administrators. However my peakoverload account is an administrator one yet even adding this permission doesnt allow me to restore the file!

    Any ideas what I can do to restore this file?

  2. #2

    louishen's Avatar
    Member Since
    Oct 22, 2007
    Mac Mini Core i7 2012 | White 2009 MacBook 2 Ghz | 733 Mhz G4 Quicksilver
    Rename your new user account to something else (do this in System Preferences > Accounts - not just manually rename the folder), then you should be able to restore peakoverload in its entirety
    Member of the Month September 2008 & August 2012 | Found advice useful? Ė use the rep system

  3. #3

    Member Since
    Feb 13, 2007
    Worthing, West Sussex, UK
    27" iMac 3.1Ghz 16GB RAM, 1TB HD. iPhone 4.
    Cheers for that. I tried that but unfortunately it didn't work. However I did manage to resolve it by using Toast to create a disc image of my Aperture Library from within my Time Machine backup. Then mounting the image and simply copying the contents to my Pictures folder.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Time Machine Restore
    By rfomlover in forum Apple Notebooks
    Replies: 2
    Last Post: 02-16-2015, 07:23 PM
  2. Replies: 3
    Last Post: 11-26-2014, 10:53 PM
  3. Replies: 9
    Last Post: 11-28-2011, 02:20 PM
  4. how much time to restore 450gb with time machine
    By bellastrada in forum OS X - Apps and Games
    Replies: 6
    Last Post: 09-22-2009, 01:08 AM
  5. Time Machine backup restore on/to a different machine?
    By scarredtaka in forum OS X - Operating System
    Replies: 3
    Last Post: 01-10-2008, 04:35 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts