New To Mac-Forums?

Welcome to our community! Join the discussion today by registering your FREE account. If you have any problems with the registration process, please contact us!

Get your questions answered by community gurus Advice and insight from world-class Apple enthusiasts Exclusive access to members-only contests, giveaways and deals

Join today!

 
Start a Discussion
 

Mac-Forums Brief

Subscribe to Mac-Forums Brief to receive special offers from Mac-Forums partners and sponsors

Join the conversation RSS
OS X - Operating System General OS operation information and support

dyld: Library not loaded: /usr/lib/libaprutil-1.0.dylib


Post Reply New Thread Subscribe

 
Thread Tools
Stunner

 
Member Since: Apr 03, 2010
Posts: 1
Stunner is on a distinguished road

Stunner is offline
Ey guys, so I have quite a bit of a problem.

This time I followed this: Lemon Team’s blog Blog Archive Setting up Subversion 1.5 on Xcode

The last two steps I did and after I did it. My Xcode project's SVN capabilities were gone and when I went to add in a new repository the settings for subversion wouldn't pop up, but they would appear fine for Perforce and CVS. Anyways, hardly knowing anything about symbolic links, I wanted to undo my changes, so I made this script and ran it:

Code:
mkdir temp
cp /usr/lib/libapr-1.dylib ./temp
cp /usr/lib/libapr-1.0.dylib ./temp
cp /usr/lib/libaprutil-1.dylib ./temp
cp /usr/lib/libaprutil-1.0.dylib ./temp
cp /usr/lib/libsvn_client-1.dylib ./temp
cp /usr/lib/libsvn_client-1.0.dylib ./temp
cp /usr/lib/libsvn_diff-1.dylib ./temp
cp /usr/lib/libsvn_diff-1.0.dylib ./temp
cp /usr/lib/libsvn_fs_fs-1.dylib ./temp
cp /usr/lib/libsvn_fs_fs-1.0.dylib ./temp
cp /usr/lib/libsvn_fs-1.dylib ./temp
cp /usr/lib/libsvn_fs-1.0.dylib ./temp
cp /usr/lib/libsvn_ra_local-1.dylib ./temp
cp /usr/lib/libsvn_ra_local-1.0.dylib ./temp
cp /usr/lib/libsvn_ra_svn-1.dylib ./temp
cp /usr/lib/libsvn_ra_svn-1.0.dylib ./temp
cp /usr/lib/libsvn_ra-1.dylib ./temp
cp /usr/lib/libsvn_ra-1.0.dylib ./temp
cp /usr/lib/libsvn_wc-1.dylib ./temp
cp /usr/lib/libsvn_wc-1.0.dylib ./temp
cp /usr/lib/libsvn_repos-1.dylib ./temp
cp /usr/lib/libsvn_repos-1.0.dylib ./temp
cp /usr/lib/libsvn_subr-1.dylib ./temp
cp /usr/lib/libsvn_subr-1.0.dylib ./temp
cp /usr/lib/libsvn_delta-1.dylib ./temp
cp /usr/lib/libsvn_delta-1.0.dylib ./temp
cp /usr/lib/libsvn_diff-1.dylib ./temp
cp /usr/lib/libsvn_diff-1.0.dylib ./temp
rm /usr/lib/libapr-1.dylib
rm /usr/lib/libapr-1.0.dylib
rm /usr/lib/libaprutil-1.dylib
rm /usr/lib/libaprutil-1.0.dylib
rm /usr/lib/libsvn_client-1.dylib
rm /usr/lib/libsvn_client-1.0.dylib
rm /usr/lib/libsvn_diff-1.dylib
rm /usr/lib/libsvn_diff-1.0.dylib
rm /usr/lib/libsvn_fs_fs-1.dylib
rm /usr/lib/libsvn_fs_fs-1.0.dylib
rm /usr/lib/libsvn_fs-1.dylib
rm /usr/lib/libsvn_fs-1.0.dylib
rm /usr/lib/libsvn_ra_local-1.dylib
rm /usr/lib/libsvn_ra_local-1.0.dylib
rm /usr/lib/libsvn_ra_svn-1.dylib
rm /usr/lib/libsvn_ra_svn-1.0.dylib
rm /usr/lib/libsvn_ra-1.dylib
rm /usr/lib/libsvn_ra-1.0.dylib
rm /usr/lib/libsvn_wc-1.dylib
rm /usr/lib/libsvn_wc-1.0.dylib
rm /usr/lib/libsvn_repos-1.dylib
rm /usr/lib/libsvn_repos-1.0.dylib
rm /usr/lib/libsvn_subr-1.dylib
rm /usr/lib/libsvn_subr-1.0.dylib
rm /usr/lib/libsvn_delta-1.dylib
rm /usr/lib/libsvn_delta-1.0.dylib
rm /usr/lib/libsvn_diff-1.dylib
rm /usr/lib/libsvn_diff-1.0.dylib
And that definitely did not fix the problem. I even uninstalled and reinstalled Xcode to try to get the functionality back but that didn't work, and while I was installing Xcode I realized this error message for svn:
Code:
$ svn
dyld: Library not loaded: /usr/lib/libaprutil-1.0.dylib
  Referenced from: /opt/subversion/bin/svn
  Reason: image not found
So I tried installing svn again and that didn't do the trick either. So I am really in a pickle now. If anyone can help me or point me in the right direction as to what to do to fix the problem, please let me know! Thanks in advance.
QUOTE Thanks

Post Reply New Thread Subscribe


« Images Not Showing in "Preview" Application | Changing image files of applications »
Thread Tools

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off
Forum Jump

Similar Threads
Thread
Thread Starter
Forum
Replies
Last Post
share an iPhoto library between two macs on home network Mo_274 OS X - Apps and Games 2 09-04-2009 08:02 AM
iTunes Tips And Tricks RJgamer iPod Hardware and Accessories 2 07-12-2007 11:59 AM
Just How Secure Are the 'Reset Safari' & 'Erase Free Space' Facility? scoot OS X - Operating System 3 05-30-2007 05:28 PM
100s of crashes every time I update library wealcan iPod Hardware and Accessories 1 04-28-2007 12:26 AM

All times are GMT -4. The time now is 10:14 AM.

Powered by vBulletin
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
X

Welcome to Mac-Forums.com

Create your username to jump into the discussion!

New members like you have made this community the ultimate source for your Mac since 2003!


(4 digit year)

Already a member?