New To Mac-Forums?

Welcome to our community! Join the discussion today by registering your FREE account. If you have any problems with the registration process, please contact us!

Get your questions answered by community gurus Advice and insight from world-class Apple enthusiasts Exclusive access to members-only contests, giveaways and deals

Join today!

 
Start a Discussion
 

Mac-Forums Brief

Subscribe to Mac-Forums Brief to receive special offers from Mac-Forums partners and sponsors

Join the conversation RSS
OS X - Operating System General OS operation information and support

MAC Problems [+Safari, AirPort]


Post Reply New Thread Subscribe

 
Thread Tools
lasantos

 
Member Since: Feb 28, 2010
Posts: 2
lasantos is on a distinguished road

lasantos is offline
Hello all

I got a brand new Macbook Pro.
It's really cool, i'm loving it... but some problems are making em nervous.

First:
In Safari, many images are not loading properly.
They load about half way, then the rest of it is filled with a gray color.
It's just annoying!

Second:
I have a router D-Link, and i use internet wireless.
I am getting disconnected every time! When i am browsing, downloads just stops, videos stops loading and a cant connect to the router.
To solve it, i have to restart AirPort and do everything from the beginning.


It's all really annoying... i really need some help to solve it. Just not normal.

Someone know how to solve those things?
Thank you.

(Sorry for bad english)
QUOTE Thanks
chas_m

 
chas_m's Avatar
 
Member Since: Jan 22, 2010
Location: Victoria, BC
Posts: 15,696
chas_m has a reputation beyond reputechas_m has a reputation beyond reputechas_m has a reputation beyond reputechas_m has a reputation beyond reputechas_m has a reputation beyond reputechas_m has a reputation beyond reputechas_m has a reputation beyond reputechas_m has a reputation beyond reputechas_m has a reputation beyond reputechas_m has a reputation beyond reputechas_m has a reputation beyond repute
Mac Specs: 2009 MBP, Black speakers, Black Benq second monitor, black(ish) iPhone 5s, Black 2012 iPad, etc.

chas_m is offline
Replace the D-Link with a good router. I suggest the Apple brand, since I've never found a router that outperforms it, or is easier to set up and configure.
QUOTE Thanks
TheTGDJ

 
Member Since: Feb 08, 2010
Location: United Kingdom
Posts: 9
TheTGDJ is on a distinguished road
Mac Specs: 13" MacBook Pro, 2.53 GHz Intel Core 2 Duo, 4GB 1067 MHz DDR3.

TheTGDJ is offline
I would also suggest getting a new router I use Netgear for my router and touch wood I have had no problems with it so far. I would also try the basic and obvious reasons such as clearing your cache and switching off your modem for 30 seconds and then your router for 30 seconds. Sometimes this helps fix basic problems.
QUOTE Thanks
lasantos

 
Member Since: Feb 28, 2010
Posts: 2
lasantos is on a distinguished road

lasantos is offline
In other forums, ppl are saying that WPA or WPA2 might cause this problem.

Even tho its not safe, i'll change it to WEP and see if it works.

If the problem persists, probably i am going to change the router.

Thanks for the replies.


But the problem with the Safari still here... anyone had the same problem?
QUOTE Thanks

Post Reply New Thread Subscribe


« Mail help needed! =] | need help restoring account 10.4 »
Thread Tools

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off
Forum Jump

Similar Threads
Thread
Thread Starter
Forum
Replies
Last Post
Three tremendous problems with my Mac. Please help me. (long read) DismantleDesign Apple Notebooks 4 02-23-2010 04:52 PM
Running Windows on Mac rickmahmoud Running Windows (or anything else) on your Mac 7 02-16-2008 11:31 PM
Mac Users Get More ISP Choices schweb Apple Rumors and Reports 1 03-06-2003 10:57 AM

All times are GMT -4. The time now is 12:24 AM.

Powered by vBulletin
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
X

Welcome to Mac-Forums.com

Create your username to jump into the discussion!

New members like you have made this community the ultimate source for your Mac since 2003!


(4 digit year)

Already a member?