Results 1 to 4 of 4

Thread: Won't Login

  1. #1
    Won't Login

    Member Since
    Jan 26, 2010
    Posts
    3
    Won't Login
    System:
    This is a Powerbook G4 running Leopard.

    Problem:
    Computer boots, I see the login screen, type my password and then read the line says "logging in...". I see the basic blue background and then the cursor for a little while. Then it throws me back to the login screen again. I am more than 100% sure that the password is correct.

    Solutions I have tried:
    Booting in safe mode / won't login
    Booting in Single User Mode and then deleting the com.apple.loginwindow.plist file to force the system create a new one
    Zapping PRAM and booting in safe mode
    Single User Mode - I did fsck and no errors found.

    None of the above worked for me. I am wondering what the problem could be. I don't have another mac that I can backup my data using firewire cable. I am looking for a fix without installing the whole operating system from scratch or a way that I can save my data.

    What do you think the problem could be? Any input is greatly appreciated.

    Thank you!

  2. #2
    Won't Login
    toMACsh's Avatar
    Member Since
    Jul 30, 2009
    Location
    Wisconsin
    Posts
    5,826
    Specs:
    Mac Mini Core 2 Duo
    If the password was incorrect, wouldn't there be a message to that effect? (I never log out.)

    Do you think it would be worthwhile to boot from an OS disc and Repair Permissions?

  3. #3
    Won't Login

    Member Since
    Jan 26, 2010
    Posts
    3
    Thanks toMACsh.

    I finally solved the issue without installing everything from scratch. Takes a minute. I am not sure if it is post the link of another website so I am just going to quote the solution:

    THE SOLUTION :


    the lsregister process is crashing. I found a clue to the fix in a 2003 blog posting by a guy named Rick when he said After a couple hours of snooping, and some luck (I was able to ssh in from another machine and watch the system log report the crashes), I discovered that Launch Services’ cache was corrupted, and was causing lsregister to seg fault. His posting was related to MacOSX 10.2.6, and since then the name of the Launch Services cache file has morphed. I found it in the same place (the /Library/Caches directory), but now there is more than one and they take the form of “com.apple.LaunchServices-023uid.csstore” where uid varies depending on the appropriate userid number. I removed all of the Launch Services files from /Library/Caches, restarted, and was able to log in fine. The only side effect was that the applications-to-launch-at-login list was gone (the “Login Items” tab of the Account Preference Pane) and had to be reconstructed.
    Link to the Article: Fixing a Mac OSX Leopard Login Loop Caused by Launch Services | Disruptive Library Technology Jester

    Cheers!

  4. #4
    Won't Login
    deus_ex_machina's Avatar
    Member Since
    Aug 06, 2004
    Location
    Tejas
    Posts
    1,713
    Specs:
    2GHz Mac Mini 2GB RAM 160GB 10.6.2 | MDD DP 1.25GHz G4 1.5GB RAM 10.4.11 | 233MHz iMac G3 10.3.9
    Thanks for posting the solution!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Mac freezes & won't login
    By dy699 in forum OS X - Operating System
    Replies: 5
    Last Post: 09-18-2013, 05:57 PM
  2. MacBook white won't login?
    By Kittybuick in forum Apple Notebooks
    Replies: 0
    Last Post: 05-06-2012, 02:38 PM
  3. Can't boot from disk, Darwin won't take login
    By Socalfem in forum Apple Desktops
    Replies: 4
    Last Post: 12-27-2011, 02:14 AM
  4. Firefox won't login?
    By chew in forum OS X - Apps and Games
    Replies: 2
    Last Post: 11-06-2008, 08:41 AM
  5. eMac won't LOGIN
    By Vacuum in forum OS X - Operating System
    Replies: 15
    Last Post: 12-05-2004, 09:34 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •