Mac Forums

Mac Forums (http://www.mac-forums.com/forums/)
-   OS X - Operating System (http://www.mac-forums.com/forums/os-x-operating-system/)
-   -   commands for changing sharing permissions (http://www.mac-forums.com/forums/os-x-operating-system/176449-commands-changing-sharing-permissions.html)

MiamiSpeedin86 11-17-2009 07:02 AM

commands for changing sharing permissions
 
hello all, my first post in this forum

forgive my newbness, i am very unfamiliar with macs

i have recently had a problem on osx 10.5 leopard...
when i start up computer it shows the mac logo and the loading symbol but it doesnşt pass that, i have left the computer on for hours and it does not go anywhere..

i have tried that command to make it seem like a fresh install has been made
.AppleSetupDone but when it gets to setup internet connection same thing happens... the rainbow circle just keeps spinning for hours and nothing happens


i messed with the sharing and permissions to the hard drive(maybe this caused it?)

this is what i did

user 1 - read and write
user 2 - read only
everyone - read only (this is where i changed it to ´none´)

is this what messed it up?

is there a command i can put in the DOS looking like thing that can change the permissions back for everyone to read only

any help would be greatly appreciated, before my dad kills me for ruining his macs


btw i have another macbook air with same problem and another with no problem... incase i need another mac to get into the broken ones

louishen 11-17-2009 08:05 AM

Try booting up in safe mode first and see if you can get in to the system

To start up into Safe Mode (to Safe Boot), do this:

1. Be sure the computer is shut down.

2. Press the power button.

3. Immediately after you hear the startup tone, hold the Shift key. The Shift key should be held as soon as possible after the startup tone but not before.

4. Release the Shift key when you see the gray Apple icon and the progress indicator (looks like a spinning gear).

MiamiSpeedin86 11-18-2009 07:05 AM

No. I just tried that and it still is stuck at apple logo with spinning gears...
Another problem is these MacBook airs don't make a startup chime for some reason too, but I tried various times holding the shift key at a different time, everytime I started up.


Is there something else I can try?

MiamiSpeedin86 11-18-2009 07:06 AM

Is there a way to safe boot from single user mode?

MiamiSpeedin86 11-18-2009 01:25 PM

And I tried the fsck command but that did not help either...

I do not have the original CDs because my dad is great for throwing those things away

MiamiSpeedin86 11-19-2009 12:33 PM

Bump. Please help me. I have tried searching and asking people but. Still no reply. I know there is a command to restore the file permissions I just don't know what they are lol please help

louishen 11-19-2009 01:14 PM

If you can get to the command line then you can do a permissions repair

Quote:

sudo diskutil repairPermissions /

MiamiSpeedin86 11-20-2009 01:53 PM

Negative... System message

sudo: can't open /private/etc/subfolders: permission denied
:/ root# sendmail: warning: valid_hostname: empty hostname
sendmail: fatal: unable to use my own hostname

louishen 11-20-2009 02:13 PM

Give these a go

mount -uw /
chown root /
chmod 1775 /
exit

MiamiSpeedin86 11-24-2009 09:10 AM

thanks louishen that worked perfect!!!!

did it on both my macs and its 100% now!

i wish you many sexy parties(stewie)

RobinJ6 04-03-2011 08:03 PM

Thanks!
 
Ok guys, I know this thread is nearly 2 years old and I apologise for that. Against regular forum use I know.

But

I have to thank you guys for this. Was literally about to die with my mac issues, NOWHERE else on the entire internet has offered a solution to this issue other than to reformat and start again.

I nearly cried when this method got my little 2008 macbook back and running again.

So thanks, really. And sorry again for bringing back a dead thread. :)


All times are GMT -4. The time now is 01:04 PM.

Powered by vBulletin
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.