I'm using MacPorts and install libtool 2.2. But then I realized that I needed libtool 1.5

I tried to do:
port uninstall libtool
port install libtool1

But then when Ii type libtool --version I still can see that I have libtool of version 2.2

What am I doing wrong and how to install libtool 1.5

Thanks in advance,