Mac Forums

Mac Forums (http://www.mac-forums.com/forums/)
-   OS X - Operating System (http://www.mac-forums.com/forums/os-x-operating-system/)
-   -   formatted usb in os x now it wont work in windows (http://www.mac-forums.com/forums/os-x-operating-system/172963-formatted-usb-os-x-now-wont-work-windows.html)

unix 10-23-2009 11:34 PM

formatted usb in os x now it wont work in windows
 
i used disk utility to format my usb thumb drive with the MS-DOS format. and when i put it into my windows pc, it says it needs to be initialized, but when i try to initialize it it only formats 200mb out of the 4GB that exists on my drive....what do i do...

chscag 10-24-2009 01:13 AM

What to do? Throw the drive away. You are not supposed to format most thumb flash drives unless the drive manufacturer specifically says it can be reformatted. Why did you try to format it in the first place? The drive was probably already pre-formatted to FAT-32 at the factory.

Regards.

Nethfel 10-24-2009 01:52 AM

Ok -
A) don't worry, it's NOT a big deal.
B) The problem is most likely easily fixable if what I think happened, happened.

Here's what's most likely happened:

When you formatted the thumb drive w/ disk utilities it was set to use a GUID partition table scheme. On a Mac this isn't a big deal - on a PC, well it's a different story - when formatted with this scheme you end up with 2 partitions - a tiny one (that comes first in the partition table, but is invisible on OSX) and your main one. Windows doesn't like thumb drives with multiple partitions, and will see the first small partition, claiming the drive isn't formatted, then once formatted, you end up with a 200meg drive - if you use the manage tool in windows and go to the drives section, you'll see the drive there with the multiple partitions.

put your thumb drive back in your mac, go to disk utilities, go to partition, select 1 Partition, make sure it's set for FAT32, and on the bottom, click options, make sure to change the partition table to master boot record. apply the changes.

That *should* fix the problem. I had a similar problem when I reformatted a thumb drive and didn't think to check the partition table scheme, changed it and repartitioned and it was good again.

unix 10-24-2009 02:54 AM

great fix Nethfel, i tried it out and it worked perfectly. thanks a ton man.

Nethfel 10-24-2009 10:44 AM

Not a problem, glad I could help out.


All times are GMT -4. The time now is 04:55 AM.

Powered by vBulletin
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.