Mac Forums

Mac Forums (http://www.mac-forums.com/forums/)
-   OS X - Operating System (http://www.mac-forums.com/forums/os-x-operating-system/)
-   -   Snow lepoard running crazy slow (http://www.mac-forums.com/forums/os-x-operating-system/171610-snow-lepoard-running-crazy-slow.html)

BostonMarley 10-14-2009 06:32 PM

Snow lepoard running crazy slow
 
New to the forums here because I have never had any issues with any of the Macs I have ever owned. I am hoping someone who is more knowledgeable can help me. I upgraded my imac from Tiger to Snow Leopard last week and the computer is running beyond slow now. It seems like all I ever see is the rainbow pinwheel spinning around and around. I cant even play a song in itunes without it pausing in the middle of a song.

I have tried to research this online but I havent found anything that helps. I already deleted the LaunchDaemons/com.apple.audio.coreaudiod.plist file but that didnt help. Is anyone having the same issues?

Thanks for your help.

podraig 10-14-2009 07:02 PM

Check
 
Have a look here first, and check whether the update applies to your computer;
Apple - Downloads - Mac OS X Updates - Performance Update 1.0 (Snow Leopard)
If it does not apply to you or work for you, then go to users in pref panes,
(1) disable guest account,
(2) disable THIRD PARTY Preference panes
(3) Check for updates of third party plugins for Safari and Mail and uninstall them if not compatible.
If you have further problems;
try resetting pram; restart holding down option command p and r keys until you hear chime for the second time then let go
If all of these options fail, insert install disc, utilities, disc utility, repair permissions. Do this from your install disc
;D

cwa107 10-14-2009 08:19 PM

I had a similar intermittent issue and found that it was related to incompatible third-party daemons running in the background. I was able to nail this down just by seeing the repeat instances of starting and stopping of the daemon in the Console log (Applications => Utilities => Console). Once I removed it (Paragon Snapshot Beta), performance was great for a little while.

Shortly after that, I noticed that Paragon updated another one of their products that I use - Paragon NTFS for Mac, claiming that it was now Snow Leopard compatible. I installed it and it seemed to work fine initially. But I started encountering numerous spinning wheels, particularly when using Firefox and iPhoto, but also using other miscellaneous applications. I found that after removing Paragon NTFS, everything was great again.

The moral of this story, even if you did a clean install, as I did - it's entirely possible that the migration assistant can pull over incompatible software that runs transparently in the background and can cause major issues.

Take a look at Console and see if anything stands out as being weird. Also, use a program like AppFresh to ensure that all of your apps are up to date.

BostonMarley 10-15-2009 03:52 PM

Well the update didn't work because it said that I was not having thos issues. I went under the accounts and it only shows one account. No third party accounts of anykind. I tried to reset the pram but for some reason I would never get a second chime so I have no idea what that means. I guess today after work I will boot from the instal disc to see if I can repair the permissions.

CWA- I like your idea but to be honest I am not sure what I am looking for. Guess this experience shows me how little I know about macs even though I have owned them for years. Just never had an issue. Used to working on my PCs because they mess up everyday it seems.

cwa107 10-15-2009 03:55 PM

Save a copy of your console log and attach it to your next post. I'll look through it and see if anything jumps out at me.

BostonMarley 10-15-2009 06:37 PM

Man I really appreciate you helping me with this cwa. Let me know if you need more. I had to take alot out to post it on here.


10/14/09 6:35:58 PM com.apple.Dock.agent[78] 2009-10-14 18:35:58.711 DashboardClient[315:a03] [110d70] |Server|Warning| failed to connect to the server: NSPortTimeoutException connection timeout: did not receive reply
10/14/09 6:36:18 PM [0x0-0x35035].com.apple.Safari[312] Wed Oct 14 18:36:18 sil-yangs-computer.local Safari[312] <Error>: kCGErrorCannotComplete: CGSDeviceUnlock: Invalid device window
10/14/09 6:36:18 PM [0x0-0x35035].com.apple.Safari[312] Wed Oct 14 18:36:18 sil-yangs-computer.local Safari[312] <Error>: kCGErrorFailure: Set a breakpoint @ CGErrorBreakpoint() to catch errors as they are logged.
10/14/09 6:36:18 PM [0x0-0x35035].com.apple.Safari[312] Wed Oct 14 18:36:18 sil-yangs-computer.local Safari[312] <Error>: kCGErrorCannotComplete: CGSDeviceLock: Invalid device window
10/14/09 6:36:18 PM [0x0-0x35035].com.apple.Safari[312] Wed Oct 14 18:36:18 sil-yangs-computer.local Safari[312] <Error>: kCGErrorCannotComplete: CGSDeviceLock: Invalid device window
10/14/09 6:36:18 PM [0x0-0x35035].com.apple.Safari[312] Wed Oct 14 18:36:18 sil-yangs-computer.local Safari[312] <Error>: kCGErrorCannotComplete: CGSDeviceLock: Invalid device window
10/14/09 6:36:18 PM [0x0-0x35035].com.apple.Safari[312] Wed Oct 14 18:36:18 sil-yangs-computer.local Safari[312] <Error>: kCGErrorCannotComplete: CGSDeviceLock: Invalid device window
10/14/09 6:36:18 PM [0x0-0x35035].com.apple.Safari[312] Wed Oct 14 18:36:18 sil-yangs-computer.local Safari[312] <Error>: kCGErrorCannotComplete: CGSDeviceLock: Invalid device window
10/14/09 6:36:18 PM [0x0-0x35035].com.apple.Safari[312] Wed Oct 14 18:36:18 sil-yangs-computer.local Safari[312] <Error>: kCGErrorCannotComplete: CGSDeviceSynchronize: Invalid device window
10/14/09 6:36:18 PM com.apple.launchd.peruser.501[74] ([0x0-0x1f01f].com.apple.Preview[179]) Exited: Killed
10/14/09 6:36:51 PM com.apple.launchd[1] *** launchd[1] has started up. ***
10/14/09 6:37:49 PM com.apple.launchd.peruser.501[73] (com.apple.ReportCrash) Falling back to default Mach exception handler. Could not find: com.apple.ReportCrash.Self
10/14/09 6:38:20 PM com.apple.launchd.peruser.501[73] (com.apple.Kerberos.renew.plist[89]) Exited with exit code: 1
10/14/09 6:38:33 PM com.apple.launchd.peruser.501[73] (com.apple.pbs) Throttling respawn: Will start in 9 seconds
10/14/09 6:38:43 PM com.apple.WindowServer[55] Wed Oct 14 18:38:43 sil-yangs-computer.local WindowServer[55] <Error>: kCGErrorFailure: Set a breakpoint @ CGErrorBreakpoint() to catch errors as they are logged.
10/14/09 6:48:05 PM [0x0-0x13013].com.apple.iTunes[123] Child process initialized.
10/14/09 6:48:31 PM com.apple.launchd.peruser.501[73] ([0x0-0x15015].com.kodak.EasyShare[126]) Exited with exit code: 1
10/14/09 6:51:54 PM com.apple.WebKit.PluginAgent[144] Debugger() was called!
10/14/09 7:38:46 PM SubmitDiagInfo[166] Removed expired file /Library/Logs/DiagnosticReports/SystemUIServer_2009-09-30-193301_sil-yangs-computer.spin
10/14/09 8:15:41 PM com.apple.WebKit.PluginAgent[144] Debugger() was called!
10/14/09 8:30:30 PM [0x0-0x13013].com.apple.iTunes[123] Child process initialized.
10/14/09 8:30:30 PM AppleMobileBackup[198] BackupAgent starting up...
10/14/09 8:30:30 PM [0x0-0x13013].com.apple.iTunes[123] 2009-10-14 20:30:30.422 AppleMobileBackup[198:903] BackupAgent starting up...
10/14/09 8:38:06 PM com.apple.WebKit.PluginAgent[144] Debugger() was called!
10/14/09 8:38:07 PM [0x0-0x13013].com.apple.iTunes[123] Child process initialized.
10/14/09 8:50:02 PM System Preferences[247] Could not connect the action resetLocationWarningsSheetOk: to target of class AppleSecurity_Pref
10/14/09 8:50:02 PM System Preferences[247] Could not connect the action resetLocationWarningsSheetCancel: to target of class AppleSecurity_Pref
10/14/09 8:52:56 PM com.apple.launchd.peruser.501[73] ([0x0-0x28028].com.apple.Console[241]) Exited: Killed
10/14/09 8:53:16 PM com.apple.launchd[1] *** launchd[1] has started up. ***
10/14/09 8:54:25 PM com.apple.launchd.peruser.501[78] (com.apple.ReportCrash) Falling back to default Mach exception handler. Could not find: com.apple.ReportCrash.Self
10/14/09 8:54:50 PM com.apple.launchd.peruser.501[78] (com.apple.Kerberos.renew.plist[95]) Exited with exit code: 1
10/15/09 1:16:43 PM com.apple.launchd[1] *** launchd[1] has started up. ***
10/15/09 1:19:36 PM com.apple.launchd.peruser.501[80] (com.apple.ReportCrash) Falling back to default Mach exception handler. Could not find: com.apple.ReportCrash.Self
10/15/09 1:19:55 PM com.apple.launchd.peruser.501[80] (com.apple.Kerberos.renew.plist[95]) Exited with exit code: 1
10/15/09 1:20:09 PM com.apple.WindowServer[53] Thu Oct 15 13:20:09 sil-yangs-computer.local WindowServer[53] <Error>: kCGErrorFailure: Set a breakpoint @ CGErrorBreakpoint() to catch errors as they are logged.
10/15/09 1:21:20 PM com.apple.WebKit.PluginAgent[118] Debugger() was called!
10/15/09 1:22:12 PM com.apple.WebKit.PluginAgent[118] Debugger() was called!
10/15/09 1:22:50 PM com.apple.WebKit.PluginAgent[118] Debugger() was called!
10/15/09 1:23:12 PM com.apple.WebKit.PluginAgent[118] Debugger() was called!
10/15/09 1:23:38 PM com.apple.WebKit.PluginAgent[118] Debugger() was called!
10/15/09 1:24:01 PM com.apple.WebKit.PluginAgent[118] Debugger() was called!
10/15/09 1:24:31 PM com.apple.WebKit.PluginAgent[118] Debugger() was called!
10/15/09 1:28:22 PM com.apple.WebKit.PluginAgent[118] Debugger() was called!

10/15/09 1:29:48 PM ReportCrash[125] Saved crash report for WebKitPluginHost[124] version 6531 (6531.4) to /Users/silyang/Library/Logs/DiagnosticReports/WebKitPluginHost_2009-10-15-132948_sil-yangs-computer.crash
10/15/09 1:40:29 PM ReportCrash[140] Saved crash report for WebKitPluginHost[126] version 6531 (6531.4) to /Users/silyang/Library/Logs/DiagnosticReports/WebKitPluginHost_2009-10-15-134029_sil-yangs-computer.crash
10/15/09 1:41:44 PM com.apple.WebKit.PluginAgent[118] Debugger() was called!
10/15/09 1:45:19 PM com.apple.WebKit.PluginAgent[118] Debugger() was called!
10/15/09 1:46:51 PM com.apple.WebKit.PluginAgent[118] Debugger() was called!
10/15/09 1:48:46 PM com.apple.WebKit.PluginAgent[118] Debugger() was called!
10/15/09 1:48:53 PM com.apple.WebKit.PluginAgent[118] Debugger() was called!
10/15/09 1:49:10 PM com.apple.WebKit.PluginAgent[118] Debugger() was called!
10/15/09 1:51:14 PM ReportCrash[154] Saved crash report for WebKitPluginHost[150] version 6531 (6531.4) to /Users/silyang/Library/Logs/DiagnosticReports/WebKitPluginHost_2009-10-15-135114_sil-yangs-computer.crash
10/15/09 1:51:33 PM com.apple.launchd.peruser.501[80] ([0x0-0xe00e].com.apple.Safari[115]) Job appears to have crashed: Segmentation fault
10/15/09 1:52:08 PM ReportCrash[154] Saved crash report for Safari[115] version 4.0.3 (6531.9) to /Users/silyang/Library/Logs/DiagnosticReports/Safari_2009-10-15-135208_sil-yangs-computer.crash
10/15/09 1:54:11 PM com.apple.WebKit.PluginAgent[169] Debugger() was called!
10/15/09 3:51:59 PM com.apple.WebKit.PluginAgent[169] Debugger() was called!
10/15/09 3:52:16 PM com.apple.WebKit.PluginAgent[169] Debugger() was called!
10/15/09 6:12:45 PM SubmitDiagInfo[217] Submitted spin report: /Library/Logs/DiagnosticReports/SystemUIServer_2009-10-15-155127_sil-yangs-computer.spin
10/15/09 6:13:03 PM SubmitDiagInfo[217] Removed expired file /Users/silyang/Library/Logs/DiagnosticReports/WebKitPluginHost_2009-10-01-172707_sil-yangs-computer.crash
10/15/09 6:13:13 PM SubmitDiagInfo[217] Removed expired file /Users/silyang/Library/Logs/DiagnosticReports/WebKitPluginHost_2009-10-01-172058_sil-yangs-computer.crash
10/15/09 6:13:17 PM SubmitDiagInfo[217] Removed expired file /Users/silyang/Library/Logs/DiagnosticReports/WebKitPluginHost_2009-10-01-172003_sil-yangs-computer.crash
10/15/09 6:13:17 PM SubmitDiagInfo[217] Removed expired file /Users/silyang/Library/Logs/DiagnosticReports/WebKitPluginHost_2009-10-01-171803_sil-yangs-computer.crash
10/15/09 6:13:17 PM SubmitDiagInfo[217] Removed expired file /Users/silyang/Library/Logs/DiagnosticReports/WebKitPluginHost_2009-10-01-171738_sil-yangs-computer.crash
10/15/09 6:13:17 PM SubmitDiagInfo[217] Removed expired file /Users/silyang/Library/Logs/DiagnosticReports/WebKitPluginHost_2009-10-01-171629_sil-yangs-computer.crash
10/15/09 6:13:17 PM SubmitDiagInfo[217] Removed expired file /Users/silyang/Library/Logs/DiagnosticReports/WebKitPluginHost_2009-10-01-171458_sil-yangs-computer.crash
10/15/09 6:13:17 PM SubmitDiagInfo[217] Removed expired file /Users/silyang/Library/Logs/DiagnosticReports/WebKitPluginHost_2009-10-01-171438_sil-yangs-computer.crash
10/15/09 6:13:18 PM SubmitDiagInfo[217] Removed expired file /Users/silyang/Library/Logs/DiagnosticReports/WebKitPluginHost_2009-10-01-171347_sil-yangs-computer.crash
10/15/09 6:13:18 PM SubmitDiagInfo[217] Removed expired file /Users/silyang/Library/Logs/DiagnosticReports/WebKitPluginHost_2009-10-01-133047_sil-yangs-computer.crash
10/15/09 6:13:18 PM SubmitDiagInfo[217] Removed expired file /Users/silyang/Library/Logs/DiagnosticReports/WebKitPluginHost_2009-10-01-130406_sil-yangs-computer.crash
10/15/09 6:13:34 PM SubmitDiagInfo[217] Submitted crash report: /Users/silyang/Library/Logs/DiagnosticReports/WebKitPluginHost_2009-10-15-135114_sil-yangs-computer.crash
10/15/09 6:13:51 PM SubmitDiagInfo[217] Submitted crash report: /Users/silyang/Library/Logs/DiagnosticReports/Safari_2009-10-15-135208_sil-yangs-computer.crash
10/15/09 6:14:46 PM SubmitDiagInfo[217] SubmitDiagInfo successfully uploaded 16 diagnostic messages.
10/15/09 6:15:12 PM com.apple.WebKit.PluginAgent[169] Debugger() was called!
10/15/09 6:15:33 PM com.apple.WebKit.PluginAgent[169] Debugger() was called!

BostonMarley 10-15-2009 06:44 PM

This is all it says lately:

10/15/09 6:14:46 PM SubmitDiagInfo[217] SubmitDiagInfo successfully uploaded 16 diagnostic messages.
10/15/09 6:15:12 PM com.apple.WebKit.PluginAgent[169] Debugger() was called!
10/15/09 6:15:33 PM com.apple.WebKit.PluginAgent[169] Debugger() was called!
10/15/09 6:30:15 PM com.apple.WebKit.PluginAgent[169] Debugger() was called!
10/15/09 6:31:20 PM com.apple.WebKit.PluginAgent[169] Debugger() was called!
10/15/09 6:32:01 PM com.apple.WebKit.PluginAgent[169] Debugger() was called!
10/15/09 6:32:34 PM com.apple.WebKit.PluginAgent[169] Debugger() was called!
10/15/09 6:33:09 PM com.apple.WebKit.PluginAgent[169] Debugger() was called!
10/15/09 6:33:26 PM com.apple.WebKit.PluginAgent[169] Debugger() was called!
10/15/09 6:34:41 PM com.apple.WebKit.PluginAgent[169] Debugger() was called!
10/15/09 6:35:01 PM com.apple.WebKit.PluginAgent[169] Debugger() was called!
10/15/09 6:35:36 PM com.apple.WebKit.PluginAgent[169] Debugger() was called!
10/15/09 6:36:10 PM com.apple.WebKit.PluginAgent[169] Debugger() was called!
10/15/09 6:36:42 PM com.apple.WebKit.PluginAgent[169] Debugger() was called!
10/15/09 6:42:31 PM com.apple.WebKit.PluginAgent[169] Debugger() was called!
10/15/09 6:42:50 PM com.apple.WebKit.PluginAgent[169] Debugger() was called!

vansmith 10-15-2009 06:46 PM

I'm not that great with logs (they're very cryptic to me) but it appears that you're having some issues with Webkit and plugins. In other words, something is happening with plugins and Safari. What plugins do you have installed? To check, open up Safari and go to Help > Installed Plug-Ins.

BostonMarley 10-15-2009 06:54 PM

The plugins I have are:

iPhotoPhotocast
Shockwave Flash
Quicktime 7.6.3
Quartz Composer
Java Plug-in for Cocoa

BostonMarley 10-15-2009 06:55 PM

I have no idea what the quartz composer is

cwa107 10-15-2009 08:23 PM

I don't really use Safari, but looking at mine, I seem to have all of those plug-ins and mine seems to run fine.

I did notice that there's a Kodak EasyShare component that failed. Are you up-to-date on Kodak's software? I know their Windows software is pretty flaky, I wouldn't be surprised if their Mac stuff is equally as bad.

Have you run Disk Utility at all to repair permissions / repair disk?

Also, have you tried creating a second account and using that just for troubleshooting purposes?

BostonMarley 10-16-2009 06:15 PM

Ok I did updates for Kodak EasyShare as well as for my printer but that didnt help out any. All I see is the freaking rainbow pinwheel all the time. I will now run Disk Utility to see if that helps.

BostonMarley 10-16-2009 06:40 PM

Well the disk permissions might be the issue there are several permissions being repaired.

BostonMarley 10-16-2009 07:17 PM

Hey in the permission report it says something that concerns me.

Warning:SUID file "System/library/core....as been modified and will not be repaired.


Anyone know what this means?

cwa107 10-16-2009 09:25 PM

Quote:

Originally Posted by BostonMarley (Post 925919)
Hey in the permission report it says something that concerns me.

Warning:SUID file "System/library/core....as been modified and will not be repaired.


Anyone know what this means?

I get that on two files, even after a clean install. I think it's a Snow Leopard bug.


All times are GMT -4. The time now is 08:24 PM.

Powered by vBulletin
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.