Results 1 to 3 of 3
  1. #1

    Member Since
    Mar 03, 2008
    Unhappy Bad Startup Error after Snow Leopard "Install"
    So I backed up my drive last night on Time Machine (I'm no dope) so that today I could upate to Snow Leopard. Well, I got almost through the install and then got an error message saying that Snow Leopard could not complete intsallation. I was able to choose my old startup disk and tried to reboot-- all to no avail. I zapped the PRAM, tried to start up in safe boot, and even with the Snow Leopard disk back in. Whenever it started up, it would get to the grey screen (apple showing), then shut off.

    Then I ran fsck and got this error:

    ** Checking Catalog file.
    disk0s3: I/O error.
    Invalid node structure
    (4, 3226)
    ** Volume check failed

    So I know my hard drive is whack, though I really don't think it's failing (because I have gotten some errors previously on Disk Utilty). Here's my question, though. If I wipe the drive clean and reinstall Leopard, then restore from Time Machione, will I also restore just the drive errors? I do own Disk Warrior and Prosoft's Drive utiltiy (Sorry, am at work-- can't remember the name). . .

    Suggestions, please!

  2. #2

    chscag's Avatar
    Member Since
    Jan 23, 2008
    Fort Worth, Texas
    27" iMac i5, 3.2 GHz, iPad 3, iPhone 5c, iPhone 6+, 3 iPods, El Capitan
    Lesson learned? Check the drive first before installing a new OS....

    You can try using Prosoft's Data Rescue II if you wish, but since you have a Time Machine backup why not:

    Buy a new drive, install Leopard on it, restore your data using the Time Machine backup, then install the Snow Leopard upgrade. Probably save yourself some time and headaches this way plus you'll have a new and larger hard drive.


  3. #3

    Member Since
    Mar 03, 2008

    I've finally fixed the problem, though it was a little weird.

    Neither my startup disks, nor installation disks for Leopard OR Tiger would work. I received the same error message, something to the effect that this OS could not be installed on this computer. Using the Leopard disk, I quick erased the hard drive, figuring that my drive errors were keeping me from being able to install Leopard. I then ran disk utility to ensure my errors were gone (they were), so I hoped Leopard might now install, but nope. . . still couldn't install Leopard. Finally I figured that Snow Leopard had originally all but installed on the computer and it wouldn't allow me to step down. I put in the Snow Leopard install disk and didn't get the message. Indeed, it now installed flawlessly, though it didn't give me customizable options at first (and I wanted Rosetta). Then I restored from Time Machine and finally, upon restart, I received a message saying that some HP installer/program (I didn't get a chance to jot it down) needed Rosetta and asked if I wanted to install it, so I did. Finally, when I seemed to be up and running again, I rechecked Disk Utility, just in case Time Machine restored the disk errors. Thankfully, they hadn't.

    So-- it's looking good. . . I hope.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. "Unclean" Install from 4.11 to Snow Leopard? - Help!
    By adrianzag in forum OS X - Operating System
    Replies: 8
    Last Post: 05-30-2014, 01:00 PM
  2. MBP 17" wont install Snow Leopard while downgrading from LION
    By iamtherena in forum OS X - Operating System
    Replies: 1
    Last Post: 11-29-2011, 05:54 PM
  3. What does this site's "Bad Request" error mean?
    By rsherid in forum OS X - Apps and Games
    Replies: 5
    Last Post: 08-24-2010, 04:59 PM
  4. Running the latest "snow leopard" under "windows xp/VMWARE"
    By phil128 in forum OS X - Operating System
    Replies: 2
    Last Post: 11-03-2009, 08:20 PM
  5. Replies: 5
    Last Post: 01-31-2008, 09:14 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts