New To Mac-Forums?

Welcome to our community! Join the discussion today by registering your FREE account. If you have any problems with the registration process, please contact us!

Get your questions answered by community gurus Advice and insight from world-class Apple enthusiasts Exclusive access to members-only contests, giveaways and deals

Join today!

 
Start a Discussion
 

Mac-Forums Brief

Subscribe to Mac-Forums Brief to receive special offers from Mac-Forums partners and sponsors

Join the conversation RSS
OS X - Operating System General OS operation information and support

OS 10.6 - File associations - I give up


Post Reply New Thread Subscribe

 
Thread Tools
tewatson

 
tewatson's Avatar
 
Member Since: Sep 27, 2008
Location: SoCal
Posts: 34
tewatson is on a distinguished road
Mac Specs: iMac C2D 2.66, MBP i5 2.4, MB C2D 2.4, iPad2 32GB 3G

tewatson is offline
OK - how does one change default file associations for Quicktime in SL? Can't for the life of me figure it out and searches here and on the Apple site turn up nothing.

.wmv files try to open in Windows Media Player...it's now the default app in the "Open with" menu. I can set individual files to always open in QT, but how do I set that as a global preference?

Tom
QUOTE Thanks
mrplow

 
mrplow's Avatar
 
Member Since: Oct 01, 2007
Location: UK
Posts: 6,545
mrplow has a reputation beyond reputemrplow has a reputation beyond reputemrplow has a reputation beyond reputemrplow has a reputation beyond reputemrplow has a reputation beyond reputemrplow has a reputation beyond reputemrplow has a reputation beyond reputemrplow has a reputation beyond reputemrplow has a reputation beyond reputemrplow has a reputation beyond reputemrplow has a reputation beyond repute
Mac Specs: 27" iMac i7 (2011) 10.9, iPhone5s, iPad3, AppleTV2

mrplow is offline
Right-click the file, select "Open With...."
Select "Other", choose the app you want to use then tick the "Always Open With" box.

That should set a global default for that file type/app.

External hard disk acquisition addict - but admitting the problem is the first step to a robust backup

Please use the reputation system if you think you've been helped - top right of this post
QUOTE Thanks
Nimraynn

 
Member Since: Aug 24, 2009
Location: SE London, UK
Posts: 53
Nimraynn is on a distinguished road
Mac Specs: Alu iMac 2.4 Core 2 Duo, 4GB memory, 320GB HDD + 750GB Ext HDD

Nimraynn is offline
Quote:
Originally Posted by mrplow View Post
Right-click the file, select "Open With...."
Select "Other", choose the app you want to use then tick the "Always Open With" box.

That should set a global default for that file type/app.
I was using that option on Snow Leopard yesterday, but that for some reason only set the file type association for that individual file, not every file of that type. As I was taught on these forums, right click a file and select "Get Info...". Expand the "Open With" section, select the app and click "Change all..."

That appears to have done it for me.

QUOTE Thanks
tewatson

 
tewatson's Avatar
 
Member Since: Sep 27, 2008
Location: SoCal
Posts: 34
tewatson is on a distinguished road
Mac Specs: iMac C2D 2.66, MBP i5 2.4, MB C2D 2.4, iPad2 32GB 3G

tewatson is offline
That only sets it for each individual file. There is a menu that pops up on a right-click and "Open With", listing WMP (Default) and QT. This menu reflects the WMP global default and does not change, regardless of what settings I fiddle with. There is no "Change All" option.

Any other ideas?

Tom
QUOTE Thanks
bobtomay

 
bobtomay's Avatar
 
Member Since: Dec 22, 2006
Location: Texas, where else?
Posts: 24,597
bobtomay has a reputation beyond reputebobtomay has a reputation beyond reputebobtomay has a reputation beyond reputebobtomay has a reputation beyond reputebobtomay has a reputation beyond reputebobtomay has a reputation beyond reputebobtomay has a reputation beyond reputebobtomay has a reputation beyond reputebobtomay has a reputation beyond reputebobtomay has a reputation beyond reputebobtomay has a reputation beyond repute
Mac Specs: 15" MBP 2.33 C2D 256 4GB, MBA 13" i7 1.8, MB 2.0 2GB, Nano 4th, 3GS, iPad 1

bobtomay is offline
Option 1.
Right click and select 'Get Info' on any wmv file

Then in the Open With section select QuickTime Player.app
If that file already has QuickTime selected, change it to something else - any other option and then change it back to QuickTime.
Then click on the 'Change All...' button.




Option 2.
Right click and select 'Open With' > 'Other'
In that window scroll until you find QuickTime Player.app and select it
Then place a checkmark in 'Always Open With'




And if you can't do it now, there's no help.

I cannot be held responsible for the things that come out of my mouth.
In the Windows world, most everything folks don't understand is called a virus.
QUOTE Thanks
DarkestRitual

 
Member Since: Apr 09, 2009
Location: Ithaca NY
Posts: 2,073
DarkestRitual is just really niceDarkestRitual is just really niceDarkestRitual is just really niceDarkestRitual is just really nice
Mac Specs: 13 inch alMacBook 2GHz C2D 4G DDR3, 1.25GHz G4 eMac

DarkestRitual is offline
OR as suggested, highlight a file... hit command I - select "open with" - and then check th ebox that says "always open files of this type with..." or something similar
QUOTE Thanks
Kash

 
Kash's Avatar
 
Member Since: Dec 03, 2006
Location: Irvine, CA
Posts: 9,385
Kash has a brilliant futureKash has a brilliant futureKash has a brilliant futureKash has a brilliant futureKash has a brilliant futureKash has a brilliant futureKash has a brilliant futureKash has a brilliant futureKash has a brilliant futureKash has a brilliant futureKash has a brilliant future
Mac Specs: Black Macbook C2D 2GHz 3GB RAM 250GB HD iPhone 4 iPad 3G

Kash is offline
Quote:
Originally Posted by tewatson View Post
That only sets it for each individual file. There is a menu that pops up on a right-click and "Open With", listing WMP (Default) and QT. This menu reflects the WMP global default and does not change, regardless of what settings I fiddle with. There is no "Change All" option.

Any other ideas?

Tom
You clearly didn't read the instructions carefully enough. Nobody is telling you to select "Open With" from the right click menu, they're telling you to click on "Get Info" and then look for "Open With."


June 2007
July 2009
QUOTE Thanks
tewatson

 
tewatson's Avatar
 
Member Since: Sep 27, 2008
Location: SoCal
Posts: 34
tewatson is on a distinguished road
Mac Specs: iMac C2D 2.66, MBP i5 2.4, MB C2D 2.4, iPad2 32GB 3G

tewatson is offline
Quote:
Originally Posted by Kash View Post
You clearly didn't read the instructions carefully enough. Nobody is telling you to select "Open With" from the right click menu
Uh...I read just fine, and tell me again what the following reply didn't say...?

Quote:
Originally Posted by mrplow View Post
Right-click the file, select "Open With...."
My point was that no matter what I did, the default setting indicated through a right-click, open with, was always WMP... Bobtomay's procedure worked - thank you for that.

Tom
QUOTE Thanks
bobtomay

 
bobtomay's Avatar
 
Member Since: Dec 22, 2006
Location: Texas, where else?
Posts: 24,597
bobtomay has a reputation beyond reputebobtomay has a reputation beyond reputebobtomay has a reputation beyond reputebobtomay has a reputation beyond reputebobtomay has a reputation beyond reputebobtomay has a reputation beyond reputebobtomay has a reputation beyond reputebobtomay has a reputation beyond reputebobtomay has a reputation beyond reputebobtomay has a reputation beyond reputebobtomay has a reputation beyond repute
Mac Specs: 15" MBP 2.33 C2D 256 4GB, MBA 13" i7 1.8, MB 2.0 2GB, Nano 4th, 3GS, iPad 1

bobtomay is offline
Quote:
Originally Posted by tewatson View Post
Uh...I read just fine, and tell me again what the following reply didn't say...?

Quote:
Originally Posted by mrplow View Post
Right-click the file, select "Open With...."
....

Tom
I know what it did say - and suggest you might look at it again...

Quote:
Originally Posted by mrplow View Post
Right-click the file, select "Open With...."
Select "Other", choose the app you want to use then tick the "Always Open With" box.

That should set a global default for that file type/app.

Uh...Sorry, but No, you didn't read just fine 'this' time. You stopped short in following mrplow's directions. After the "Open With" he also said to select "Other". There is no difference between his directions and the Option 2 listed in my post. Following mrplows directions would have solved it.

And Nimraynn's method is what is pictured in my Option 1.

I cannot be held responsible for the things that come out of my mouth.
In the Windows world, most everything folks don't understand is called a virus.
QUOTE Thanks

Post Reply New Thread Subscribe


« Minimizing Windows 10.6? | Address book/web "favourites" file retrieval »
Thread Tools

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off
Forum Jump

Similar Threads
Thread
Thread Starter
Forum
Replies
Last Post
Moving mp3's to your Audiobooks folder bobtomay iPod Hardware and Accessories 10 10-10-2009 12:02 PM
Weird file size issue Ramen Tetsujin OS X - Operating System 0 07-21-2009 12:49 PM
PDF file probs Malc50 Switcher Hangout 5 04-10-2008 06:50 PM
File Associations - Change All Not Working!? SunPro02 OS X - Operating System 2 06-28-2007 02:42 PM
ZFS To Become Default File System In Leopard kaidomac Apple Rumors and Reports 21 06-26-2007 02:29 PM

All times are GMT -4. The time now is 11:16 PM.

Powered by vBulletin
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
X

Welcome to Mac-Forums.com

Create your username to jump into the discussion!

New members like you have made this community the ultimate source for your Mac since 2003!


(4 digit year)

Already a member?