I am fairly new to Macs..I just bought mine a few months back and am running 10.2.6 right now. I need to access a website that has JAVA 2 on it (if I update to 10.2.8 will that fix it?). I keep getting an error message that JAVA 2 is not installed. I went through system preferences to update, and I am running 1.4.1 of Java right now. The tech running the other site said that the server runs 1.4.2 so I won;t be able to access it on the Mac?? My PC running windows 2000 does it fine..I was able to get the Java 1.4.2 for that with no problems. Does anyone know if / when 1.4.2 will be available for MAX OS 10.2 ? I heard a rumor that it was coming out for 10.3? If anyone has any information it will be GREATLY appreciated. Thank you!