Mac Forums

Mac Forums (http://www.mac-forums.com/forums/)
-   OS X - Operating System (http://www.mac-forums.com/forums/os-x-operating-system/)
-   -   iMac slowing down (http://www.mac-forums.com/forums/os-x-operating-system/143865-imac-slowing-down.html)

mackenzi1 03-04-2009 06:00 PM

iMac slowing down
 
I have an Intel-based core 2, 2.4 GHz iMac, bought brand new about 15 months ago.

Just recently it seems to have been slowing down, particularly when opening apps, images and using Front Row (movie trailers now take 2 or 3 minutes to buffer before running, where before they ran pretty much instantly).

It has 1 GB 667 MHz of RAM, so I'm puzzled why it should be slowing. I don't use it for anything unusual (just music, internet, mail, photos etc) or download any illegal software.

Any ideas?

MacTrooper 03-05-2009 04:24 PM

How full is the hard drive? Limited HD space will also cause your machine to slow. I saw on another posting info about a program that will tell you how your HD space is being used, but I don't recall the name of it.

mackenzi1 03-06-2009 04:11 PM

Doubt it's the hard drive. Have used 100 GB out of 300 GB - 200 GB still to use. Problem seems to be with videos, even Youtube is now slower.

Thanks for your reply though!

pigoo3 03-06-2009 04:14 PM

Quote:

Originally Posted by mackenzi1 (Post 813936)
I have an Intel-based core 2, 2.4 GHz iMac, bought brand new about 15 months ago.

Just recently it seems to have been slowing down, particularly when opening apps, images and using Front Row (movie trailers now take 2 or 3 minutes to buffer before running, where before they ran pretty much instantly).

It has 1 GB 667 MHz of RAM, so I'm puzzled why it should be slowing. I don't use it for anything unusual (just music, internet, mail, photos etc) or download any illegal software.

Any ideas?

Have you repaired "permissions" lately?

- Nick

richard1098 03-07-2009 02:48 AM

Have you tried defragmenting the disk? I use iDefrag. After 6 months use, defragmenting the drive made a noticeable difference.

scathe 03-07-2009 04:06 AM

Quote:

Originally Posted by mackenzi1 (Post 815004)
Doubt it's the hard drive. Have used 100 GB out of 300 GB - 200 GB still to use. Problem seems to be with videos, even Youtube is now slower.

Thanks for your reply though!

Youtube? Video trailers?(mentioned in the first post) Sounds like you have an internet connection problem, if the videos take a long time to buffer, it's likely you have something eating up your bandwidth

Even though you might not notice it, Front Row trailers are downloaded off the internet.


All times are GMT -4. The time now is 02:33 PM.

Powered by vBulletin
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.