Since i've tried Spaces for the first time i've fallen in love with it, nowadays its a must for the computing part of my life.

But im having some troubles lately. Issues with my superdrive aside, i can't get Leopard to switch between spaces when i switch apps through cmd+tab or even when clicking said app in the dock.

Done my research, tried a couple commands for the terminal but i haven't made an inch of a progress here. Yes, i checked the checkbox in System preference, i have disabled spaces, enabled it; disabled it again, relaunch dock, finder, restart, enabled it again.

This happens with every app, not just one in particularly. I cant really say since when this is happening, maybe yesterday, maybe before. I know it happened before, but cant recall what i did or didn't do to fix it.

Any comments would be much appreciated.

thx in advance.

PS: It changes to the chosen app in the menu bar, it just doesnt switch between spaces. I can switch to a given space with warp or my keyboard shortcut.