New To Mac-Forums?

Welcome to our community! Join the discussion today by registering your FREE account. If you have any problems with the registration process, please contact us!

Get your questions answered by community gurus Advice and insight from world-class Apple enthusiasts Exclusive access to members-only contests, giveaways and deals

Join today!

 
Start a Discussion
 

Mac-Forums Brief

Subscribe to Mac-Forums Brief to receive special offers from Mac-Forums partners and sponsors

Join the conversation RSS
OS X - Operating System General OS operation information and support

640MB enough?!?!


Post Reply New Thread Subscribe

 
Thread Tools
FordGuy
Guest
 
Posts: n/a

Hey All!

Just a quick question. I have a 733 G4 w/ 640MB RAM. I am running Jaguar, and it doesn't seem all that fast to me. I notice it really seems to drag when I'm running IE 5, Mail, MS Word X, iTunes, and AIM. Does it just sound like they are pulling alot of processor power from the puny 733MHz Processor? or would an upgrade of RAM make a difference? I thought putting a 512MB chip in would do a big difference, which it did. Brought it from 128MB and this thing really seemed to fly, of course at that time I didn't like OS X, so I was still using 9.

Any ideas?

Thanks,

Justin
QUOTE Thanks
Emrys

 
Emrys's Avatar
 
Member Since: Oct 27, 2002
Location: Vermont
Posts: 1,345
Emrys is on a distinguished road
Mac Specs: 17" iMac G4 800MHz 1GB RAM

Emrys is offline
I put a gig in my 800 MHz G4, and it works great. Occasionaly I can get it to max out, but for the most part it runs awesome with a GB or RAM. i would recommend doing it. You can get a 512MB PC133 stick of RAM for $78 at MemoryX.net. It is worth every penny. And installing it isn't hard at all. There are instructions on the net somewhere.

My opinion ( as always ) : Max out your RAM with as much as you can possibly afford, you will be happy in the end, and you will never say "Damn, I have too much RAM"

Emrys
Community Administrator / Moderator
MAC-FORUMS.COM - The Ultimate Source For Your Mac!
QUOTE Thanks

Post Reply New Thread Subscribe


« HELP! W-LAN drivers! | executing programs on startup »
Thread Tools

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off
Forum Jump

Similar Threads
Thread
Thread Starter
Forum
Replies
Last Post
900mhz iBook G3, 640MB, 40GB, airport card...LOOK mpeters13 Internet, Networking, and Wireless 1 04-07-2004 11:34 AM

All times are GMT -4. The time now is 03:11 AM.

Powered by vBulletin
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
X

Welcome to Mac-Forums.com

Create your username to jump into the discussion!

New members like you have made this community the ultimate source for your Mac since 2003!


(4 digit year)

Already a member?