Results 1 to 2 of 2
  1. #1

    jimmymac3's Avatar
    Member Since
    Mar 26, 2008
    Unhappy Sloooww internet, have run all fixes, what am I missing?
    My internet has been slowing down over time recently, to where it takes over a minute just to load a page. I've fixed permissions, run Onyx and done everything I know, repeatedly with no success. Is there something I could be missing? My MacBook runs fine on the same wi-fi network. I'd appreciate any input...thanks in advance...

  2. #2

    Member Since
    Feb 03, 2008
    Lately, there has been a lot of issues with DNS servers. I have Time Warner Road Runner, and no matter how much I complained, they are doing jack sht.

    Go to OpenDNS and get their DNS addresses and put them in your router, see if that helps; it helped me but only for a short period to where OpenDNS is also slow.

    Also, try turning off Airport if you're not using it.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. how do get internet explorer to run on mac computer?
    By arcolino in forum OS X - Operating System
    Replies: 9
    Last Post: 01-04-2012, 04:53 AM
  2. How do I run Internet Explorer on a Mac?
    By crazychile in forum Running Windows (or anything else) on your Mac
    Replies: 7
    Last Post: 04-25-2010, 01:02 PM
  3. Replies: 0
    Last Post: 10-22-2009, 12:44 AM
  4. Internet Connect missing!
    By peetaw in forum OS X - Apps and Games
    Replies: 3
    Last Post: 03-05-2008, 12:54 AM
  5. OS Fixes?
    By Verrminator in forum Switcher Hangout
    Replies: 2
    Last Post: 02-13-2005, 07:04 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts