Results 1 to 3 of 3
  1. #1

    Member Since
    Oct 10, 2008
    Invalid B-Tree Node Size
    I have a MacBook which came up with a flashing folder with a question mark last night when I started it.

    I went into disk utility and located my HD after starting the MacBook using the Install CD. However the HD: Disk0s2 was grayed out. I tried repairing the disk but every time I did this, I got a message saying "Invalid B-Tree Node Size". I also tried running fsck as a single user on the drive and got the same message. Now when I go into disk utility, I don't even see my drive anymore. The only thing I see there is the OS X Install Disc.

    I don't have any backups of my drive.

    I've also read that disk warrior may be an option. However, before I went down that route, I wanted to find out if there are any suggestions at all.

    I would very much appreciate any help that anyone can provide.

  2. #2

    louishen's Avatar
    Member Since
    Oct 22, 2007
    Mac Mini Core i7 2012 | White 2009 MacBook 2 Ghz | 733 Mhz G4 Quicksilver
    How old is that macbook?

    You basically have a corrupt disk structure (the disk it self is likely fine but the information about the data structure has gone.

    You will need a boot up disk with disc warrior on it to attempt to rescue that disk, unless you have access to another mac
    Member of the Month September 2008 & August 2012 | Found advice useful? use the rep system

  3. #3

    Member Since
    Oct 10, 2008
    Thanks for the response louishen.

    The MacBook is only a year old.

    I do have a MacBook Pro. How would I go about using the MacBook Pro to rescue my MacBook?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. B-tree node error and Time Machine
    By troverman in forum OS X - Operating System
    Replies: 6
    Last Post: 05-15-2015, 01:47 PM
  2. Invalid B-Tree Node Size Fix Issues.
    By hobobirdtx in forum Other Hardware and Peripherals
    Replies: 5
    Last Post: 07-28-2013, 09:32 PM
  3. Invalid B-tree node size
    By norrab in forum OS X - Operating System
    Replies: 9
    Last Post: 08-25-2010, 07:35 PM
  4. G-Tech External HD "Invalid B-tree node size," won't mount -- HELP!
    By craiginbminor in forum Other Hardware and Peripherals
    Replies: 3
    Last Post: 08-24-2008, 06:14 PM
  5. Invalid B-tree Node Size?? Please help me
    By a1brammer in forum Apple Notebooks
    Replies: 7
    Last Post: 02-08-2006, 08:18 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts