New To Mac-Forums?

Welcome to our community! Join the discussion today by registering your FREE account. If you have any problems with the registration process, please contact us!

Get your questions answered by community gurus Advice and insight from world-class Apple enthusiasts Exclusive access to members-only contests, giveaways and deals

Join today!

 
Start a Discussion
 

Mac-Forums Brief

Subscribe to Mac-Forums Brief to receive special offers from Mac-Forums partners and sponsors

Join the conversation RSS
OS X - Operating System General OS operation information and support

OS 10.5 - FOREIGN LANGUAGE function flips back to English for no apparent reason.


Post Reply New Thread Subscribe

 
Thread Tools
MacMan7

 
Member Since: Aug 23, 2008
Location: Salt Lake City, UT
Posts: 7
MacMan7 is on a distinguished road
Mac Specs: iMac 2GHz, Intel Core Duo; Mac OSX 10.5.4

MacMan7 is offline
When I try to type an entire page in Russian or any other foreign language (in Microsoft WORD) the little flag at the top of the iMac screen flips from the language flag to the American flag every time I move to a new line, or sometimes even while I'm on the same line. Also, if I want to edit a word typed in a foreign language, one would think that a changed letter within the word could be entered in the same language, but not so. Any change appears in English, and I must first click on the appropriate language flag AGAIN to get the correction the way I want it.

I have tried using a Russian font as well as selecting Russian as one of the languages in my preferences. Nothing seems to work for me. And it sure gets tedious to have to return to the language flags 400+ times for every page I want to type.

Is there any setting I can use to lock the language in place?
QUOTE Thanks
Mjc.americor

 
Mjc.americor's Avatar
 
Member Since: Feb 02, 2008
Location: Traverse City MI
Posts: 447
Mjc.americor will become famous soon enough
Mac Specs: 15.4" MacBook Pro 4GB 500GB 2.4Ghz

Mjc.americor is offline
USA english is the default.
After you change the Region settings, down at the bottom the of page in the left hand corner you will see a open or closed lock. After you change your settings, click the lock if its open to close it and the settings will remain the same

15.4" MacBook Pro Unibody
2.4GHz 4GB Ram and 500GB HD nVidia Geforce 9600
QUOTE Thanks
MacMan7

 
Member Since: Aug 23, 2008
Location: Salt Lake City, UT
Posts: 7
MacMan7 is on a distinguished road
Mac Specs: iMac 2GHz, Intel Core Duo; Mac OSX 10.5.4

MacMan7 is offline
Thank you Mjc.americor,
I think we're on the right track. But I can't find anything in System Preferences about "Region," so going any further than that with your instructions is impossible. I'm still a relative novice although I have been using Macs ever since they came out. So what might be a rather simply thing for you to find may be more of a challenge for me.
So where do I go to find the setting for "Region"? Even then I may have to come back to you to walk me through the rest of the process. I appreciate very much your efforts to assist me!
MacMan7
QUOTE Thanks
louishen

 
louishen's Avatar
 
Member Since: Oct 22, 2007
Location: London
Posts: 8,941
louishen has a brilliant futurelouishen has a brilliant futurelouishen has a brilliant futurelouishen has a brilliant futurelouishen has a brilliant futurelouishen has a brilliant futurelouishen has a brilliant futurelouishen has a brilliant futurelouishen has a brilliant futurelouishen has a brilliant futurelouishen has a brilliant future
Mac Specs: Mac Mini Core i7 2012 | White 2009 MacBook 2 Ghz | 733 Mhz G4 Quicksilver

louishen is offline
Are you pressing Command - Space at any time?

That shortcut will cycle through the active languages on the mac

To disable that shortcut, go to system preferences > Keyboard and Mouse and select the keyboard shortcuts tab.

About 3/4 the way down is input menu, you can turn it off there. You might also want to disable Universal Access shortcuts as well (near the top) as they can be accidentally activated and often cause confusion when turned on
QUOTE Thanks
MacMan7

 
Member Since: Aug 23, 2008
Location: Salt Lake City, UT
Posts: 7
MacMan7 is on a distinguished road
Mac Specs: iMac 2GHz, Intel Core Duo; Mac OSX 10.5.4

MacMan7 is offline
Thanks for your reply, louishen,
We must be using different systems. When I press Command-Space the "Spotlight" feature of System OSX10.5.4 shows up in the right-hand corner of the screen. That action does not cycle through the active languages, unfortunately.

As to disabling that shortcut, I don't even see it listed. I did try disabling the Universal Access shortcuts, however, but that didn't solve the problem of the seemingly uncontrolable jumping back and forth of the font from Russian to English. At least I have one more thing to try that didn't work. So thanks for your help in narrowing that list down.
QUOTE Thanks

Post Reply New Thread Subscribe


« HELP! cant modify contense of a program?! | RUSSIAN font has NO PERIOD! »
Thread Tools

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off
Forum Jump

All times are GMT -4. The time now is 08:03 AM.

Powered by vBulletin
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
X

Welcome to Mac-Forums.com

Create your username to jump into the discussion!

New members like you have made this community the ultimate source for your Mac since 2003!


(4 digit year)

Already a member?