I cannot access my Home folder! I'm told that I do not have sufficient privelidges but I'm the Administrator!!! I was browsing the web in Safari when it lost its preferences. I went to the Home folder and couldn't get in so restarted but all I get in the side bar is the unaccessable Home folder & the Apps folder.

In the 'Get Info' window, in 'Ownership & Permissions', 'You Can' is set to No Access and is grey out. 'Owner' is set to system but when I try and change that to my username it goes straight back to system before I can apply it. I also tried setting up a new admin user to try and change the permissions but they are set correctly.

What's also strange is that in the new admin user it shows that I have over 22Gb in my Home folder (consisting of 2 disk images instead of the usual Pictures, Documents etc files) but if I log in as that user it tells me the Home folder is an alias with zero k inside.

I've tried the usuals, fixing permissions, starting in safe mode and admin changing password. I also tried turning File Vault off but after 45 minutes it comes up with an error.

Is this retreivable?