Mac Forums

Mac Forums (http://www.mac-forums.com/forums/)
-   OS X - Operating System (http://www.mac-forums.com/forums/os-x-operating-system/)
-   -   Sleep issues.....that old chestnut (http://www.mac-forums.com/forums/os-x-operating-system/109298-sleep-issues-old-chestnut.html)

mpcengineering 05-22-2008 04:22 AM

Sleep issues.....that old chestnut
 
Ok, so I have sleep problems with a 10.4.11 20" iMac I'm building here, and it just wont go to sleep on its own after the time defined in energy saving. Sleeps fine from the apple menu, wakes up fine in every case, and the monitor switches off with no problems.

So, this seems to be a pretty widespread problem caused by a numerous plethora of issues from what I've read over the last few days. Sometimes it seems to be caused by external usb devices, I can safely say this is not the case as there aren't any usb devices except for the keyboard and mouse. I can also says its not caused by having network connectivity as the symptoms are the same whether there is network connectivity or not.

Unfortunately, I cant be conclusive as to whether or not this particular mac ever actually went to sleep, I can only say that it was highlighted when I installed sleepwatcher and found that the mac was not actually sleeping at all.

In my book, I think the way forward is to start to try and narrow down the processes that are running that might be affecting sleep, so I ran up activity monitor and monitored disk activity on active processes. With sleep time set to 1 min, the time passed with apparently no disk activity, but the mac did not sleep. Same with cpu usage, same with network activity. I left the mac on all night, still didn't sleep...

At this point, I'm a bit stuck as to what to do next to try and narrow down exactly what is causing the sleep issues. I mean it must be a running process, so if I can find this process then I can hopefully find the root of the problem. Anyone have any ideas as to how to continue from here?

Soulwar 05-22-2008 07:51 AM

Have you tried resetting the SMC or SMU? (Depending on your model)

mpcengineering 05-22-2008 08:13 AM

Hi Soulwar, yeah I've already tried that along with a fair bunch of other stuff suggested in other threads, no luck so far. I'm currently sifting through the console and system logs to try and see if there are any clues there....

EDIT: And monitoring the console and system logs over the time that the machine should go to sleep, and for a good half hour afterwards reveals big fat zero entries.......very helpful.

Soulwar 05-22-2008 10:02 AM

Look for corrupt preference files. You can use OnyX. While your at it, run the maintenance programs. (delete caches, etc..)

mpcengineering 05-22-2008 11:50 AM

Well thanks for the suggestions but I've run out of time really now so I had to end up frigging it with a forced sleep in the startup item of sleepwatcher. Works fine, but you just have to remember that the idle time needs to be changed here and doesn't follow the idle time set in the energy save options. This mac is going to be a kiosk mode machine for clients and others to view the company website in our reception area, so for this purpose the solution is acceptable. Thanks for the thoughts anyway.


All times are GMT -4. The time now is 02:23 AM.

Powered by vBulletin
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.