Mac Forums

Mac Forums (http://www.mac-forums.com/forums/)
-   OS X - Operating System (http://www.mac-forums.com/forums/os-x-operating-system/)
-   -   Time Machine Restore - Permissions Issue (http://www.mac-forums.com/forums/os-x-operating-system/104017-time-machine-restore-permissions-issue.html)

JuanGuapo 04-08-2008 01:33 PM

Time Machine Restore - Permissions Issue
 
Hello all...

I'm having a sort of dilemma with Time Machine that I'm hoping someone can answer for me.

We just finished the 23hr restore of our Mac Mini with Time Machine; it was a full restore from the Leopard disc.

The restore went smoothly and finished leaving everything exactly as it was before we did the full restore.

However, I noticed that the permissions are not correct for the Macintosh HD (/) root folder.

When I go to the Macintosh HD and do a Get Info, I notice that it says "You have read only privileges" instead of having read/write privileges.

Furthermore, the groups are set up as...

wheel - read/write
system - read/write
everyone - read only


...there is no "admin" account listed.

I checked my Macbook and it has the following listed...

sytem - read/write
admin - read/write
everyone - read only



I run Repair Permissions in the Disk Utility and after a successful run, I notice that the permissions are still off. So, I have some free time and decide to do a full TM restore on my Macbook, and the permissions are now the same as they are on the Mini..

wheel - read/write
system - read/write
everyone - read only



When I try to change the Macintosh HD icon, it will not let me. When I try to add/remove anything from the root folder, I now need to enter a password to do so.

What is wrong w/ Time Machine?

Thanks for your help.

JG

Specs:

Mac Mini 1.83 Ghz / 1GB / 120GB / Leopard 10.5.2
BlackBook 2.4Ghz / 4GB / 250GB / Leopard 10.5.2

JuanGuapo 04-18-2008 07:09 PM

::bump:: Anyone?

Lifeisabeach 04-18-2008 07:41 PM

There's a couple nifty little apps that may help. Be sure to use these ONLY if you are certain that the existing permission structure is wrong AND you are certain of what they should be. I have used them myself to fix some really buggy permissions problems successfully.

First you can try ACL Fix. This will strip the permissions from any file/folder that you please and hopefully will result in the "correct" default permissions in place. USE AT OWN RISK!!!

Secondly... try iRepair. This will let you set custom group/owner permissions to a file/folder. Again... USE AT OWN RISK!!!

Holler back if you try these and let us know how it worked out.


All times are GMT -4. The time now is 08:33 PM.

Powered by vBulletin
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.