After hooking up my new external hard drive to my macbook, I realized that whenever I put CD-Rs or DVD-Rs in, the "no changes" icon (pencil with a line through it) appears, meaning I can't drag & drop anything from them into the external hard drive, or the desktop, or any folders or anything. This was a problem for me as I wanted to get info from CDs onto my new external hard drive. I messed around with "ownership & permission" and "details" and all that jazz, but nothing worked.

For some reason, it would let me drag stuff into iTunes and iPhoto. I was able to put my movies into iTunes/iPhoto, then get them from there onto my external hard drive.

Took twice as long, but it worked.

Then today I realized that whenever I try to download applications that come in disk images, the no changes icon appears then, too so I can't download most applications.

It also won't me repair permissions in disk utility.

Why is this no changes icon popping up that prevents me from dragging & dropping and what do I do to get rid of it?!